summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2010-09-29 21:17:22 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2010-09-29 21:17:22 +0000
commitd508522457b784cdaf93c8c0890d186ca258ab0c (patch)
tree773416302f01c76a04beced26e4a53d5e2b2829e /gnome-extra/yelp
parentDisable tests with Python 3. (diff)
downloadgentoo-2-d508522457b784cdaf93c8c0890d186ca258ab0c.tar.gz
gentoo-2-d508522457b784cdaf93c8c0890d186ca258ab0c.tar.bz2
gentoo-2-d508522457b784cdaf93c8c0890d186ca258ab0c.zip
Version bump. Include patches from r1, plus i18n updates.
(Portage version: 2.2_rc88/cvs/Linux x86_64)
Diffstat (limited to 'gnome-extra/yelp')
-rw-r--r--gnome-extra/yelp/ChangeLog7
-rw-r--r--gnome-extra/yelp/yelp-2.30.2.ebuild72
2 files changed, 78 insertions, 1 deletions
diff --git a/gnome-extra/yelp/ChangeLog b/gnome-extra/yelp/ChangeLog
index fce72fa7f4e1..b2c558545710 100644
--- a/gnome-extra/yelp/ChangeLog
+++ b/gnome-extra/yelp/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for gnome-extra/yelp
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/yelp/ChangeLog,v 1.242 2010/09/11 18:52:26 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/yelp/ChangeLog,v 1.243 2010/09/29 21:17:22 eva Exp $
+
+*yelp-2.30.2 (29 Sep 2010)
+
+ 29 Sep 2010; Gilles Dartiguelongue <eva@gentoo.org> +yelp-2.30.2.ebuild:
+ Version bump. Include patches from r1, plus i18n updates.
11 Sep 2010; Joseph Jezak <josejx@gentoo.org> yelp-2.30.1-r1.ebuild:
Marked ppc for bug #324077.
diff --git a/gnome-extra/yelp/yelp-2.30.2.ebuild b/gnome-extra/yelp/yelp-2.30.2.ebuild
new file mode 100644
index 000000000000..d281f86e3104
--- /dev/null
+++ b/gnome-extra/yelp/yelp-2.30.2.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/yelp/yelp-2.30.2.ebuild,v 1.1 2010/09/29 21:17:22 eva Exp $
+
+EAPI="2"
+
+inherit autotools eutils gnome2
+
+DESCRIPTION="Help browser for GNOME"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-freebsd ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="beagle lzma"
+
+RDEPEND=">=gnome-base/gconf-2
+ >=app-text/gnome-doc-utils-0.19.1
+ >=x11-libs/gtk+-2.18
+ >=dev-libs/glib-2.16
+ >=dev-libs/libxml2-2.6.5
+ >=dev-libs/libxslt-1.1.4
+ >=x11-libs/startup-notification-0.8
+ >=dev-libs/dbus-glib-0.71
+ beagle? ( || (
+ >=dev-libs/libbeagle-0.3.0
+ =app-misc/beagle-0.2* ) )
+ net-libs/xulrunner:1.9
+ sys-libs/zlib
+ app-arch/bzip2
+ lzma? ( || (
+ app-arch/xz-utils
+ app-arch/lzma-utils ) )
+ >=app-text/rarian-0.7
+ >=app-text/scrollkeeper-9999"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ >=dev-util/intltool-0.35
+ >=dev-util/pkgconfig-0.9
+ gnome-base/gnome-common"
+# If eautoreconf:
+# gnome-base/gnome-common
+
+DOCS="AUTHORS ChangeLog NEWS README TODO"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ --with-gecko=libxul-embedding
+ $(use_enable lzma)"
+
+ if use beagle; then
+ G2CONF="${G2CONF} --with-search=beagle"
+ else
+ G2CONF="${G2CONF} --with-search=basic"
+ fi
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # Fix automagic lzma support, bug #266128
+ epatch "${FILESDIR}/${PN}-2.26.0-automagic-lzma.patch"
+
+ # Fix build with xulrunner-1.9.2
+ epatch "${FILESDIR}/${PN}-2.28.1-system-nspr.patch"
+
+ intltoolize --force --copy --automake || die "intltoolize failed"
+ eautoreconf
+
+ # strip stupid options in configure, see bug #196621
+ sed -i 's|$AM_CFLAGS -pedantic -ansi|$AM_CFLAGS|' configure || die "sed failed"
+}