summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-02-26 16:49:18 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-02-26 16:49:18 +0000
commit98e66ff2d654738ae7e8af3c0fb1851be682d2ff (patch)
treea8f7c604db26128b001b50cde47407664893e47c /gnome-extra
parentMarked ~ppc64 wrt #340455 (diff)
downloadgentoo-2-98e66ff2d654738ae7e8af3c0fb1851be682d2ff.tar.gz
gentoo-2-98e66ff2d654738ae7e8af3c0fb1851be682d2ff.tar.bz2
gentoo-2-98e66ff2d654738ae7e8af3c0fb1851be682d2ff.zip
Set SUPPORT_PYTHON_ABIS (bug #313467).
(Portage version: 2.2.0_alpha25_p8/cvs/Linux x86_64)
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/libgsf/ChangeLog6
-rw-r--r--gnome-extra/libgsf/libgsf-1.14.19.ebuild56
2 files changed, 56 insertions, 6 deletions
diff --git a/gnome-extra/libgsf/ChangeLog b/gnome-extra/libgsf/ChangeLog
index 3ef36e7d8d62..b4ce3b6e8bbf 100644
--- a/gnome-extra/libgsf/ChangeLog
+++ b/gnome-extra/libgsf/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for gnome-extra/libgsf
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/libgsf/ChangeLog,v 1.168 2011/02/24 20:29:41 tomka Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/libgsf/ChangeLog,v 1.169 2011/02/26 16:49:18 arfrever Exp $
+
+ 26 Feb 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ libgsf-1.14.19.ebuild:
+ Set SUPPORT_PYTHON_ABIS (bug #313467).
24 Feb 2011; Thomas Kahle <tomka@gentoo.org> libgsf-1.14.19.ebuild:
x86 stable per bug 353436
diff --git a/gnome-extra/libgsf/libgsf-1.14.19.ebuild b/gnome-extra/libgsf/libgsf-1.14.19.ebuild
index e06826b0fff3..7165b4342360 100644
--- a/gnome-extra/libgsf/libgsf-1.14.19.ebuild
+++ b/gnome-extra/libgsf/libgsf-1.14.19.ebuild
@@ -1,9 +1,12 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/libgsf/libgsf-1.14.19.ebuild,v 1.4 2011/02/24 20:29:41 tomka Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/libgsf/libgsf-1.14.19.ebuild,v 1.5 2011/02/26 16:49:18 arfrever Exp $
-EAPI="2"
+EAPI="3"
GCONF_DEBUG="no"
+PYTHON_DEPEND="python? 2:2.6"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.[45] 3.* *-jython"
inherit autotools eutils gnome2 python multilib
@@ -51,6 +54,10 @@ pkg_setup() {
$(use_with python)
$(use_with gtk gdk-pixbuf)
$(use_with thumbnail gconf)"
+
+ if use python; then
+ python_pkg_setup
+ fi
}
src_prepare() {
@@ -68,6 +75,9 @@ src_prepare() {
# Fix build with FEATURES="stricter"
epatch "${FILESDIR}/${PN}-1.14.19-missing-declaration.patch"
+ # Python bindings are built/installed manually.
+ sed -e "/SUBDIRS += python/d" -i Makefile.am
+
intltoolize --force --copy --automake || die "intltoolize failed"
eautoreconf
@@ -76,6 +86,39 @@ src_prepare() {
ln -s $(type -P true) py-compile
}
+src_compile() {
+ gnome2_src_compile
+
+ if use python; then
+ python_copy_sources python
+
+ building() {
+ emake \
+ PYTHON_INCLUDES="-I$(python_get_includedir)" \
+ pyexecdir="$(python_get_sitedir)" \
+ pythondir="$(python_get_sitedir)"
+ }
+ python_execute_function -s --source-dir python building
+ fi
+}
+
+src_install() {
+ gnome2_src_install
+
+ if use python; then
+ installation() {
+ emake \
+ DESTDIR="${D}" \
+ pyexecdir="$(python_get_sitedir)" \
+ pythondir="$(python_get_sitedir)" \
+ install
+ }
+ python_execute_function -s --source-dir python installation
+
+ python_clean_installation_image
+ fi
+}
+
pkg_preinst() {
gnome2_pkg_preinst
preserve_old_lib /usr/$(get_libdir)/libgsf-1.so.1
@@ -84,9 +127,9 @@ pkg_preinst() {
pkg_postinst() {
gnome2_pkg_postinst
+
if use python; then
- python_need_rebuild
- python_mod_optimize $(python_get_sitedir)/gsf
+ python_mod_optimize gsf
fi
preserve_old_lib_notify /usr/$(get_libdir)/libgsf-1.so.1
@@ -95,5 +138,8 @@ pkg_postinst() {
pkg_postrm() {
gnome2_pkg_postrm
- python_mod_cleanup /usr/$(get_libdir)/python*/site-packages/gsf
+
+ if use python; then
+ python_mod_cleanup gsf
+ fi
}