summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Hadaway <raker@gentoo.org>2002-07-27 02:43:17 +0000
committerNick Hadaway <raker@gentoo.org>2002-07-27 02:43:17 +0000
commite98ea39cd1eebe0a07c4911a7f2f10da19e50ef4 (patch)
tree81f56cf1b05dc855114c14e2f17aca36e50e74d8 /gnome-extra
parentadded mask for new version of libgda. (diff)
downloadgentoo-2-e98ea39cd1eebe0a07c4911a7f2f10da19e50ef4.tar.gz
gentoo-2-e98ea39cd1eebe0a07c4911a7f2f10da19e50ef4.tar.bz2
gentoo-2-e98ea39cd1eebe0a07c4911a7f2f10da19e50ef4.zip
Updated to latest version of libgda. This version no longer requires any patches to compile and has dropped LDAP support.
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/libgda/ChangeLog9
-rw-r--r--gnome-extra/libgda/files/digest-libgda-0.8.1921
-rw-r--r--gnome-extra/libgda/libgda-0.8.192.ebuild96
3 files changed, 105 insertions, 1 deletions
diff --git a/gnome-extra/libgda/ChangeLog b/gnome-extra/libgda/ChangeLog
index 11698f96dcf0..5984037f6bb6 100644
--- a/gnome-extra/libgda/ChangeLog
+++ b/gnome-extra/libgda/ChangeLog
@@ -1,7 +1,14 @@
# ChangeLog for gnome-extra/libgda
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/libgda/ChangeLog,v 1.5 2002/07/25 04:14:27 spider Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/libgda/ChangeLog,v 1.6 2002/07/27 02:43:17 raker Exp $
+*libgda-0.8.192 (26 Jul 2002)
+
+ 26 Jul 2002; Nick Hadaway <raker@gentoo.org>
+ libgda-0.8.192.ebuild, files/digest-libgda-0.8.192 :
+
+ Updated to latest version of libgda. This version no longer requires
+ any patches to compile and has dropped LDAP support.
25 Jul 2002; Spider <spider@gentoo.org>
SLOT KEYWORDS and LICENSE added
diff --git a/gnome-extra/libgda/files/digest-libgda-0.8.192 b/gnome-extra/libgda/files/digest-libgda-0.8.192
new file mode 100644
index 000000000000..e708991907a3
--- /dev/null
+++ b/gnome-extra/libgda/files/digest-libgda-0.8.192
@@ -0,0 +1 @@
+MD5 5a532ee249e1e4fcc0267840064e9de2 libgda-0.8.192.tar.gz 825508
diff --git a/gnome-extra/libgda/libgda-0.8.192.ebuild b/gnome-extra/libgda/libgda-0.8.192.ebuild
new file mode 100644
index 000000000000..1a08fee047d6
--- /dev/null
+++ b/gnome-extra/libgda/libgda-0.8.192.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/libgda/libgda-0.8.192.ebuild,v 1.1 2002/07/27 02:43:17 raker Exp $
+
+inherit gnome2
+
+S=${WORKDIR}/${P}
+DESCRIPTION="gda library"
+SRC_URI="ftp://ftp.gnome-db.org/pub/gnome-db/sources/v0.8.192/${P}.tar.gz
+ ftp://ftp.gnome.org/pub/gnome/2.0.0/sources/${PN}/${P}.tar.gz"
+HOMEPAGE="http://www.gnome.org/gnome-db"
+SLOT="0"
+LICENSE="GPL-2 LGPL-2"
+KEYWORDS="x86"
+
+DEPEND=">=dev-libs/glib-2.0.4
+ >=x11-libs/gtk+-2.0.5
+ >=dev-libs/libxml2-2.4.23
+ >=gnome-base/ORBit-0.5.16
+ >=gnome-base/oaf-0.6.8
+ >=gnome-base/gconf-1.2.0
+ mysql? ( >=dev-db/mysql-3.23.51 )
+ postgres? ( >=dev-db/postgresql-7.2.1 )
+ odbc? ( >=dev-db/unixODBC-2.0.6 )
+ sqlite? ( >=dev-db/sqlite-2.4.2 )"
+
+src_compile() {
+
+ local myconf
+
+ if [ "`use mysql`" ]
+ then
+ myconf="--with-mysql=/usr"
+ else
+ myconf="--without-mysql"
+ fi
+
+ if [ "`use postgres`" ]
+ then
+ myconf="$myconf --with-postgres=/usr"
+ else
+ myconf="$myconf --without-postgres"
+ fi
+
+ if [ "`use odbc`" ]
+ then
+ myconf="$myconf --with-odbc"
+ else
+ myconf="$myconf --without-odbc"
+ fi
+
+ if [ "`use sqlite`" ]
+ then
+ myconf="$myconf --with-sqlite=/usr"
+ else
+ myconf="$myconf --without-sqlite"
+ fi
+
+ econf $myconf || die "configure failed"
+
+ # Doesn't work with -j 4 (hallski)
+ make LDFLAGS="-lncurses" LIBREADLINE="-lreadline -lncurses" \
+ || die "make failed"
+}
+
+src_install() {
+
+ cd ${S}/doc
+ cp Makefile Makefile.old
+ sed -e "s:scrollkeeper-update.*::g" Makefile.old > Makefile
+ rm Makefile.old
+ cd ${S}
+
+ make prefix=${D}/usr \
+ sysconfdir=${D}/etc \
+ localstatedir=${D}/var/lib \
+ INSTALLMAN3DIR=${D}/usr/share/man/man3 \
+ GDA_oafinfodir=${D}/usr/share/oaf \
+ idldir=${D}/usr/share/idl/libgda \
+ dtddir=${D}/usr/share/libgda/dtd \
+ datadir=${D}/usr/share \
+ install || die
+
+ dodoc AUTHORS COPYING.* ChangeLog NEWS README
+}
+
+pkg_postinst() {
+ echo ">>> Updating Scrollkeeper database..."
+ scrollkeeper-update >/dev/null 2>&1
+}
+
+pkg_postrm() {
+ echo ">>> Updating Scrollkeeper database..."
+ scrollkeeper-update >/dev/null 2>&1
+}
+