summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Gryniewicz <dang@gentoo.org>2007-06-14 17:28:11 +0000
committerDaniel Gryniewicz <dang@gentoo.org>2007-06-14 17:28:11 +0000
commitea1b4cbcede9e395bd944056f1d23b4cc4c51917 (patch)
treec0c59e694f2daed5b0ce6dbffb84caa7b503d1d0 /gnome-extra
parentalpha stable wrt #163113 (diff)
downloadgentoo-2-ea1b4cbcede9e395bd944056f1d23b4cc4c51917.tar.gz
gentoo-2-ea1b4cbcede9e395bd944056f1d23b4cc4c51917.tar.bz2
gentoo-2-ea1b4cbcede9e395bd944056f1d23b4cc4c51917.zip
Add fix for IMAP overflow; bug #182011
(Portage version: 2.1.2.9)
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/evolution-data-server/ChangeLog13
-rw-r--r--gnome-extra/evolution-data-server/evolution-data-server-1.10.1-r3.ebuild144
-rw-r--r--gnome-extra/evolution-data-server/evolution-data-server-1.6.2-r1.ebuild110
-rw-r--r--gnome-extra/evolution-data-server/evolution-data-server-1.8.3-r5.ebuild162
-rw-r--r--gnome-extra/evolution-data-server/files/digest-evolution-data-server-1.10.1-r33
-rw-r--r--gnome-extra/evolution-data-server/files/digest-evolution-data-server-1.6.2-r13
-rw-r--r--gnome-extra/evolution-data-server/files/digest-evolution-data-server-1.8.3-r53
-rw-r--r--gnome-extra/evolution-data-server/files/evolution-data-server-1.10.1-imap-overflow.patch21
8 files changed, 458 insertions, 1 deletions
diff --git a/gnome-extra/evolution-data-server/ChangeLog b/gnome-extra/evolution-data-server/ChangeLog
index b1e210f408ce..9c4e3a2dbedf 100644
--- a/gnome-extra/evolution-data-server/ChangeLog
+++ b/gnome-extra/evolution-data-server/ChangeLog
@@ -1,6 +1,17 @@
# ChangeLog for gnome-extra/evolution-data-server
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/evolution-data-server/ChangeLog,v 1.124 2007/06/02 03:27:37 leio Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/evolution-data-server/ChangeLog,v 1.125 2007/06/14 17:28:11 dang Exp $
+
+*evolution-data-server-1.10.1-r3 (14 Jun 2007)
+*evolution-data-server-1.8.3-r5 (14 Jun 2007)
+*evolution-data-server-1.6.2-r1 (14 Jun 2007)
+
+ 14 Jun 2007; Daniel Gryniewicz <dang@gentoo.org>
+ +files/evolution-data-server-1.10.1-imap-overflow.patch,
+ +evolution-data-server-1.6.2-r1.ebuild,
+ +evolution-data-server-1.8.3-r5.ebuild,
+ +evolution-data-server-1.10.1-r3.ebuild:
+ Add fix for IMAP overflow; bug #182011
02 Jun 2007; <leio@gentoo.org> -evolution-data-server-1.8.2.ebuild,
-evolution-data-server-1.8.3.ebuild,
diff --git a/gnome-extra/evolution-data-server/evolution-data-server-1.10.1-r3.ebuild b/gnome-extra/evolution-data-server/evolution-data-server-1.10.1-r3.ebuild
new file mode 100644
index 000000000000..dc05db4ba571
--- /dev/null
+++ b/gnome-extra/evolution-data-server/evolution-data-server-1.10.1-r3.ebuild
@@ -0,0 +1,144 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/evolution-data-server/evolution-data-server-1.10.1-r3.ebuild,v 1.1 2007/06/14 17:28:11 dang Exp $
+
+inherit db-use eutils flag-o-matic gnome2 autotools
+
+DESCRIPTION="Evolution groupware backend"
+HOMEPAGE="http://www.gnome.org/projects/evolution/"
+
+LICENSE="LGPL-2 Sleepycat"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="doc ipv6 kerberos keyring krb4 ldap ssl"
+
+RDEPEND=">=dev-libs/glib-2.10
+ >=gnome-base/libbonobo-2.4.2
+ >=gnome-base/orbit-2.9.8
+ >=gnome-base/libgnomeui-2
+ >=gnome-base/gnome-vfs-2
+ >=gnome-base/libgnome-2
+ >=gnome-base/gnome-common-2
+ keyring? ( gnome-base/gnome-keyring )
+ >=dev-libs/libxml2-2
+ >=gnome-base/gconf-2
+ >=x11-libs/gtk+-2
+ >=gnome-base/libglade-2
+ >=net-libs/libsoup-2.2.90
+ sys-libs/zlib
+ =sys-libs/db-4*
+ ldap? ( >=net-nds/openldap-2.0 )
+ ssl? (
+ >=dev-libs/nspr-4.4
+ >=dev-libs/nss-3.9 )
+ kerberos? ( virtual/krb5 )
+ krb4? ( virtual/krb5 )"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9
+ >=dev-util/intltool-0.35.5
+ doc? ( >=dev-util/gtk-doc-1.4 )"
+
+DOCS="ChangeLog MAINTAINERS NEWS TODO"
+
+RESTRICT="confcache"
+
+pkg_setup() {
+ G2CONF="$(use_with ldap openldap) \
+ $(use_with kerberos krb5 /usr) \
+ $(use_enable ssl nss) \
+ $(use_enable ssl smime) \
+ $(use_enable ipv6) \
+ $(use_enable keyring gnome-keyring) \
+ --with-libdb=/usr/$(get_libdir)"
+
+ if use krb4 && ! built_with_use virtual/krb5 krb4; then
+ ewarn
+ ewarn "In order to add kerberos 4 support, you have to emerge"
+ ewarn "virtual/krb5 with the 'krb4' USE flag enabled as well."
+ ewarn
+ ewarn "Skipping for now."
+ ewarn
+ G2CONF="${G2CONF} --without-krb4"
+ else
+ G2CONF="${G2CONF} $(use_with krb4 krb4 /usr)"
+ fi
+}
+
+src_unpack() {
+ gnome2_src_unpack
+
+ # Fix what ?
+ epatch ${FILESDIR}/${PN}-1.2.0-gentoo_etc_services.patch
+
+ # Fix broken libdb build
+ epatch "${FILESDIR}"/${PN}-1.7.3-libdb.patch
+
+ # Resolve symbols at execution time for setgid binaries
+ epatch "${FILESDIR}"/${PN}-no_lazy_bindings.patch
+
+ # Rewind in camel-disco-diary to fix a crash
+ epatch "${FILESDIR}"/${PN}-1.8.0-camel-rewind.patch
+
+ # Fix vulnerability in APOP authentification; bug #174210
+ epatch "${FILESDIR}"/${PN}-APOP-auth-fix.patch
+
+ # Fix vulnerability in IMAP; bug #182011
+ epatch "${FILESDIR}"/${PN}-1.10.1-imap-overflow.patch
+
+#-------------Upstream GNOME look here -----------------#
+
+ # --as-needed fixes
+ epatch "${FILESDIR}"/${PN}-1.9.91-as-needed.patch
+
+ # fix for dep ordering so we can add libedataserverui to libexchange-storage
+ # we need to do this or: undefined reference to `e_passwords_get_password'
+ # are the kinds of errors you will get.
+
+ # move the groupwise backend and provider for addressbook, camel, and
+ # calendar to its own folder called server.deps.
+ mkdir server.deps
+ mv addressbook/backends/groupwise server.deps/addressbook
+ mv camel/providers/groupwise server.deps/camel
+ mv calendar/backends/groupwise server.deps/calendar
+
+ # now fix the autotools foo for the new directory and the removed ones
+ echo "SUBDIRS = addressbook camel calendar" > server.deps/Makefile.am
+
+ # remove groupwise folder from Makefile's since they are in a diff location
+ sed -i -e 's: groupwise::' addressbook/backends/Makefile.am camel/providers/Makefile.am calendar/backends/Makefile.am
+
+ # fix configure.in location of the Makefile's
+ sed -i -e 's:addressbook/backends/groupwise:server.deps/addressbook:' configure.in
+ sed -i -e 's:camel/providers/groupwise:server.deps/camel:' configure.in
+ # tack on the server.deps Makefile on our last edit
+ sed -i -e 's:calendar/backends/groupwise:server.deps/calendar/Makefile\nserver.deps:' configure.in
+
+ # fix file includes
+ sed -i -e 's:<backends/groupwise/e-book-backend-groupwise.h>:"server.deps/addressbook/e-book-backend-groupwise.h":' addressbook/libedata-book/e-data-book-factory.c
+
+ # Fix db version for FreeBSD users where -ldb is always db-1
+ sed -i -e "s:-ldb:-l$(db_libname):" configure.in
+
+#---------------Upstream GNOME stop here---------------
+ eautoreconf
+}
+
+src_compile() {
+ # Use NSS/NSPR only if 'ssl' is enabled.
+ if use ssl ; then
+ sed -i -e "s|mozilla-nss|nss|
+ s|mozilla-nspr|nspr|" ${S}/configure
+ G2CONF="${G2CONF} --enable-nss=yes"
+ else
+ G2CONF="${G2CONF} --without-nspr-libs --without-nspr-includes \
+ --without-nss-libs --without-nss-includes"
+ fi
+
+ # /usr/include/db.h is always db-1 on FreeBSD
+ # so include the right dir in CPPFLAGS
+ append-cppflags "-I$(db_includedir)"
+
+ cd "${S}"
+ gnome2_src_compile
+}
diff --git a/gnome-extra/evolution-data-server/evolution-data-server-1.6.2-r1.ebuild b/gnome-extra/evolution-data-server/evolution-data-server-1.6.2-r1.ebuild
new file mode 100644
index 000000000000..248382a3db64
--- /dev/null
+++ b/gnome-extra/evolution-data-server/evolution-data-server-1.6.2-r1.ebuild
@@ -0,0 +1,110 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/evolution-data-server/evolution-data-server-1.6.2-r1.ebuild,v 1.1 2007/06/14 17:28:11 dang Exp $
+
+inherit eutils gnome2
+
+DESCRIPTION="Evolution groupware backend"
+HOMEPAGE="http://www.ximian.com/"
+
+LICENSE="LGPL-2 Sleepycat"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc ipv6 kerberos krb4 ldap nntp ssl"
+
+RDEPEND=">=dev-libs/glib-2.4
+ >=gnome-base/libbonobo-2.4.2
+ >=gnome-base/orbit-2.9.8
+ >=gnome-base/libgnomeui-2
+ >=gnome-base/gnome-vfs-2
+ >=gnome-base/libgnome-2
+ >=dev-libs/libxml2-2
+ >=gnome-base/gconf-2
+ >=x11-libs/gtk+-2
+ >=gnome-base/libglade-2
+ >=net-libs/libsoup-2.2
+ sys-libs/zlib
+ ldap? ( >=net-nds/openldap-2.0 )
+ ssl? (
+ >=dev-libs/nspr-4.4
+ >=dev-libs/nss-3.9 )
+ kerberos? ( virtual/krb5 )
+ krb4? ( virtual/krb5 )"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9
+ >=dev-util/intltool-0.28
+ doc? ( >=dev-util/gtk-doc-1.4 )"
+
+MAKEOPTS="${MAKEOPTS} -j1"
+DOCS="ChangeLog MAINTAINERS NEWS TODO"
+
+RESTRICT="confcache"
+
+pkg_setup() {
+ G2CONF="$(use_with ldap openldap) \
+ $(use_with kerberos krb5 /usr) \
+ $(use_enable ssl nss) \
+ $(use_enable ssl smime) \
+ $(use_enable ipv6) \
+ $(use_enable nntp)"
+
+ if use krb4 && ! built_with_use virtual/krb5 krb4; then
+ ewarn
+ ewarn "In order to add kerberos 4 support, you have to emerge"
+ ewarn "virtual/krb5 with the 'krb4' USE flag enabled as well."
+ ewarn
+ ewarn "Skipping for now."
+ ewarn
+ G2CONF="${G2CONF} --without-krb4"
+ else
+ G2CONF="${G2CONF} $(use_with krb4 krb4 /usr)"
+ fi
+}
+
+src_unpack() {
+ unpack "${A}"
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${PN}-1.2.0-gentoo_etc_services.patch
+
+ # Fix calandar crashing, bug #86174
+ epatch "${FILESDIR}"/${PN}-1.4.2.1-calandar-crash-fix.patch
+
+ # Resolve symbols at execution time for setgid binaries
+ epatch "${FILESDIR}"/${PN}-no_lazy_bindings.patch
+
+ # Fix vulnerability in IMAP; bug #182011
+ epatch "${FILESDIR}"/${PN}-1.10.1-imap-overflow.patch
+
+ sed -n -e '/GNOME_COMPILE_WARNINGS/,/dnl IT_PROG_INTLTOOL/p' \
+ aclocal.m4 > gnome.m4
+ export WANT_AUTOMAKE=1.9
+ aclocal -I . || die "aclocal failed"
+ automake || die "automake failed"
+}
+
+src_compile() {
+ # Use NSS/NSPR only if 'ssl' is enabled.
+ if use ssl ; then
+ NSS_LIB=/usr/$(get_libdir)/nss
+ NSS_INC=/usr/include/nss
+ NSPR_LIB=/usr/$(get_libdir)/nspr
+ NSPR_INC=/usr/include/nspr
+
+ G2CONF="${G2CONF} \
+ --with-nspr-includes=${NSPR_INC} \
+ --with-nspr-libs=${NSPR_LIB} \
+ --with-nss-includes=${NSS_INC} \
+ --with-nss-libs=${NSS_LIB}"
+ else
+ G2CONF="${G2CONF} --without-nspr-libs --without-nspr-includes \
+ --without-nss-libs --without-nss-includes"
+ fi
+
+ cd "${S}/libdb/dist"
+ ./s_config || die
+
+ cd "${S}"
+ gnome2_src_compile
+}
diff --git a/gnome-extra/evolution-data-server/evolution-data-server-1.8.3-r5.ebuild b/gnome-extra/evolution-data-server/evolution-data-server-1.8.3-r5.ebuild
new file mode 100644
index 000000000000..a2af578e9949
--- /dev/null
+++ b/gnome-extra/evolution-data-server/evolution-data-server-1.8.3-r5.ebuild
@@ -0,0 +1,162 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/evolution-data-server/evolution-data-server-1.8.3-r5.ebuild,v 1.1 2007/06/14 17:28:11 dang Exp $
+
+WANT_AUTOMAKE="1.9"
+WANT_AUTOCONF="latest"
+inherit db-use eutils flag-o-matic gnome2 autotools
+
+DESCRIPTION="Evolution groupware backend"
+HOMEPAGE="http://www.gnome.org/projects/evolution/"
+
+LICENSE="LGPL-2 Sleepycat"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="doc ipv6 kerberos keyring krb4 ldap nntp ssl"
+
+RDEPEND=">=dev-libs/glib-2.4
+ >=gnome-base/libbonobo-2.4.2
+ >=gnome-base/orbit-2.9.8
+ >=gnome-base/libgnomeui-2
+ >=gnome-base/gnome-vfs-2
+ >=gnome-base/libgnome-2
+ >=gnome-base/gnome-common-2
+ keyring? ( gnome-base/gnome-keyring )
+ >=dev-libs/libxml2-2
+ >=gnome-base/gconf-2
+ >=x11-libs/gtk+-2
+ >=gnome-base/libglade-2
+ >=net-libs/libsoup-2.2.90
+ sys-libs/zlib
+ =sys-libs/db-4*
+ ldap? ( >=net-nds/openldap-2.0 )
+ ssl? (
+ >=dev-libs/nspr-4.4
+ >=dev-libs/nss-3.9 )
+ kerberos? ( virtual/krb5 )
+ krb4? ( virtual/krb5 )"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9
+ >=dev-util/intltool-0.35
+ doc? ( >=dev-util/gtk-doc-1.4 )"
+
+MAKEOPTS="${MAKEOPTS} -j1"
+DOCS="ChangeLog MAINTAINERS NEWS TODO"
+
+RESTRICT="confcache"
+
+pkg_setup() {
+ G2CONF="$(use_with ldap openldap) \
+ $(use_with kerberos krb5 /usr) \
+ $(use_enable ssl nss) \
+ $(use_enable ssl smime) \
+ $(use_enable ipv6) \
+ $(use_enable nntp) \
+ $(use_enable keyring gnome-keyring) \
+ --with-libdb=/usr/$(get_libdir)"
+
+ if use krb4 && ! built_with_use virtual/krb5 krb4; then
+ ewarn
+ ewarn "In order to add kerberos 4 support, you have to emerge"
+ ewarn "virtual/krb5 with the 'krb4' USE flag enabled as well."
+ ewarn
+ ewarn "Skipping for now."
+ ewarn
+ G2CONF="${G2CONF} --without-krb4"
+ else
+ G2CONF="${G2CONF} $(use_with krb4 krb4 /usr)"
+ fi
+}
+
+src_unpack() {
+ gnome2_src_unpack
+
+ epatch "${FILESDIR}"/${PN}-1.2.0-gentoo_etc_services.patch
+
+ # Fix broken libdb build
+ epatch "${FILESDIR}"/${PN}-1.7.3-libdb.patch
+
+ # Resolve symbols at execution time for setgid binaries
+ epatch "${FILESDIR}"/${PN}-no_lazy_bindings.patch
+
+ # exchange-storage --as-needed fixes
+ epatch "${FILESDIR}"/${PN}-1.7.3-exchange-storage.patch
+ epatch "${FILESDIR}"/${PN}-1.7.4-move-subdirs.patch
+
+ # Rewind in camel-disco-diary to fix a crash
+ epatch "${FILESDIR}"/${PN}-1.8.0-camel-rewind.patch
+
+ # Fix non-english contact insertion. Upstream bug:
+ # http://bugzilla.gnome.org/show_bug.cgi?id=405531
+ epatch "${FILESDIR}"/${P}-category.patch
+
+ # Fix DST changes; bug #172835
+ epatch "${FILESDIR}"/${P}-dst.patch.gz
+
+ # Fix vulnerability in APOP authentification; bug #174210
+ epatch "${FILESDIR}"/${PN}-APOP-auth-fix.patch
+
+ # Fix vulnerability in IMAP; bug #182011
+ epatch "${FILESDIR}"/${PN}-1.10.1-imap-overflow.patch
+
+#-------------Upstream GNOME look here -----------------#
+
+ # fix for dep ordering so we can add libedataserverui to libexchange-storage
+ # we need to do this or: undefined reference to `e_passwords_get_password'
+ # are the kinds of errors you will get.
+
+ # move the groupwise backend and provider for addressbook, camel, and
+ # calendar to its own folder called server.deps.
+ mkdir server.deps
+ mv addressbook/backends/groupwise server.deps/addressbook
+ mv camel/providers/groupwise server.deps/camel
+ mv calendar/backends/groupwise server.deps/calendar
+
+ # now fix the autotools foo for the new directory and the removed ones
+ echo "SUBDIRS = addressbook camel calendar" > server.deps/Makefile.am
+
+ # remove groupwise folder from Makefile's since they are in a diff location
+ sed -i -e 's: groupwise::' addressbook/backends/Makefile.am camel/providers/Makefile.am calendar/backends/Makefile.am
+
+ # fix configure.in location of the Makefile's
+ sed -i -e 's:addressbook/backends/groupwise:server.deps/addressbook:' configure.in
+ sed -i -e 's:camel/providers/groupwise:server.deps/camel:' configure.in
+ # tack on the server.deps Makefile on our last edit
+ sed -i -e 's:calendar/backends/groupwise:server.deps/calendar/Makefile\nserver.deps:' configure.in
+
+ # fix file includes
+ sed -i -e 's:<backends/groupwise/e-book-backend-groupwise.h>:"server.deps/addressbook/e-book-backend-groupwise.h":' addressbook/libedata-book/e-data-book-factory.c
+
+ # Fix db version for FreeBSD users where -ldb is always db-1
+ sed -i -e "s:-ldb:-l$(db_libname):" configure.in
+
+#---------------Upstream GNOME stop here---------------
+ eautoreconf
+}
+
+src_compile() {
+ # Use NSS/NSPR only if 'ssl' is enabled.
+ if use ssl ; then
+ NSS_LIB=/usr/$(get_libdir)/nss
+ NSS_INC=/usr/include/nss
+ NSPR_LIB=/usr/$(get_libdir)/nspr
+ NSPR_INC=/usr/include/nspr
+
+ G2CONF="${G2CONF} \
+ --with-nspr-includes=${NSPR_INC} \
+ --with-nspr-libs=${NSPR_LIB} \
+ --with-nss-includes=${NSS_INC} \
+ --with-nss-libs=${NSS_LIB}"
+ else
+ G2CONF="${G2CONF} --without-nspr-libs --without-nspr-includes \
+ --without-nss-libs --without-nss-includes"
+ fi
+
+ # /usr/include/db.h is always db-1 on FreeBSD
+ # so include the right dir in CPPFLAGS
+ append-cppflags "-I$(db_includedir)"
+
+ cd "${S}"
+ gnome2_src_compile
+}
diff --git a/gnome-extra/evolution-data-server/files/digest-evolution-data-server-1.10.1-r3 b/gnome-extra/evolution-data-server/files/digest-evolution-data-server-1.10.1-r3
new file mode 100644
index 000000000000..031700144864
--- /dev/null
+++ b/gnome-extra/evolution-data-server/files/digest-evolution-data-server-1.10.1-r3
@@ -0,0 +1,3 @@
+MD5 1175bf76756009975f684116e76638c3 evolution-data-server-1.10.1.tar.bz2 7120388
+RMD160 edf55c74c458ed849635ace52340615017ad6a6d evolution-data-server-1.10.1.tar.bz2 7120388
+SHA256 289a541974fb37ed3e2392b19fd3e83429bfecd6873db52d4598ad4db5d1e905 evolution-data-server-1.10.1.tar.bz2 7120388
diff --git a/gnome-extra/evolution-data-server/files/digest-evolution-data-server-1.6.2-r1 b/gnome-extra/evolution-data-server/files/digest-evolution-data-server-1.6.2-r1
new file mode 100644
index 000000000000..e496e60a0ad0
--- /dev/null
+++ b/gnome-extra/evolution-data-server/files/digest-evolution-data-server-1.6.2-r1
@@ -0,0 +1,3 @@
+MD5 165f493eec8a2c8fc6eca3fdeb8c4885 evolution-data-server-1.6.2.tar.bz2 7179353
+RMD160 59af916ab4a9fabc14c65c16189188f829459985 evolution-data-server-1.6.2.tar.bz2 7179353
+SHA256 3b02b940aaa90034609b9401d3da586e5439363ade9bf8d7fc562acacd28bfde evolution-data-server-1.6.2.tar.bz2 7179353
diff --git a/gnome-extra/evolution-data-server/files/digest-evolution-data-server-1.8.3-r5 b/gnome-extra/evolution-data-server/files/digest-evolution-data-server-1.8.3-r5
new file mode 100644
index 000000000000..0defb70b07af
--- /dev/null
+++ b/gnome-extra/evolution-data-server/files/digest-evolution-data-server-1.8.3-r5
@@ -0,0 +1,3 @@
+MD5 f6a824f2553fd97555b8785a452fb6ab evolution-data-server-1.8.3.tar.bz2 7024111
+RMD160 8051f35a0db514f919bf730cd35c37ea75029061 evolution-data-server-1.8.3.tar.bz2 7024111
+SHA256 cbc067d87722afef84e8c4914787d990015e0c69b3bf3576fc15c8193ffd2fcc evolution-data-server-1.8.3.tar.bz2 7024111
diff --git a/gnome-extra/evolution-data-server/files/evolution-data-server-1.10.1-imap-overflow.patch b/gnome-extra/evolution-data-server/files/evolution-data-server-1.10.1-imap-overflow.patch
new file mode 100644
index 000000000000..7a241c1731a4
--- /dev/null
+++ b/gnome-extra/evolution-data-server/files/evolution-data-server-1.10.1-imap-overflow.patch
@@ -0,0 +1,21 @@
+diff --exclude-from=/home/dang/.scripts/diffrc -up -ruN evolution-data-server-1.10.1.orig/camel/providers/imap/camel-imap-folder.c evolution-data-server-1.10.1/camel/providers/imap/camel-imap-folder.c
+--- evolution-data-server-1.10.1.orig/camel/providers/imap/camel-imap-folder.c 2007-04-09 08:42:39.000000000 -0400
++++ evolution-data-server-1.10.1/camel/providers/imap/camel-imap-folder.c 2007-06-14 13:02:54.000000000 -0400
+@@ -655,7 +655,7 @@ imap_rescan (CamelFolder *folder, int ex
+ uid = g_datalist_get_data (&data, "UID");
+ flags = GPOINTER_TO_UINT (g_datalist_get_data (&data, "FLAGS"));
+
+- if (!uid || !seq || seq > summary_len) {
++ if (!uid || !seq || seq > summary_len || seq < 0) {
+ g_datalist_clear (&data);
+ continue;
+ }
+@@ -2789,7 +2789,7 @@ parse_fetch_response (CamelImapFolder *i
+
+ if (*response != '*' || *(response + 1) != ' ')
+ return NULL;
+- seq = strtol (response + 2, &response, 10);
++ seq = strtoul (response + 2, &response, 10);
+ if (seq == 0)
+ return NULL;
+ if (g_ascii_strncasecmp (response, " FETCH (", 8) != 0)