summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2012-04-16 18:29:09 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2012-04-16 18:29:09 +0000
commitefb30074dbf169c5e31d48b112c44b18a44ad3c8 (patch)
treeff8b06a1012508e3caa2ec88edf12c3cdbeba558 /gnome-extra
parentAdd another glib-2.32 fix, thanks to Yaw_e and Dmitry K (bug #412239). (diff)
downloadgentoo-2-efb30074dbf169c5e31d48b112c44b18a44ad3c8.tar.gz
gentoo-2-efb30074dbf169c5e31d48b112c44b18a44ad3c8.tar.bz2
gentoo-2-efb30074dbf169c5e31d48b112c44b18a44ad3c8.zip
Add another glib-2.32 fix.
(Portage version: 2.2.0_alpha100/cvs/Linux x86_64)
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/evolution-data-server/ChangeLog7
-rw-r--r--gnome-extra/evolution-data-server/evolution-data-server-2.32.3-r2.ebuild3
-rw-r--r--gnome-extra/evolution-data-server/files/evolution-data-server-2.32.3-g_thread_init.patch149
3 files changed, 157 insertions, 2 deletions
diff --git a/gnome-extra/evolution-data-server/ChangeLog b/gnome-extra/evolution-data-server/ChangeLog
index 2a2e529f7c67..3dbaf8463be9 100644
--- a/gnome-extra/evolution-data-server/ChangeLog
+++ b/gnome-extra/evolution-data-server/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for gnome-extra/evolution-data-server
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/evolution-data-server/ChangeLog,v 1.327 2012/04/15 19:58:05 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/evolution-data-server/ChangeLog,v 1.328 2012/04/16 18:29:09 tetromino Exp $
+
+ 16 Apr 2012; Alexandre Rostovtsev <tetromino@gentoo.org>
+ evolution-data-server-2.32.3-r2.ebuild,
+ +files/evolution-data-server-2.32.3-g_thread_init.patch:
+ Add another glib-2.32 fix.
15 Apr 2012; Alexandre Rostovtsev <tetromino@gentoo.org>
evolution-data-server-2.32.3-r2.ebuild,
diff --git a/gnome-extra/evolution-data-server/evolution-data-server-2.32.3-r2.ebuild b/gnome-extra/evolution-data-server/evolution-data-server-2.32.3-r2.ebuild
index 00788bdf08f6..5d7b543e2a0c 100644
--- a/gnome-extra/evolution-data-server/evolution-data-server-2.32.3-r2.ebuild
+++ b/gnome-extra/evolution-data-server/evolution-data-server-2.32.3-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/evolution-data-server/evolution-data-server-2.32.3-r2.ebuild,v 1.2 2012/04/15 19:58:05 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/evolution-data-server/evolution-data-server-2.32.3-r2.ebuild,v 1.3 2012/04/16 18:29:09 tetromino Exp $
EAPI="4"
GCONF_DEBUG="no"
@@ -94,6 +94,7 @@ src_prepare() {
# Fix building with glib-2.32, bug #412109
epatch "${FILESDIR}/${P}-gmodule-explicit.patch"
+ epatch "${FILESDIR}/${P}-g_thread_init.patch"
# /usr/include/db.h is always db-1 on FreeBSD
# so include the right dir in CPPFLAGS
diff --git a/gnome-extra/evolution-data-server/files/evolution-data-server-2.32.3-g_thread_init.patch b/gnome-extra/evolution-data-server/files/evolution-data-server-2.32.3-g_thread_init.patch
new file mode 100644
index 000000000000..d85910a79245
--- /dev/null
+++ b/gnome-extra/evolution-data-server/files/evolution-data-server-2.32.3-g_thread_init.patch
@@ -0,0 +1,149 @@
+From ffdfc6c7005e967a96f9ad0ea32ce782f0126a56 Mon Sep 17 00:00:00 2001
+From: Milan Crha <mcrha@redhat.com>
+Date: Mon, 24 Oct 2011 09:42:17 +0200
+Subject: [PATCH] Call g_thread_init() conditionally
+
+[Alexandre Rostovtsev <tetromino@gentoo.org>: backport to 2.32]
+---
+ addressbook/libedata-book/e-data-book-factory.c | 2 ++
+ calendar/backends/file/e-cal-backend-file.c | 2 ++
+ calendar/libedata-cal/e-data-cal-factory.c | 2 ++
+ camel/camel-index-control.c | 4 +++-
+ camel/camel-text-index.c | 2 ++
+ camel/providers/imapx/test-imapx.c | 2 ++
+ camel/tests/lib/camel-test.c | 2 ++
+ libedataserverui/test-name-selector.c | 2 ++
+ servers/groupwise/soap-test.c | 2 ++
+ 9 files changed, 19 insertions(+), 1 deletions(-)
+
+diff --git a/addressbook/libedata-book/e-data-book-factory.c b/addressbook/libedata-book/e-data-book-factory.c
+index 310ee2b..7c25f9c 100644
+--- a/addressbook/libedata-book/e-data-book-factory.c
++++ b/addressbook/libedata-book/e-data-book-factory.c
+@@ -602,7 +602,9 @@ main (gint argc, gchar **argv)
+
+ g_type_init ();
+ g_set_prgname (E_PRGNAME);
++ #if !GLIB_CHECK_VERSION(2,31,0)
+ if (!g_thread_supported ()) g_thread_init (NULL);
++ #endif
+
+ factory = g_object_new (E_TYPE_DATA_BOOK_FACTORY, NULL);
+
+diff --git a/calendar/backends/file/e-cal-backend-file.c b/calendar/backends/file/e-cal-backend-file.c
+index 9bacb88..3721240 100644
+--- a/calendar/backends/file/e-cal-backend-file.c
++++ b/calendar/backends/file/e-cal-backend-file.c
+@@ -3786,7 +3786,9 @@ main(gint argc, gchar **argv)
+ FILE* fin = NULL;
+
+ g_type_init ();
++ #if !GLIB_CHECK_VERSION(2,31,0)
+ g_thread_init (NULL);
++ #endif
+
+ context = g_option_context_new ("- test utility for e-d-s file backend");
+ g_option_context_add_main_entries (context, entries, GETTEXT_PACKAGE);
+diff --git a/calendar/libedata-cal/e-data-cal-factory.c b/calendar/libedata-cal/e-data-cal-factory.c
+index db9cc1c..aa35082 100644
+--- a/calendar/libedata-cal/e-data-cal-factory.c
++++ b/calendar/libedata-cal/e-data-cal-factory.c
+@@ -911,7 +911,9 @@ main (gint argc, gchar **argv)
+
+ g_type_init ();
+ g_set_prgname (E_PRGNAME);
++ #if !GLIB_CHECK_VERSION(2,31,0)
+ if (!g_thread_supported ()) g_thread_init (NULL);
++ #endif
+
+ #ifdef HAVE_ICAL_UNKNOWN_TOKEN_HANDLING
+ ical_set_unknown_token_handling_setting (ICAL_DISCARD_TOKEN);
+diff --git a/camel/camel-index-control.c b/camel/camel-index-control.c
+index 771cba2..9c15971 100644
+--- a/camel/camel-index-control.c
++++ b/camel/camel-index-control.c
+@@ -124,7 +124,9 @@ gint main(gint argc, gchar **argv)
+ if (argc<2)
+ do_usage(argv[0]);
+
+- g_thread_init(NULL);
++ #if !GLIB_CHECK_VERSION(2,31,0)
++ g_thread_init (NULL);
++ #endif
+ camel_init(NULL, 0);
+
+ if (!strcmp(argv[1], "compress"))
+diff --git a/camel/camel-text-index.c b/camel/camel-text-index.c
+index e242669..8240608 100644
+--- a/camel/camel-text-index.c
++++ b/camel/camel-text-index.c
+@@ -1851,7 +1851,9 @@ gint main (gint argc, gchar **argv)
+
+ printf ("Camel text index tester!\n");
+
++ #if !GLIB_CHECK_VERSION(2,31,0)
+ g_thread_init (NULL);
++ #endif
+ camel_init (NULL, 0);
+
+ idx = (CamelIndex *)camel_text_index_new ("textindex", O_CREAT|O_RDWR|O_TRUNC);
+diff --git a/camel/providers/imapx/test-imapx.c b/camel/providers/imapx/test-imapx.c
+index ede8d65..6db0ab7 100644
+--- a/camel/providers/imapx/test-imapx.c
++++ b/camel/providers/imapx/test-imapx.c
+@@ -36,7 +36,9 @@ main (gint argc, gchar *argv[])
+ }
+
+ uri = argv[1];
++ #if !GLIB_CHECK_VERSION(2,31,0)
+ g_thread_init (NULL);
++ #endif
+ system ("rm -rf /tmp/test-camel-imapx");
+ camel_init ("/tmp/test-camel-imapx", TRUE);
+ camel_provider_init ();
+diff --git a/camel/tests/lib/camel-test.c b/camel/tests/lib/camel-test.c
+index 44a20ae..42703e8 100644
+--- a/camel/tests/lib/camel-test.c
++++ b/camel/tests/lib/camel-test.c
+@@ -99,8 +99,10 @@ camel_test_init(gint argc, gchar **argv)
+ setup = 1;
+
+ g_type_init ();
++ #if !GLIB_CHECK_VERSION(2,31,0)
+ /* yeah, we do need ot thread init, even though camel isn't compiled with enable threads */
+ g_thread_init (NULL);
++ #endif
+
+ path = g_strdup_printf ("/tmp/camel-test");
+ if (mkdir (path, 0700) == -1 && errno != EEXIST)
+diff --git a/libedataserverui/test-name-selector.c b/libedataserverui/test-name-selector.c
+index 71552b1..8f92e2d 100644
+--- a/libedataserverui/test-name-selector.c
++++ b/libedataserverui/test-name-selector.c
+@@ -83,7 +83,9 @@ gint
+ main (gint argc, gchar **argv)
+ {
+ gtk_init (&argc, &argv);
++ #if !GLIB_CHECK_VERSION(2,31,0)
+ g_thread_init (NULL);
++ #endif
+
+ camel_init (NULL, 0);
+
+diff --git a/servers/groupwise/soap-test.c b/servers/groupwise/soap-test.c
+index 221a8b7..0ab93f0 100644
+--- a/servers/groupwise/soap-test.c
++++ b/servers/groupwise/soap-test.c
+@@ -49,7 +49,9 @@ gint
+ main (gint argc, gchar *argv[])
+ {
+ g_type_init ();
++ #if !GLIB_CHECK_VERSION(2,31,0)
+ g_thread_init (NULL);
++ #endif
+
+ /* Hostname Eg: http(s)://domain_name:/port_number/soap */
+ if (argc != 3 && argc != 4) {
+--
+1.7.8.5
+