summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2008-02-07 16:53:52 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2008-02-07 16:53:52 +0000
commit1a20903df0351e387f597444264be80b98a83fc5 (patch)
tree4a57ae275a37d386d533e30338b0cfeba5490fbc /gnustep-libs/rigs/rigs-0.2.2.20061009.ebuild
parentAdded vim-syntax USE flag, bug #208399. (diff)
downloadgentoo-2-1a20903df0351e387f597444264be80b98a83fc5.tar.gz
gentoo-2-1a20903df0351e387f597444264be80b98a83fc5.tar.bz2
gentoo-2-1a20903df0351e387f597444264be80b98a83fc5.zip
Version bump, cleaner ebuild, partially fixes bug #208643
(Portage version: 2.1.4.1)
Diffstat (limited to 'gnustep-libs/rigs/rigs-0.2.2.20061009.ebuild')
-rw-r--r--gnustep-libs/rigs/rigs-0.2.2.20061009.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnustep-libs/rigs/rigs-0.2.2.20061009.ebuild b/gnustep-libs/rigs/rigs-0.2.2.20061009.ebuild
new file mode 100644
index 000000000000..e6e2a394110f
--- /dev/null
+++ b/gnustep-libs/rigs/rigs-0.2.2.20061009.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnustep-libs/rigs/rigs-0.2.2.20061009.ebuild,v 1.1 2008/02/07 16:53:51 voyageur Exp $
+
+inherit gnustep-2
+
+DESCRIPTION="Ruby Interface for GNUstep."
+HOMEPAGE="http://www.gnustep.org/experience/RIGS.html"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+KEYWORDS="~amd64 ~ppc ~x86"
+LICENSE="LGPL-2.1 GPL-2"
+SLOT="0"
+
+DEPEND="dev-lang/ruby"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${P}-install-rb.patch
+}
+
+src_install() {
+ gnustep-base_src_install
+
+ # install examples
+ if use doc; then
+ cd "${S}"
+ dodir ${GNUSTEP_SYSTEM_DOC}/RIGS
+ cp -pPR Examples "${D}"/${GNUSTEP_SYSTEM_DOC}/RIGS
+ fi
+}