summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Alexander <wired@gentoo.org>2009-11-02 20:30:37 +0000
committerAlex Alexander <wired@gentoo.org>2009-11-02 20:30:37 +0000
commitfd982245d4cb1731134001dc68fb61eaad36ba16 (patch)
treefb68511dbbafc2f9e56c0e7cc14df6c36cdc300e /kde-base/ark
parentVersion bump KDE 4.3.3 (diff)
downloadgentoo-2-fd982245d4cb1731134001dc68fb61eaad36ba16.tar.gz
gentoo-2-fd982245d4cb1731134001dc68fb61eaad36ba16.tar.bz2
gentoo-2-fd982245d4cb1731134001dc68fb61eaad36ba16.zip
Version bump KDE 4.3.3
(Portage version: 2.2_rc48/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'kde-base/ark')
-rw-r--r--kde-base/ark/ChangeLog7
-rw-r--r--kde-base/ark/ark-4.3.3.ebuild30
2 files changed, 36 insertions, 1 deletions
diff --git a/kde-base/ark/ChangeLog b/kde-base/ark/ChangeLog
index dd793155fce5..1e9c0b3517b7 100644
--- a/kde-base/ark/ChangeLog
+++ b/kde-base/ark/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/ark
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/ark/ChangeLog,v 1.129 2009/10/18 16:00:47 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ark/ChangeLog,v 1.130 2009/11/02 20:30:37 wired Exp $
+
+*ark-4.3.3 (02 Nov 2009)
+
+ 02 Nov 2009; Alex Alexander <wired@gentoo.org> +ark-4.3.3.ebuild:
+ Version bump
18 Oct 2009; Markus Meier <maekke@gentoo.org> ark-4.3.1.ebuild:
x86 stable, bug #287697
diff --git a/kde-base/ark/ark-4.3.3.ebuild b/kde-base/ark/ark-4.3.3.ebuild
new file mode 100644
index 000000000000..e4a5d4769157
--- /dev/null
+++ b/kde-base/ark/ark-4.3.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ark/ark-4.3.3.ebuild,v 1.1 2009/11/02 20:30:37 wired Exp $
+
+EAPI="2"
+
+KMNAME="kdeutils"
+inherit kde4-meta
+
+DESCRIPTION="KDE Archiving tool"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="+archive +bzip2 debug +handbook lzma zip"
+
+DEPEND="
+ $(add_kdebase_dep libkonq)
+ archive? ( >=app-arch/libarchive-2.6.1[bzip2?,lzma?,zlib] )
+ lzma? ( app-arch/xz-utils )
+ zip? ( >=dev-libs/libzip-0.8 )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_with archive LibArchive)
+ $(cmake-utils_use_with bzip2 BZip2)
+ $(cmake-utils_use_with lzma LibLZMA)
+ $(cmake-utils_use_with zip LibZip)
+ "
+ kde4-meta_src_configure
+}