summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2013-03-06 13:42:15 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2013-03-06 13:42:15 +0000
commitdaec5bb32d717672af35168b16bb8164f2533810 (patch)
tree64932fcb885be528a75e27b8edcfefe4903e17a0 /kde-base/audiocd-kio
parentSwitch 9999 to truly live 'develop' branch per user request. (diff)
downloadgentoo-2-daec5bb32d717672af35168b16bb8164f2533810.tar.gz
gentoo-2-daec5bb32d717672af35168b16bb8164f2533810.tar.bz2
gentoo-2-daec5bb32d717672af35168b16bb8164f2533810.zip
Bump KDE SC 4.10.1
(Portage version: 2.2.0_alpha166/cvs/Linux x86_64, RepoMan options: --force, signed Manifest commit with key 7887F787)
Diffstat (limited to 'kde-base/audiocd-kio')
-rw-r--r--kde-base/audiocd-kio/ChangeLog8
-rw-r--r--kde-base/audiocd-kio/audiocd-kio-4.10.1.ebuild43
2 files changed, 50 insertions, 1 deletions
diff --git a/kde-base/audiocd-kio/ChangeLog b/kde-base/audiocd-kio/ChangeLog
index a0108a99a243..cd798996313a 100644
--- a/kde-base/audiocd-kio/ChangeLog
+++ b/kde-base/audiocd-kio/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/audiocd-kio
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/audiocd-kio/ChangeLog,v 1.19 2013/02/23 15:55:42 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/audiocd-kio/ChangeLog,v 1.20 2013/03/06 13:41:50 dilfridge Exp $
+
+*audiocd-kio-4.10.1 (06 Mar 2013)
+
+ 06 Mar 2013; Andreas K. Huettel <dilfridge@gentoo.org>
+ +audiocd-kio-4.10.1.ebuild:
+ Version bump KDE SC 4.10.1
23 Feb 2013; Agostino Sarubbo <ago@gentoo.org> audiocd-kio-4.10.0.ebuild,
audiocd-kio-4.9.5.ebuild:
diff --git a/kde-base/audiocd-kio/audiocd-kio-4.10.1.ebuild b/kde-base/audiocd-kio/audiocd-kio-4.10.1.ebuild
new file mode 100644
index 000000000000..9b569b85f492
--- /dev/null
+++ b/kde-base/audiocd-kio/audiocd-kio-4.10.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/audiocd-kio/audiocd-kio-4.10.1.ebuild,v 1.1 2013/03/06 13:41:51 dilfridge Exp $
+
+EAPI=5
+
+KDE_HANDBOOK="optional"
+inherit kde4-base
+
+DESCRIPTION="KDE kioslaves from the kdemultimedia package"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug encode flac vorbis"
+
+# 4 of 9 tests fail. Last checked for 4.2.88
+RESTRICT=test
+
+DEPEND="
+ $(add_kdebase_dep libkcddb)
+ $(add_kdebase_dep libkcompactdisc)
+ media-sound/cdparanoia
+ encode? (
+ flac? ( >=media-libs/flac-1.1.2 )
+ vorbis? ( media-libs/libvorbis )
+ )
+"
+RDEPEND="${DEPEND}"
+
+add_blocker kdemultimedia-kioslaves
+
+KMLOADLIBS="libkcddb"
+
+src_configure() {
+ if use encode; then
+ mycmakeargs=(
+ $(cmake-utils_use_with flac)
+ $(cmake-utils_use_with vorbis OggVorbis)
+ )
+ else
+ mycmakeargs=(-DWITH_OggVorbis=OFF -DWITH_Flac=OFF)
+ fi
+
+ kde4-base_src_configure
+}