summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2011-07-09 15:14:29 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2011-07-09 15:14:29 +0000
commit198ce394c73bbfe7e1f269f6e39a5a98cab823a2 (patch)
tree4491916cd89010371521f0c68a631a977483b823 /kde-base/cantor
parentBump to an up-to-date version, and add maintainer (diff)
downloadgentoo-2-198ce394c73bbfe7e1f269f6e39a5a98cab823a2.tar.gz
gentoo-2-198ce394c73bbfe7e1f269f6e39a5a98cab823a2.tar.bz2
gentoo-2-198ce394c73bbfe7e1f269f6e39a5a98cab823a2.zip
[kde-base] Add KDE SC 4.6.5
(Portage version: 2.2.0_alpha43/cvs/Linux x86_64)
Diffstat (limited to 'kde-base/cantor')
-rw-r--r--kde-base/cantor/ChangeLog7
-rw-r--r--kde-base/cantor/cantor-4.6.5.ebuild50
2 files changed, 56 insertions, 1 deletions
diff --git a/kde-base/cantor/ChangeLog b/kde-base/cantor/ChangeLog
index 420b38895937..834a446f8dbd 100644
--- a/kde-base/cantor/ChangeLog
+++ b/kde-base/cantor/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/cantor
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/cantor/ChangeLog,v 1.36 2011/07/06 20:05:23 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/cantor/ChangeLog,v 1.37 2011/07/09 15:14:03 alexxy Exp $
+
+*cantor-4.6.5 (09 Jul 2011)
+
+ 09 Jul 2011; Alexey Shvetsov <alexxy@gentoo.org> +cantor-4.6.5.ebuild:
+ Version bump KDE SC 4.6.5
06 Jul 2011; Andreas K. Huettel <dilfridge@gentoo.org> -cantor-4.6.2.ebuild:
Drop KDE 4.6.2
diff --git a/kde-base/cantor/cantor-4.6.5.ebuild b/kde-base/cantor/cantor-4.6.5.ebuild
new file mode 100644
index 000000000000..5cb8c6d6d8c2
--- /dev/null
+++ b/kde-base/cantor/cantor-4.6.5.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/cantor/cantor-4.6.5.ebuild,v 1.1 2011/07/09 15:14:03 alexxy Exp $
+
+EAPI=4
+
+KDE_HANDBOOK="optional"
+KDE_SCM="git"
+if [[ ${PV} == *9999 ]]; then
+ kde_eclass="kde4-base"
+else
+ KMNAME="kdeedu"
+ kde_eclass="kde4-meta"
+fi
+inherit ${kde_eclass}
+
+DESCRIPTION="KDE4 interface for doing mathematics and scientific computing"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug ps +R"
+
+# TODO Add Sage Mathematics Software backend (http://www.sagemath.org)
+RDEPEND="
+ ps? ( app-text/libspectre )
+ R? ( dev-lang/R )
+"
+DEPEND="${RDEPEND}
+ >=dev-cpp/eigen-2.0.3:2
+"
+
+src_configure() {
+ mycmakeargs+="
+ $(cmake-utils_use_with ps LibSpectre)
+ $(cmake-utils_use_with R)
+ "
+
+ ${kde_eclass}_src_configure
+}
+
+pkg_postinst() {
+ ${kde_eclass}_pkg_postinst
+
+ if ! use R; then
+ echo
+ ewarn "You have decided to build ${PN} with no backend."
+ ewarn "To have this application functional, please do one of below:"
+ ewarn " # emerge -va1 '='${CATEGORY}/${P} with 'R' USE flag enabled"
+ ewarn " # emerge -vaDu sci-mathematics/maxima"
+ echo
+ fi
+}