summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2005-07-28 21:16:26 +0000
committerDan Armak <danarmak@gentoo.org>2005-07-28 21:16:26 +0000
commit80ceeb9343ee15917cb727fa4e9f34cfcf2e09d4 (patch)
tree10350f32a739306558a2f194fa917fdb13a0e42c /kde-base/juk/juk-3.4.2.ebuild
parentMarked ~ppc. (diff)
downloadgentoo-2-80ceeb9343ee15917cb727fa4e9f34cfcf2e09d4.tar.gz
gentoo-2-80ceeb9343ee15917cb727fa4e9f34cfcf2e09d4.tar.bz2
gentoo-2-80ceeb9343ee15917cb727fa4e9f34cfcf2e09d4.zip
KDE 3.4.2 split ebuilds. p.masked, to be unmasked shortly.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'kde-base/juk/juk-3.4.2.ebuild')
-rw-r--r--kde-base/juk/juk-3.4.2.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/kde-base/juk/juk-3.4.2.ebuild b/kde-base/juk/juk-3.4.2.ebuild
new file mode 100644
index 000000000000..91e128197512
--- /dev/null
+++ b/kde-base/juk/juk-3.4.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/juk/juk-3.4.2.ebuild,v 1.1 2005/07/28 21:16:10 danarmak Exp $
+
+KMNAME=kdemultimedia
+MAXKDEVER=$PV
+KM_DEPRANGE="$PV $MAXKDEVER"
+inherit kde-meta eutils
+
+DESCRIPTION="Jukebox and music manager for KDE"
+KEYWORDS=" ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="flac gstreamer mp3 vorbis"
+
+# There's a configure switch for optional musicbrainz support, but there's no use flag for it, and I don't want to introduce
+# a local nomusicbrainz flag
+DEPEND="media-libs/taglib
+ media-libs/tunepimp
+ media-libs/musicbrainz
+ gstreamer? ( >=media-libs/gstreamer-0.8
+ >=media-libs/gst-plugins-0.8 )
+ $(deprange $PV $MAXKDEVER kde-base/akode)"
+
+RDEPEND="${DEPEND}
+ gstreamer? ( mp3? ( >=media-plugins/gst-plugins-mad-0.8 )
+ vorbis? ( >=media-plugins/gst-plugins-ogg-0.8
+ >=media-plugins/gst-plugins-vorbis-0.8 )
+ flac? ( >=media-plugins/gst-plugins-flac-0.8 ) )"
+
+PATCHES="$FILESDIR/configure-fix-kdemultimedia-juk.patch"
+myconf="$myconf $(use_with gstreamer)"
+
+KMCOPYLIB="
+ libakode akode/lib/"
+KMEXTRACTONLY="arts/configure.in.in
+ akode/lib/"
+
+pkg_setup() {
+ if ! useq arts && ! useq gstreamer; then
+ eerror "${PN} needs USE=\"arts\" (and kdelibs compiled with USE=\"arts\") or USE=\"gstreamer\""
+ die
+ fi
+}