summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2012-01-25 18:17:26 +0000
committerJohannes Huber <johu@gentoo.org>2012-01-25 18:17:26 +0000
commit8f5c0a404860825a8ca1de5f74decd3e3b2f411e (patch)
treefd54bf03f8193c4baefa01616ebd14e3b25f8717 /kde-base/kde-l10n
parentUse github from thirdpartymirrors. (diff)
downloadgentoo-2-8f5c0a404860825a8ca1de5f74decd3e3b2f411e.tar.gz
gentoo-2-8f5c0a404860825a8ca1de5f74decd3e3b2f411e.tar.bz2
gentoo-2-8f5c0a404860825a8ca1de5f74decd3e3b2f411e.zip
Version bump KDE SC 4.8.0
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'kde-base/kde-l10n')
-rw-r--r--kde-base/kde-l10n/ChangeLog7
-rw-r--r--kde-base/kde-l10n/kde-l10n-4.8.0.ebuild89
2 files changed, 95 insertions, 1 deletions
diff --git a/kde-base/kde-l10n/ChangeLog b/kde-base/kde-l10n/ChangeLog
index c7015399f50b..1acaa8376ed6 100644
--- a/kde-base/kde-l10n/ChangeLog
+++ b/kde-base/kde-l10n/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kde-l10n
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kde-l10n/ChangeLog,v 1.122 2012/01/17 13:28:45 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kde-l10n/ChangeLog,v 1.123 2012/01/25 18:16:42 johu Exp $
+
+*kde-l10n-4.8.0 (25 Jan 2012)
+
+ 25 Jan 2012; Johannes Huber <johu@gentoo.org> +kde-l10n-4.8.0.ebuild:
+ Version bump KDE SC 4.8.0
17 Jan 2012; Johannes Huber <johu@gentoo.org> -kde-l10n-4.7.3.ebuild:
Remove KDE SC 4.7.3
diff --git a/kde-base/kde-l10n/kde-l10n-4.8.0.ebuild b/kde-base/kde-l10n/kde-l10n-4.8.0.ebuild
new file mode 100644
index 000000000000..d6592becbe19
--- /dev/null
+++ b/kde-base/kde-l10n/kde-l10n-4.8.0.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kde-l10n/kde-l10n-4.8.0.ebuild,v 1.1 2012/01/25 18:16:42 johu Exp $
+
+EAPI=4
+
+inherit kde4-base
+
+DESCRIPTION="KDE internationalization package"
+HOMEPAGE="http://www.kde.org/"
+LICENSE="GPL-2"
+
+DEPEND="
+ sys-devel/gettext
+"
+RDEPEND="!<kde-misc/konq-plugins-4.6"
+
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="+handbook"
+
+# /usr/portage/distfiles $ ls -1 kde-l10n-*-${PV}.* |sed -e 's:-${PV}.tar.bz2::' -e 's:kde-l10n-::' |tr '\n' ' '
+MY_LANGS="ar bg bs ca ca@valencia cs da de el en_GB es et eu fa fi fr ga gl hr
+hu ia is it ja kk km ko lt lv nb nds nl nn pa pl pt pt_BR ro ru si sk sl sr sv
+tg th tr uk vi wa zh_CN zh_TW"
+
+URI_BASE="${SRC_URI/-${PV}.tar.bz2/}"
+SRC_URI=""
+
+for MY_LANG in ${MY_LANGS} ; do
+ IUSE="${IUSE} linguas_${MY_LANG}"
+ SRC_URI="${SRC_URI} linguas_${MY_LANG}? ( ${URI_BASE}/${PN}-${MY_LANG}-${PV}.tar.bz2 )"
+done
+
+S="${WORKDIR}"
+
+src_unpack() {
+ local LNG DIR
+ if [[ -z ${A} ]]; then
+ elog
+ elog "You either have the LINGUAS variable unset, or it only"
+ elog "contains languages not supported by ${P}."
+ elog "You won't have any additional language support."
+ elog
+ elog "${P} supports these language codes:"
+ elog "${MY_LANGS}"
+ elog
+ fi
+
+ [[ -n ${A} ]] && unpack ${A}
+ cd "${S}"
+
+ # add all linguas to cmake
+ if [[ -n ${A} ]]; then
+ for LNG in ${LINGUAS}; do
+ DIR="${PN}-${LNG}-${PV}"
+ if [[ -d "${DIR}" ]] ; then
+ echo "add_subdirectory( ${DIR} )" >> "${S}"/CMakeLists.txt
+ fi
+ done
+ fi
+}
+
+src_prepare() {
+ find "${S}" -name CMakeLists.txt -type f \
+ -exec sed -i -e 's:^ *add_subdirectory( *kdepim-runtime *):# no kdepim-runtime:g' {} +
+ find "${S}" -name CMakeLists.txt -type f \
+ -exec sed -i -e 's:^ *add_subdirectory( *kdepim *):# no kdepim:g' {} +
+
+ kde4-base_src_prepare
+}
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_build handbook docs)
+ )
+ [[ -n ${A} ]] && kde4-base_src_configure
+}
+
+src_compile() {
+ [[ -n ${A} ]] && kde4-base_src_compile
+}
+
+src_test() {
+ [[ -n ${A} ]] && kde4-base_src_test
+}
+
+src_install() {
+ [[ -n ${A} ]] && kde4-base_src_install
+}