summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2002-04-03 18:14:07 +0000
committerDan Armak <danarmak@gentoo.org>2002-04-03 18:14:07 +0000
commita861af5b16e4029beaf86cac2cabcf9fb0df7280 (patch)
tree65bc96dfbec68d9a38e1e9193841b1aefd37a4ca /kde-base/kdeaddons
parentunmasked gcc3 fixed version of pam (diff)
downloadgentoo-2-a861af5b16e4029beaf86cac2cabcf9fb0df7280.tar.gz
gentoo-2-a861af5b16e4029beaf86cac2cabcf9fb0df7280.tar.bz2
gentoo-2-a861af5b16e4029beaf86cac2cabcf9fb0df7280.zip
new (masked) kde3 ebuilds
Diffstat (limited to 'kde-base/kdeaddons')
-rw-r--r--kde-base/kdeaddons/kdeaddons-3.0.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/kde-base/kdeaddons/kdeaddons-3.0.ebuild b/kde-base/kdeaddons/kdeaddons-3.0.ebuild
new file mode 100644
index 000000000000..98ab584cffa4
--- /dev/null
+++ b/kde-base/kdeaddons/kdeaddons-3.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Dan Armak <danarmak@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeaddons/kdeaddons-3.0.ebuild,v 1.1 2002/04/03 18:14:06 danarmak Exp $
+. /usr/portage/eclass/inherit.eclass || die
+inherit kde-dist || die
+
+DESCRIPTION="${DESCRIPTION}Addons"
+
+newdepend ">=kde-base/kdebase-${PV}
+ ~kde-base/kdenetwork-${PV}
+ ~kde-base/kdemultimedia-${PV}
+ >=media-libs/libsdl-1.2
+ sdl? ( media-libs/libsdl )"
+
+
+src_unpack() {
+
+ kde_src_unpack
+
+ cd ${S}/noatun-plugins
+ for x in `find -iname Makefile.am` `find -iname Makefile.in`; do
+ echo "(Maybe) patching ${x}..."
+ cp ${x} ${x}2
+ sed -e "s:\$(kde_libraries)/libnoatun.so:${KDEDIR}/lib/libnoatun.so:" ${x}2 > ${x}
+ rm ${x}2
+ done
+
+}
+
+src_compile() {
+
+ kde_src_compile myconf
+
+ myconf="$myconf --with-extra-includes=/usr/include/noatun"
+ use sdl && myconf="$myconf --with-sdl --with-sdl-prefix=/usr" || myconf="$myconf --without-sdl --disable-sdltest"
+
+ # needed for some stupid noatun plugins that can't find arts include file reference.h, which lives in /usr/kde/3/include/arts
+ myconf="$myconf --with-extra-includes=/usr/kde/3/include/arts"
+
+ kde_src_compile configure make
+
+}