summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2001-10-17 18:54:05 +0000
committerDan Armak <danarmak@gentoo.org>2001-10-17 18:54:05 +0000
commitb0c521e40cb633da07544230f63b4cdcc2ed87d9 (patch)
tree1255d59932f180d1f6931abe17096921804f1349 /kde-base/kdelibs
parentNew ebuild for a rather nice webmail program. (diff)
downloadgentoo-2-b0c521e40cb633da07544230f63b4cdcc2ed87d9.tar.gz
gentoo-2-b0c521e40cb633da07544230f63b4cdcc2ed87d9.tar.bz2
gentoo-2-b0c521e40cb633da07544230f63b4cdcc2ed87d9.zip
strange fixes, related to use ipv6
Diffstat (limited to 'kde-base/kdelibs')
-rw-r--r--kde-base/kdelibs/kdelibs-2.2.1-r1.ebuild43
-rw-r--r--kde-base/kdelibs/kdelibs-2.2.ebuild3
2 files changed, 24 insertions, 22 deletions
diff --git a/kde-base/kdelibs/kdelibs-2.2.1-r1.ebuild b/kde-base/kdelibs/kdelibs-2.2.1-r1.ebuild
index b71afd023262..1531a1298991 100644
--- a/kde-base/kdelibs/kdelibs-2.2.1-r1.ebuild
+++ b/kde-base/kdelibs/kdelibs-2.2.1-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Dan Armak <danarmak@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdelibs/kdelibs-2.2.1-r1.ebuild,v 1.3 2001/10/06 15:30:16 danarmak Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdelibs/kdelibs-2.2.1-r1.ebuild,v 1.4 2001/10/17 18:54:04 danarmak Exp $
. /usr/portage/eclass/inherit.eclass || die
inherit kde-dist || die
@@ -10,35 +10,36 @@ DESCRIPTION="${DESCRIPTION}Libraries"
# kde.eclass has kdelibs in DEPEND, and we can't have that in here. so we recreate the entire
# DEPEND from scratch.
COMMONDEPEND=">=sys-devel/gcc-2.95.2
- virtual/glibc
- sys-devel/ld.so
- sys-devel/perl
- >=media-libs/audiofile-0.1.9
- >=x11-libs/qt-x11-2.3.0
- >=sys-apps/bzip2-1.0.1
- >=dev-libs/libpcre-3.4
- >=dev-libs/libxml2-2.4.1
- ssl? ( >=dev-libs/openssl-0.9.6 )
- alsa? ( >=media-libs/alsa-lib-0.5.9 )
- cups? ( net-print/cups )
- >=media-libs/tiff-3.5.5"
+ >=x11-libs/qt-x11-2.3.0
+ virtual/glibc
+ sys-devel/ld.so
+ sys-devel/perl
+ >=media-libs/audiofile-0.1.9
+ >=sys-apps/bzip2-1.0.1
+ >=dev-libs/libpcre-3.4
+ >=dev-libs/libxml2-2.4.1
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ alsa? ( >=media-libs/alsa-lib-0.5.9 )
+ cups? ( net-print/cups )
+ >=media-libs/tiff-3.5.5"
DEPEND="$COMMONDEPEND
- sys-devel/make
- sys-devel/autoconf
- sys-devel/automake"
+ sys-devel/make
+ sys-devel/autoconf
+ sys-devel/automake"
RDEPEND="$COMMONDEPEND
- ~kde-base/kde-env-${PV}
- app-text/sgml-common
- cups? ( net-print/cups )
- dev-lang/python"
+ ~kde-base/kde-env-${PV}
+ app-text/sgml-common
+ cups? ( net-print/cups )
+ dev-lang/python"
src_compile() {
kde_src_compile myconf
- myconf="$myconf --with-ipv6-lookup=no --disable-libafm"
+ myconf="$myconf --disable-libafm"
+ use ipv6 || myconf="$myconf --with-ipv6-lookup=no"
use ssl && myconf="$myconf --with-ssl-dir=/usr" || myconf="$myconf --without-ssl"
use alsa && myconf="$myconf --with-alsa" || myconf="$myconf --without-alsa"
use cups && myconf="$myconf --enable-cups" || myconf="$myconf --disable-cups"
diff --git a/kde-base/kdelibs/kdelibs-2.2.ebuild b/kde-base/kdelibs/kdelibs-2.2.ebuild
index 5caa4c0aed36..f3984c55f9e1 100644
--- a/kde-base/kdelibs/kdelibs-2.2.ebuild
+++ b/kde-base/kdelibs/kdelibs-2.2.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdelibs/kdelibs-2.2.ebuild,v 1.11 2001/10/06 14:36:55 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdelibs/kdelibs-2.2.ebuild,v 1.12 2001/10/17 18:54:05 danarmak Exp $
S=${WORKDIR}/${P}
DESCRIPTION="KDE ${PV} - Libraries"
@@ -66,6 +66,7 @@ src_compile() {
if [ "`use qtmt`" ] ; then
myopts="$myopts --enable-mt"
fi
+ if [ -z "`use ipv6`" ] ; then
myopts="$myopts --with-ipv6-lookup=no"
fi