summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2014-05-13 22:33:13 +0000
committerJohannes Huber <johu@gentoo.org>2014-05-13 22:33:13 +0000
commitc2606721e0ccfcaaf76afdb24ffbe68469cbf5e7 (patch)
treef3ad5a11a641207fd2bd788532c36594037f6ec2 /kde-base/kdepim-runtime
parentEnable multilib support, bug #493166. (diff)
downloadgentoo-2-c2606721e0ccfcaaf76afdb24ffbe68469cbf5e7.tar.gz
gentoo-2-c2606721e0ccfcaaf76afdb24ffbe68469cbf5e7.tar.bz2
gentoo-2-c2606721e0ccfcaaf76afdb24ffbe68469cbf5e7.zip
Revision bump adapts USE flag changes made in KDE SC 4.13.1.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key F3CFD2BD)
Diffstat (limited to 'kde-base/kdepim-runtime')
-rw-r--r--kde-base/kdepim-runtime/ChangeLog8
-rw-r--r--kde-base/kdepim-runtime/kdepim-runtime-4.4.11.1-r3.ebuild42
2 files changed, 49 insertions, 1 deletions
diff --git a/kde-base/kdepim-runtime/ChangeLog b/kde-base/kdepim-runtime/ChangeLog
index ae1ffaa27aa0..7ea724f8dc84 100644
--- a/kde-base/kdepim-runtime/ChangeLog
+++ b/kde-base/kdepim-runtime/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/kdepim-runtime
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepim-runtime/ChangeLog,v 1.211 2014/05/13 17:43:41 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepim-runtime/ChangeLog,v 1.212 2014/05/13 22:33:13 johu Exp $
+
+*kdepim-runtime-4.4.11.1-r3 (13 May 2014)
+
+ 13 May 2014; Johannes Huber <johu@gentoo.org>
+ +kdepim-runtime-4.4.11.1-r3.ebuild:
+ Revision bump adapts USE flag changes made in KDE SC 4.13.1.
*kdepim-runtime-4.13.1 (13 May 2014)
diff --git a/kde-base/kdepim-runtime/kdepim-runtime-4.4.11.1-r3.ebuild b/kde-base/kdepim-runtime/kdepim-runtime-4.4.11.1-r3.ebuild
new file mode 100644
index 000000000000..02fc957dd778
--- /dev/null
+++ b/kde-base/kdepim-runtime/kdepim-runtime-4.4.11.1-r3.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepim-runtime/kdepim-runtime-4.4.11.1-r3.ebuild,v 1.1 2014/05/13 22:33:13 johu Exp $
+
+EAPI=5
+
+if [[ ${PV} = *9999* ]]; then
+ KMNAME="kdepim"
+ KMMODULE="runtime"
+ inherit kde4-meta
+else
+ inherit kde4-base
+fi
+
+DESCRIPTION="KDE PIM runtime plugin collection"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug"
+
+RESTRICT="test"
+# Would need test programs _testrunner and akonaditest from kdepimlibs
+
+COMMON_DEPEND="
+ app-misc/strigi
+ >=app-office/akonadi-server-1.3.1[soprano(+)]
+ dev-libs/libxml2:2
+ dev-libs/libxslt
+ $(add_kdebase_dep kdelibs 'nepomuk' 4.13.1)
+ $(add_kdebase_dep kdepimlibs '' 4.13.1)
+ $(add_kdebase_dep libkdepim)
+ x11-misc/shared-mime-info
+"
+DEPEND="${COMMON_DEPEND}
+ dev-libs/boost
+"
+RDEPEND="${COMMON_DEPEND}
+ $(add_kdebase_dep kdepim-icons)
+"
+
+PATCHES=(
+ "${FILESDIR}/4.4/"000[1-2]-*.patch
+ "${FILESDIR}/4.4/"999[6-9]-*.patch
+)