summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2013-07-02 16:48:19 +0000
committerJohannes Huber <johu@gentoo.org>2013-07-02 16:48:19 +0000
commit02902daa78c7cf5f5386400ee0dafd0414609a10 (patch)
tree16905afe90080dedca0abd945f2f302b80b0b3e1 /kde-base/kdepimlibs
parentMove `ln` update to the patch rather than sed-ing it after the fact #475334 b... (diff)
downloadgentoo-2-02902daa78c7cf5f5386400ee0dafd0414609a10.tar.gz
gentoo-2-02902daa78c7cf5f5386400ee0dafd0414609a10.tar.bz2
gentoo-2-02902daa78c7cf5f5386400ee0dafd0414609a10.zip
Version bump KDE SC 4.10.5
(Portage version: 2.2.0_alpha186/cvs/Linux x86_64, signed Manifest commit with key F3CFD2BD)
Diffstat (limited to 'kde-base/kdepimlibs')
-rw-r--r--kde-base/kdepimlibs/ChangeLog7
-rw-r--r--kde-base/kdepimlibs/kdepimlibs-4.10.5.ebuild78
2 files changed, 84 insertions, 1 deletions
diff --git a/kde-base/kdepimlibs/ChangeLog b/kde-base/kdepimlibs/ChangeLog
index c9b883a04a7c..fc57161deb06 100644
--- a/kde-base/kdepimlibs/ChangeLog
+++ b/kde-base/kdepimlibs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kdepimlibs
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepimlibs/ChangeLog,v 1.210 2013/07/02 09:29:46 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepimlibs/ChangeLog,v 1.211 2013/07/02 16:47:34 johu Exp $
+
+*kdepimlibs-4.10.5 (02 Jul 2013)
+
+ 02 Jul 2013; Johannes Huber <johu@gentoo.org> +kdepimlibs-4.10.5.ebuild:
+ Version bump KDE SC 4.10.5
02 Jul 2013; Agostino Sarubbo <ago@gentoo.org> -kdepimlibs-4.10.3.ebuild:
Remove old
diff --git a/kde-base/kdepimlibs/kdepimlibs-4.10.5.ebuild b/kde-base/kdepimlibs/kdepimlibs-4.10.5.ebuild
new file mode 100644
index 000000000000..41e3e784d143
--- /dev/null
+++ b/kde-base/kdepimlibs/kdepimlibs-4.10.5.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepimlibs/kdepimlibs-4.10.5.ebuild,v 1.1 2013/07/02 16:47:34 johu Exp $
+
+EAPI=5
+
+KDE_HANDBOOK="optional"
+CPPUNIT_REQUIRED="optional"
+inherit kde4-base
+
+DESCRIPTION="Common library for KDE PIM apps."
+KEYWORDS=" ~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+LICENSE="LGPL-2.1"
+IUSE="debug ldap prison semantic-desktop"
+
+# some akonadi tests timeout, that probaly needs more work as its ~700 tests
+RESTRICT="test"
+
+DEPEND="
+ !kde-misc/akonadi-social-utils
+ >=app-crypt/gpgme-1.1.6
+ >=dev-libs/boost-1.35.0-r5:=
+ dev-libs/libgpg-error
+ >=dev-libs/libical-0.43
+ dev-libs/cyrus-sasl
+ >=dev-libs/qjson-0.8.1
+ $(add_kdebase_dep kdelibs 'semantic-desktop(+)?')
+ prison? ( media-libs/prison )
+ semantic-desktop? (
+ >=app-office/akonadi-server-1.9.0
+ $(add_kdebase_dep nepomuk-core)
+ media-libs/phonon
+ x11-misc/shared-mime-info
+ )
+ ldap? ( net-nds/openldap )
+"
+# boost is not linked to, but headers which include it are installed
+# bug #418071
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${PN}-4.9.1-boostincludes.patch" )
+
+src_prepare() {
+ kde4-base_src_prepare
+
+ # Disable hardcoded checks
+ sed -r -e '/find_package\((Akonadi|SharedDesktopOntologies|Soprano|Nepomuk)/{/macro_optional_/!s/find/macro_optional_&/}' \
+ -e '/set_package_properties\((Akonadi|SHAREDDESKTOPONTOLOGIES|Soprano|Nepomuk)/s/ REQUIRED / OPTIONAL /' \
+ -e '/add_subdirectory\((akonadi|mailtransport)/{/macro_optional_/!s/add/macro_optional_&/}' \
+ -i CMakeLists.txt || die
+ if ! use semantic-desktop; then
+ sed -e '/include(SopranoAddOntology)/s/^/#DISABLED /' \
+ -i CMakeLists.txt || die
+ # More reliable than -DBUILD_akonadi=OFF
+ rm -r akonadi mailtransport || die
+ fi
+}
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_build handbook doc)
+ $(cmake-utils_use_find_package ldap)
+ $(cmake-utils_use_with semantic-desktop Akonadi)
+ $(cmake-utils_use_with semantic-desktop SharedDesktopOntologies)
+ $(cmake-utils_use_with semantic-desktop Soprano)
+ $(cmake-utils_use_with semantic-desktop NepomukCore)
+ $(cmake-utils_use !semantic-desktop KALARM_USE_KRESOURCES)
+ $(cmake-utils_use_find_package prison)
+ )
+
+ kde4-base_src_configure
+}
+
+src_install() {
+ kde4-base_src_install
+ rm "${D}"/usr/share/apps/cmake/modules/FindQJSON.cmake
+ rm "${D}"/usr/share/apps/cmake/modules/FindQtOAuth.cmake #Collides with net-im/choqok
+}