summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2013-12-18 19:58:23 +0000
committerJohannes Huber <johu@gentoo.org>2013-12-18 19:58:23 +0000
commit885ecb4a69485d6d2cbb21c20f0dc4cf4f20995c (patch)
treea746d61b035d298b8c5f5bdb7a403546a6c68fe7 /kde-base/kdepimlibs
parentMask >=kde-base/kopete-4.12.0[otr] because of package mask on >=net-libs/libo... (diff)
downloadgentoo-2-885ecb4a69485d6d2cbb21c20f0dc4cf4f20995c.tar.gz
gentoo-2-885ecb4a69485d6d2cbb21c20f0dc4cf4f20995c.tar.bz2
gentoo-2-885ecb4a69485d6d2cbb21c20f0dc4cf4f20995c.zip
Version bump KDE SC 4.12.0
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key F3CFD2BD)
Diffstat (limited to 'kde-base/kdepimlibs')
-rw-r--r--kde-base/kdepimlibs/ChangeLog7
-rw-r--r--kde-base/kdepimlibs/kdepimlibs-4.12.0.ebuild57
2 files changed, 63 insertions, 1 deletions
diff --git a/kde-base/kdepimlibs/ChangeLog b/kde-base/kdepimlibs/ChangeLog
index 20e766f7c5ba..70b8de083f6a 100644
--- a/kde-base/kdepimlibs/ChangeLog
+++ b/kde-base/kdepimlibs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kdepimlibs
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepimlibs/ChangeLog,v 1.233 2013/12/12 03:36:58 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepimlibs/ChangeLog,v 1.234 2013/12/18 19:57:50 johu Exp $
+
+*kdepimlibs-4.12.0 (18 Dec 2013)
+
+ 18 Dec 2013; Johannes Huber <johu@gentoo.org> +kdepimlibs-4.12.0.ebuild:
+ Version bump KDE SC 4.12.0
12 Dec 2013; Agostino Sarubbo <ago@gentoo.org> -kdepimlibs-4.10.5.ebuild:
Remove old
diff --git a/kde-base/kdepimlibs/kdepimlibs-4.12.0.ebuild b/kde-base/kdepimlibs/kdepimlibs-4.12.0.ebuild
new file mode 100644
index 000000000000..9e2cf99bf754
--- /dev/null
+++ b/kde-base/kdepimlibs/kdepimlibs-4.12.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepimlibs/kdepimlibs-4.12.0.ebuild,v 1.1 2013/12/18 19:57:50 johu Exp $
+
+EAPI=5
+
+KDE_HANDBOOK="optional"
+CPPUNIT_REQUIRED="optional"
+inherit kde4-base
+
+DESCRIPTION="Common library for KDE PIM apps."
+KEYWORDS=" ~amd64 ~x86 ~amd64-linux ~x86-linux"
+LICENSE="LGPL-2.1"
+IUSE="debug ldap prison"
+
+# some akonadi tests timeout, that probaly needs more work as its ~700 tests
+RESTRICT="test"
+
+DEPEND="
+ !kde-misc/akonadi-social-utils
+ $(add_kdebase_dep nepomuk-core)
+ $(add_kdebase_dep kdelibs 'semantic-desktop')
+ >=app-crypt/gpgme-1.1.6
+ >=app-office/akonadi-server-1.10.43
+ >=dev-libs/boost-1.35.0-r5:=
+ dev-libs/libgpg-error
+ >=dev-libs/libical-0.43
+ dev-libs/cyrus-sasl
+ >=dev-libs/qjson-0.8.1
+ media-libs/phonon
+ x11-misc/shared-mime-info
+ prison? ( media-libs/prison )
+ ldap? ( net-nds/openldap )
+"
+# boost is not linked to, but headers which include it are installed
+# bug #418071
+RDEPEND="${DEPEND}
+ || ( !<kde-base/kdepim-runtime-4.11.50 =kde-base/kdepim-runtime-4.4.11.1-r2 )
+"
+
+PATCHES=( "${FILESDIR}/${PN}-4.9.1-boostincludes.patch" )
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_build handbook doc)
+ $(cmake-utils_use_find_package ldap)
+ $(cmake-utils_use_find_package prison)
+ )
+
+ kde4-base_src_configure
+}
+
+src_install() {
+ kde4-base_src_install
+ rm "${ED}"/usr/share/apps/cmake/modules/FindQJSON.cmake
+ rm "${ED}"/usr/share/apps/cmake/modules/FindQtOAuth.cmake #Collides with net-im/choqok
+}