summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCarsten Lohrke <carlo@gentoo.org>2007-05-23 00:35:12 +0000
committerCarsten Lohrke <carlo@gentoo.org>2007-05-23 00:35:12 +0000
commit2aa54ab6e69f3e3a50c51bab69fcb474f3b9c519 (patch)
tree22b2ed5d567527a74aaa28dd112ab3989a35dbae /kde-base/knode/knode-3.5.7.ebuild
parentVersion bump. (diff)
downloadgentoo-2-2aa54ab6e69f3e3a50c51bab69fcb474f3b9c519.tar.gz
gentoo-2-2aa54ab6e69f3e3a50c51bab69fcb474f3b9c519.tar.bz2
gentoo-2-2aa54ab6e69f3e3a50c51bab69fcb474f3b9c519.zip
Version bump.
(Portage version: 2.1.2.7)
Diffstat (limited to 'kde-base/knode/knode-3.5.7.ebuild')
-rw-r--r--kde-base/knode/knode-3.5.7.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/kde-base/knode/knode-3.5.7.ebuild b/kde-base/knode/knode-3.5.7.ebuild
new file mode 100644
index 000000000000..4f161447248a
--- /dev/null
+++ b/kde-base/knode/knode-3.5.7.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/knode/knode-3.5.7.ebuild,v 1.1 2007/05/23 00:35:12 carlo Exp $
+
+KMNAME=kdepim
+MAXKDEVER=$PV
+KM_DEPRANGE="$PV $MAXKDEVER"
+inherit kde-meta eutils
+
+DESCRIPTION="A newsreader for KDE"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+DEPEND="$(deprange $PV $MAXKDEVER kde-base/libkdepim)
+$(deprange $PV $MAXKDEVER kde-base/libkdenetwork)
+$(deprange $PV $MAXKDEVER kde-base/kontact)
+$(deprange $PV $MAXKDEVER kde-base/libkmime)
+$(deprange 3.5.6 $MAXKDEVER kde-base/libkpgp)"
+
+RDEPEND="${DEPEND}"
+
+KMCOPYLIB="
+ libkdepim libkdepim
+ libkpinterfaces kontact/interfaces
+ libkmime libkmime
+ libkpgp libkpgp"
+KMEXTRACTONLY="
+ libkdepim/
+ libkdenetwork/
+ kontact/interfaces
+ libkmime
+ libkpgp
+ libemailfunctions"
+KMEXTRA="kontact/plugins/knode" # We add here the kontact's plugin instead of compiling it with kontact because it needs a lot of this programs deps.