summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2013-12-18 19:58:23 +0000
committerJohannes Huber <johu@gentoo.org>2013-12-18 19:58:23 +0000
commit885ecb4a69485d6d2cbb21c20f0dc4cf4f20995c (patch)
treea746d61b035d298b8c5f5bdb7a403546a6c68fe7 /kde-base/korundum
parentMask >=kde-base/kopete-4.12.0[otr] because of package mask on >=net-libs/libo... (diff)
downloadgentoo-2-885ecb4a69485d6d2cbb21c20f0dc4cf4f20995c.tar.gz
gentoo-2-885ecb4a69485d6d2cbb21c20f0dc4cf4f20995c.tar.bz2
gentoo-2-885ecb4a69485d6d2cbb21c20f0dc4cf4f20995c.zip
Version bump KDE SC 4.12.0
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key F3CFD2BD)
Diffstat (limited to 'kde-base/korundum')
-rw-r--r--kde-base/korundum/ChangeLog7
-rw-r--r--kde-base/korundum/korundum-4.12.0.ebuild74
2 files changed, 80 insertions, 1 deletions
diff --git a/kde-base/korundum/ChangeLog b/kde-base/korundum/ChangeLog
index 2cb687d0baa1..751382169225 100644
--- a/kde-base/korundum/ChangeLog
+++ b/kde-base/korundum/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/korundum
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/korundum/ChangeLog,v 1.189 2013/12/12 03:37:15 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/korundum/ChangeLog,v 1.190 2013/12/18 19:57:47 johu Exp $
+
+*korundum-4.12.0 (18 Dec 2013)
+
+ 18 Dec 2013; Johannes Huber <johu@gentoo.org> +korundum-4.12.0.ebuild:
+ Version bump KDE SC 4.12.0
12 Dec 2013; Agostino Sarubbo <ago@gentoo.org> -korundum-4.10.5.ebuild:
Remove old
diff --git a/kde-base/korundum/korundum-4.12.0.ebuild b/kde-base/korundum/korundum-4.12.0.ebuild
new file mode 100644
index 000000000000..93b96b76fc68
--- /dev/null
+++ b/kde-base/korundum/korundum-4.12.0.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/korundum/korundum-4.12.0.ebuild,v 1.1 2013/12/18 19:57:47 johu Exp $
+
+EAPI=5
+
+OPENGL_REQUIRED="always"
+
+USE_RUBY="ruby19"
+# Only one ruby version is supported:
+# 1) cmake bails when configuring twice or more - solved with CMAKE_IN_SOURCE_BUILD=1
+# 2) the ebuild can only be installed for one ruby variant, otherwise the compiled
+# files with identical path+name will overwrite each other - difficult :(
+
+inherit kde4-base ruby-ng
+
+DESCRIPTION="KDE Ruby bindings"
+KEYWORDS=" ~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="akonadi debug kate okular"
+HOMEPAGE="http://techbase.kde.org/Development/Languages/Ruby"
+
+# unfortunately single modules cannot be disabled with cmake defines
+# possible more useflags have no effect... does anyone actually build this stuff?
+# may need some hacking, for now semantic-desktop just becomes a hard dependency
+
+DEPEND="
+ $(add_kdebase_dep qtruby)
+ $(add_kdebase_dep smokekde 'kate?,okular?,semantic-desktop')
+ $(add_kdebase_dep smokeqt)
+"
+RDEPEND="${DEPEND}
+"
+
+pkg_setup() {
+ ruby-ng_pkg_setup
+ kde4-base_pkg_setup
+}
+
+src_unpack() {
+ local S="${WORKDIR}/${P}"
+ kde4-base_src_unpack
+
+ cd "${WORKDIR}"
+ mkdir all
+ mv ${P} all/ || die "Could not move sources"
+}
+
+all_ruby_prepare() {
+ kde4-base_src_prepare
+}
+
+each_ruby_configure() {
+ CMAKE_USE_DIR=${S}
+ mycmakeargs=(
+ -DRUBY_LIBRARY=$(ruby_get_libruby)
+ -DRUBY_INCLUDE_PATH=$(ruby_get_hdrdir)
+ -DRUBY_EXECUTABLE=${RUBY}
+ $(cmake-utils_use_with akonadi)
+ $(cmake-utils_use_with akonadi KdepimLibs)
+ $(cmake-utils_use_disable kate)
+ $(cmake-utils_use_with okular)
+ )
+ kde4-base_src_configure
+}
+
+each_ruby_compile() {
+ CMAKE_USE_DIR=${S}
+ kde4-base_src_compile
+}
+
+each_ruby_install() {
+ CMAKE_USE_DIR=${S}
+ kde4-base_src_install
+}