summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2005-11-22 22:14:16 +0000
committerDan Armak <danarmak@gentoo.org>2005-11-22 22:14:16 +0000
commitb082217c4a241b37430dd0864ecc001ff8e923bd (patch)
treef58c26cbd1dfd16006cbeb6cf89310d4ef91531e /kde-base/kpilot
parentversion bump (diff)
downloadgentoo-2-b082217c4a241b37430dd0864ecc001ff8e923bd.tar.gz
gentoo-2-b082217c4a241b37430dd0864ecc001ff8e923bd.tar.bz2
gentoo-2-b082217c4a241b37430dd0864ecc001ff8e923bd.zip
KDE 3.5.0 (not yet released, p.masked)
(Portage version: 2.0.53_rc7)
Diffstat (limited to 'kde-base/kpilot')
-rw-r--r--kde-base/kpilot/ChangeLog7
-rw-r--r--kde-base/kpilot/files/digest-kpilot-3.5.01
-rw-r--r--kde-base/kpilot/kpilot-3.5.0.ebuild37
3 files changed, 44 insertions, 1 deletions
diff --git a/kde-base/kpilot/ChangeLog b/kde-base/kpilot/ChangeLog
index a303875d5f91..d0ae8a2b7b26 100644
--- a/kde-base/kpilot/ChangeLog
+++ b/kde-base/kpilot/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kpilot
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kpilot/ChangeLog,v 1.21 2005/11/12 15:49:32 danarmak Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kpilot/ChangeLog,v 1.22 2005/11/22 22:14:11 danarmak Exp $
+
+*kpilot-3.5.0 (22 Nov 2005)
+
+ 33 Nov 2005; Dan Armak <danarmak@gentoo.org> +kpilot-3.5.0.ebuild:
+ Ebuilds for KDE 3.5.0 final. It is not yet released, and is package.masked.
*kpilot-3.5.0_rc1 (12 Nov 2005)
diff --git a/kde-base/kpilot/files/digest-kpilot-3.5.0 b/kde-base/kpilot/files/digest-kpilot-3.5.0
new file mode 100644
index 000000000000..fb1a0b4ceae2
--- /dev/null
+++ b/kde-base/kpilot/files/digest-kpilot-3.5.0
@@ -0,0 +1 @@
+MD5 9ed0b1a66121ee1c4fbaafd17017f2d9 kdepim-3.5.0.tar.bz2 12864733
diff --git a/kde-base/kpilot/kpilot-3.5.0.ebuild b/kde-base/kpilot/kpilot-3.5.0.ebuild
new file mode 100644
index 000000000000..55eaa8c8d63a
--- /dev/null
+++ b/kde-base/kpilot/kpilot-3.5.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kpilot/kpilot-3.5.0.ebuild,v 1.1 2005/11/22 22:14:11 danarmak Exp $
+
+KMNAME=kdepim
+MAXKDEVER=$PV
+KM_DEPRANGE="$PV $MAXKDEVER"
+inherit kde-meta eutils
+
+DESCRIPTION="KPilot - HotSync software for KDE"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+DEPEND="app-pda/pilot-link
+ dev-libs/libmal
+$(deprange $PV $MAXKDEVER kde-base/libkcal)
+$(deprange $PV $MAXKDEVER kde-base/libkdepim)
+$(deprange $PV $MAXKDEVER kde-base/kontact)"
+
+KMCOPYLIB="
+ libkcal libkcal
+ libkdepim libkdepim
+ libkpinterfaces kontact/interfaces"
+# libkcal is installed because a lot of headers are needed, but it don't have to be compiled
+KMEXTRACTONLY="
+ libkcal/
+ libkdepim libkdepim/
+ kontact/interfaces/"
+KMEXTRA="
+ kfile-plugins/palm-databases
+ kontact/plugins/kpilot/" # We add here the kontact's plugin instead of compiling it with kontact because it needs a lot of this programs deps.
+
+src_compile() {
+ # needed to detect pi-notepad.h, used by the kpilot notepad conduit.
+ myconf="${myconf} --with-extra-includes=/usr/include/libpisock"
+
+ kde-meta_src_compile
+}