summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2011-01-26 20:29:26 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2011-01-26 20:29:26 +0000
commitb55417d98c3ac6be2310a3971632cceac43c9378 (patch)
tree76ff040300cffb0bfdb60a4c1a785df48fbbf7cd /kde-base/ksysguard
parent[profiles] Mask marble with gps on ppc64 (diff)
downloadgentoo-2-b55417d98c3ac6be2310a3971632cceac43c9378.tar.gz
gentoo-2-b55417d98c3ac6be2310a3971632cceac43c9378.tar.bz2
gentoo-2-b55417d98c3ac6be2310a3971632cceac43c9378.zip
[kde-base] Add KDE SC 4.6.0
(Portage version: 2.2.0_alpha19_p2/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'kde-base/ksysguard')
-rw-r--r--kde-base/ksysguard/ChangeLog7
-rw-r--r--kde-base/ksysguard/ksysguard-4.6.0.ebuild44
2 files changed, 50 insertions, 1 deletions
diff --git a/kde-base/ksysguard/ChangeLog b/kde-base/ksysguard/ChangeLog
index 676272c8997e..27f5be60ed02 100644
--- a/kde-base/ksysguard/ChangeLog
+++ b/kde-base/ksysguard/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/ksysguard
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/ksysguard/ChangeLog,v 1.193 2011/01/10 11:53:42 tampakrap Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ksysguard/ChangeLog,v 1.194 2011/01/26 20:28:36 alexxy Exp $
+
+*ksysguard-4.6.0 (26 Jan 2011)
+
+ 26 Jan 2011; Alexey Shvetsov <alexxy@gentoo.org> +ksysguard-4.6.0.ebuild:
+ Version bump KDE SC 4.6.0
*ksysguard-4.5.5 (10 Jan 2011)
diff --git a/kde-base/ksysguard/ksysguard-4.6.0.ebuild b/kde-base/ksysguard/ksysguard-4.6.0.ebuild
new file mode 100644
index 000000000000..2e0cf5c0c201
--- /dev/null
+++ b/kde-base/ksysguard/ksysguard-4.6.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ksysguard/ksysguard-4.6.0.ebuild,v 1.1 2011/01/26 20:28:36 alexxy Exp $
+
+EAPI="3"
+
+KDE_HANDBOOK="optional"
+KMNAME="kdebase-workspace"
+CPPUNIT_REQUIRED="optional"
+VIRTUALX_REQUIRED="optional"
+inherit kde4-meta
+
+DESCRIPTION="KSysguard is a network enabled task manager and system monitor application."
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug lm_sensors test"
+
+COMMONDEPEND="
+ x11-libs/libXrender
+ x11-libs/libXres
+ lm_sensors? ( sys-apps/lm_sensors )
+"
+DEPEND="${COMMONDEPEND}
+ x11-proto/renderproto
+"
+RDEPEND="${COMMONDEPEND}"
+
+KMEXTRA="
+ libs/ksysguard/
+"
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with lm_sensors Sensors)
+ )
+
+ kde4-meta_src_configure
+}
+
+pkg_postinst() {
+ kde4-meta_pkg_postinst
+ ewarn "Note that ksysguard has powerful features; one of these is the executing of arbitrary"
+ ewarn "programs with elevated privileges (as data sources). So be careful opening worksheets"
+ ewarn "from untrusted sources!"
+}