summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2013-12-03 22:36:09 +0000
committerJohannes Huber <johu@gentoo.org>2013-12-03 22:36:09 +0000
commit318092ea225b3d6ad7192e8ae024a631e482b266 (patch)
tree91df8808be8c8389bc73293ff837135ae83c78e3 /kde-base/ksystemlog
parentUpdate init file /var/run/apcupsd directory > /run/apcupsd (diff)
downloadgentoo-2-318092ea225b3d6ad7192e8ae024a631e482b266.tar.gz
gentoo-2-318092ea225b3d6ad7192e8ae024a631e482b266.tar.bz2
gentoo-2-318092ea225b3d6ad7192e8ae024a631e482b266.zip
Version bump KDE SC 4.11.4
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key F3CFD2BD)
Diffstat (limited to 'kde-base/ksystemlog')
-rw-r--r--kde-base/ksystemlog/ChangeLog7
-rw-r--r--kde-base/ksystemlog/ksystemlog-4.11.4.ebuild32
2 files changed, 38 insertions, 1 deletions
diff --git a/kde-base/ksystemlog/ChangeLog b/kde-base/ksystemlog/ChangeLog
index 0eee5b2000d7..8e2d04ac32f0 100644
--- a/kde-base/ksystemlog/ChangeLog
+++ b/kde-base/ksystemlog/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/ksystemlog
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/ksystemlog/ChangeLog,v 1.175 2013/11/05 22:22:53 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ksystemlog/ChangeLog,v 1.176 2013/12/03 22:35:42 johu Exp $
+
+*ksystemlog-4.11.4 (03 Dec 2013)
+
+ 03 Dec 2013; Johannes Huber <johu@gentoo.org> +ksystemlog-4.11.4.ebuild:
+ Version bump KDE SC 4.11.4
*ksystemlog-4.11.3 (05 Nov 2013)
diff --git a/kde-base/ksystemlog/ksystemlog-4.11.4.ebuild b/kde-base/ksystemlog/ksystemlog-4.11.4.ebuild
new file mode 100644
index 000000000000..b9cbffdbde0e
--- /dev/null
+++ b/kde-base/ksystemlog/ksystemlog-4.11.4.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ksystemlog/ksystemlog-4.11.4.ebuild,v 1.1 2013/12/03 22:35:43 johu Exp $
+
+EAPI=5
+
+KDE_HANDBOOK="optional"
+VIRTUALX_REQUIRED=test
+inherit kde4-base
+
+DESCRIPTION="KDE system log viewer"
+HOMEPAGE="http://www.kde.org/applications/system/ksystemlog/"
+KEYWORDS=" ~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug test"
+
+RESTRICT=test
+# bug 378101
+
+src_prepare() {
+ kde4-base_src_prepare
+
+ if use test; then
+ # beat this stupid test into shape: the test files contain no year, so
+ # comparison succeeds only in 2007 !!!
+ local theyear=$(date +%Y)
+ einfo Setting the current year as ${theyear} in the test files
+ sed -e "s:2007:${theyear}:g" -i tests/systemAnalyzerTest.cpp
+
+ # one test consistently fails, so comment it out for the moment
+ sed -e "s:systemAnalyzerTest:# dont run systemAnalyzerTest:g" -i ksystemlog/tests/CMakeLists.txt
+ fi
+}