summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2013-04-06 00:05:07 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2013-04-06 00:05:07 +0000
commitc106175041331c114244227a14b1c3242fe799ee (patch)
treee16e2d4ee461b8ac893f1113d86a29e0b20658b8 /kde-base/ksystemlog
parentAdd patch to support >=gtk-2.24.0. #460714 (diff)
downloadgentoo-2-c106175041331c114244227a14b1c3242fe799ee.tar.gz
gentoo-2-c106175041331c114244227a14b1c3242fe799ee.tar.bz2
gentoo-2-c106175041331c114244227a14b1c3242fe799ee.zip
Version bump KDE SC 4.10.2
(Portage version: 2.2.0_alpha171/cvs/Linux x86_64, RepoMan options: --force, signed Manifest commit with key EBE6A336BE19039C!)
Diffstat (limited to 'kde-base/ksystemlog')
-rw-r--r--kde-base/ksystemlog/ChangeLog8
-rw-r--r--kde-base/ksystemlog/ksystemlog-4.10.2.ebuild33
2 files changed, 40 insertions, 1 deletions
diff --git a/kde-base/ksystemlog/ChangeLog b/kde-base/ksystemlog/ChangeLog
index 6883e11fa4d4..9b4e661ecee2 100644
--- a/kde-base/ksystemlog/ChangeLog
+++ b/kde-base/ksystemlog/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/ksystemlog
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/ksystemlog/ChangeLog,v 1.145 2013/04/02 20:51:36 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ksystemlog/ChangeLog,v 1.146 2013/04/06 00:04:30 dilfridge Exp $
+
+*ksystemlog-4.10.2 (05 Apr 2013)
+
+ 05 Apr 2013; Andreas K. Huettel <dilfridge@gentoo.org>
+ +ksystemlog-4.10.2.ebuild:
+ Version bump KDE SC 4.10.2
02 Apr 2013; Agostino Sarubbo <ago@gentoo.org> ksystemlog-4.10.1.ebuild:
Stable for ppc64, wrt to bug #462890
diff --git a/kde-base/ksystemlog/ksystemlog-4.10.2.ebuild b/kde-base/ksystemlog/ksystemlog-4.10.2.ebuild
new file mode 100644
index 000000000000..1c70cf8be2bf
--- /dev/null
+++ b/kde-base/ksystemlog/ksystemlog-4.10.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ksystemlog/ksystemlog-4.10.2.ebuild,v 1.1 2013/04/06 00:04:30 dilfridge Exp $
+
+EAPI=5
+
+KDE_HANDBOOK="optional"
+KMNAME="kdeadmin"
+KDE_SCM="svn"
+VIRTUALX_REQUIRED=test
+inherit kde4-meta
+
+DESCRIPTION="KDE system log viewer"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug test"
+
+RESTRICT=test
+# bug 378101
+
+src_prepare() {
+ kde4-meta_src_prepare
+
+ if use test; then
+ # beat this stupid test into shape: the test files contain no year, so
+ # comparison succeeds only in 2007 !!!
+ local theyear=$(date +%Y)
+ einfo Setting the current year as ${theyear} in the test files
+ sed -e "s:2007:${theyear}:g" -i ksystemlog/tests/systemAnalyzerTest.cpp
+
+ # one test consistently fails, so comment it out for the moment
+ sed -e "s:systemAnalyzerTest:# dont run systemAnalyzerTest:g" -i ksystemlog/tests/CMakeLists.txt
+ fi
+}