summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2009-05-07 00:05:10 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2009-05-07 00:05:10 +0000
commitdf444db92f13269132e9d10abdadb7fdb330d030 (patch)
treeab59384202f5556e2b49f2b2d3f1973b5c1fdb3d /kde-base/kwin
parentVersion bump KDE 4.2.3 (diff)
downloadgentoo-2-df444db92f13269132e9d10abdadb7fdb330d030.tar.gz
gentoo-2-df444db92f13269132e9d10abdadb7fdb330d030.tar.bz2
gentoo-2-df444db92f13269132e9d10abdadb7fdb330d030.zip
Version bump KDE 4.2.3
(Portage version: 2.2_rc31/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'kde-base/kwin')
-rw-r--r--kde-base/kwin/ChangeLog7
-rw-r--r--kde-base/kwin/kwin-4.2.3.ebuild49
2 files changed, 55 insertions, 1 deletions
diff --git a/kde-base/kwin/ChangeLog b/kde-base/kwin/ChangeLog
index 664be57cf9f6..3be5fbb369a4 100644
--- a/kde-base/kwin/ChangeLog
+++ b/kde-base/kwin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kwin
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kwin/ChangeLog,v 1.147 2009/04/17 06:16:30 alexxy Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kwin/ChangeLog,v 1.148 2009/05/07 00:05:10 scarabeus Exp $
+
+*kwin-4.2.3 (07 May 2009)
+
+ 07 May 2009; Tomas Chvatal <scarabeus@gentoo.org> +kwin-4.2.3.ebuild:
+ Version bump
17 Apr 2009; Alexey Shvetsov <alexxy@gentoo.org> -kwin-4.2.1.ebuild:
Restore ~hppa keywords
diff --git a/kde-base/kwin/kwin-4.2.3.ebuild b/kde-base/kwin/kwin-4.2.3.ebuild
new file mode 100644
index 000000000000..5b27119450fe
--- /dev/null
+++ b/kde-base/kwin/kwin-4.2.3.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kwin/kwin-4.2.3.ebuild,v 1.1 2009/05/07 00:05:10 scarabeus Exp $
+
+EAPI="2"
+
+KMNAME="kdebase-workspace"
+OPENGL_REQUIRED="optional"
+inherit kde4-meta
+
+DESCRIPTION="KDE window manager"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="debug captury xcomposite xinerama"
+
+COMMONDEPEND="
+ >=kde-base/kephal-${PV}:${SLOT}[kdeprefix=]
+ x11-libs/libXdamage
+ x11-libs/libXfixes
+ >=x11-libs/libXrandr-1.2.1
+ x11-libs/libXrender
+ captury? ( media-libs/libcaptury )
+ opengl? ( virtual/opengl )
+ xcomposite? ( x11-libs/libXcomposite )
+ xinerama? ( x11-libs/libXinerama )
+"
+DEPEND="${COMMONDEPEND}
+ x11-proto/damageproto
+ x11-proto/renderproto
+ xcomposite? ( x11-proto/compositeproto )
+ xinerama? ( x11-proto/xineramaproto )
+"
+RDEPEND="${COMMONDEPEND}"
+
+src_prepare() {
+ if ! use captury; then
+ sed -e 's:^PKGCONFIG..libcaptury:#DONOTFIND &:' \
+ -i "${S}"/kwin/effects/CMakeLists.txt || \
+ die "Making captury optional failed."
+ fi
+
+ kde4-meta_src_prepare
+}
+
+src_configure() {
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_with opengl OpenGL)"
+
+ kde4-meta_src_configure
+}