summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2012-04-04 23:59:39 +0000
committerJohannes Huber <johu@gentoo.org>2012-04-04 23:59:39 +0000
commitb31cc0441f4628bad93065beae2d74cb436c08c6 (patch)
treeb946ea6b122ad7c1de4b8c58dc400606f74fb540 /kde-base/perlqt
parentdev-libs/uriparser: 0.7.7 (diff)
downloadgentoo-2-b31cc0441f4628bad93065beae2d74cb436c08c6.tar.gz
gentoo-2-b31cc0441f4628bad93065beae2d74cb436c08c6.tar.bz2
gentoo-2-b31cc0441f4628bad93065beae2d74cb436c08c6.zip
Version bump KDE SC 4.8.2
(Portage version: 2.2.0_alpha98/cvs/Linux i686)
Diffstat (limited to 'kde-base/perlqt')
-rw-r--r--kde-base/perlqt/ChangeLog7
-rw-r--r--kde-base/perlqt/perlqt-4.8.2.ebuild55
2 files changed, 61 insertions, 1 deletions
diff --git a/kde-base/perlqt/ChangeLog b/kde-base/perlqt/ChangeLog
index 2b9a9ff45325..7c4c414a701f 100644
--- a/kde-base/perlqt/ChangeLog
+++ b/kde-base/perlqt/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/perlqt
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/perlqt/ChangeLog,v 1.26 2012/04/04 19:17:49 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/perlqt/ChangeLog,v 1.27 2012/04/04 23:59:36 johu Exp $
+
+*perlqt-4.8.2 (04 Apr 2012)
+
+ 04 Apr 2012; Johannes Huber <johu@gentoo.org> +perlqt-4.8.2.ebuild:
+ Version bump KDE SC 4.8.2
04 Apr 2012; Agostino Sarubbo <ago@gentoo.org> perlqt-4.8.1.ebuild:
Stable for amd64, wrt bug #409403
diff --git a/kde-base/perlqt/perlqt-4.8.2.ebuild b/kde-base/perlqt/perlqt-4.8.2.ebuild
new file mode 100644
index 000000000000..fc14ebd8a889
--- /dev/null
+++ b/kde-base/perlqt/perlqt-4.8.2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/perlqt/perlqt-4.8.2.ebuild,v 1.1 2012/04/04 23:59:36 johu Exp $
+
+EAPI=4
+
+DECLARATIVE_REQUIRED="optional"
+MULTIMEDIA_REQUIRED="optional"
+OPENGL_REQUIRED="optional"
+QTHELP_REQUIRED="optional"
+KDE_REQUIRED="never"
+KDE_SCM="git"
+inherit kde4-base
+
+DESCRIPTION="Qt Perl bindings"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug phonon qimageblitz qscintilla qwt webkit"
+
+RDEPEND="
+ >=dev-lang/perl-5.10.1
+ dev-perl/List-MoreUtils
+ $(add_kdebase_dep smokeqt 'declarative?,multimedia?,opengl?,phonon?,qimageblitz?,qscintilla?,qthelp?,qwt?,webkit?')
+"
+DEPEND=${RDEPEND}
+
+# Split from kdebindings-perl in 4.7
+add_blocker kdebindings-perl
+
+PATCHES=(
+ "${FILESDIR}/${PN}-4.7.2-vendor.patch"
+ "${FILESDIR}/${PN}-4.8.1-tests.patch"
+)
+
+# more failures
+RESTRICT=test
+
+src_configure() {
+ local mycmakeargs=(
+ -DDISABLE_Qt3Support=ON
+ $(cmake-utils_use_disable declarative QtDeclarative)
+ $(cmake-utils_use_disable multimedia QtMultimedia)
+ $(cmake-utils_use_disable opengl QtOpenGL)
+ $(cmake-utils_use_with phonon)
+ $(cmake-utils_use_with qimageblitz QImageBlitz)
+ $(cmake-utils_use_with qscintilla QScintilla)
+ $(cmake-utils_use_disable qthelp QtHelp)
+ $(cmake-utils_use_disable qwt)
+ $(cmake-utils_use_disable webkit QtWebKit)
+ )
+ kde4-base_src_configure
+}
+
+src_test() {
+ PERL5LIB="${CMAKE_BUILD_DIR}/blib/arch:${CMAKE_BUILD_DIR}/blib/lib" kde4-base_src_test
+}