summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2011-07-09 15:14:29 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2011-07-09 15:14:29 +0000
commit198ce394c73bbfe7e1f269f6e39a5a98cab823a2 (patch)
tree4491916cd89010371521f0c68a631a977483b823 /kde-base/pykde4
parentBump to an up-to-date version, and add maintainer (diff)
downloadgentoo-2-198ce394c73bbfe7e1f269f6e39a5a98cab823a2.tar.gz
gentoo-2-198ce394c73bbfe7e1f269f6e39a5a98cab823a2.tar.bz2
gentoo-2-198ce394c73bbfe7e1f269f6e39a5a98cab823a2.zip
[kde-base] Add KDE SC 4.6.5
(Portage version: 2.2.0_alpha43/cvs/Linux x86_64)
Diffstat (limited to 'kde-base/pykde4')
-rw-r--r--kde-base/pykde4/ChangeLog8
-rw-r--r--kde-base/pykde4/files/kpythonpluginfactorywrapper.c52
-rw-r--r--kde-base/pykde4/pykde4-4.6.5-r1.ebuild172
3 files changed, 231 insertions, 1 deletions
diff --git a/kde-base/pykde4/ChangeLog b/kde-base/pykde4/ChangeLog
index 772e4b948eda..0648ef8c5dde 100644
--- a/kde-base/pykde4/ChangeLog
+++ b/kde-base/pykde4/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/pykde4
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/pykde4/ChangeLog,v 1.121 2011/07/06 20:05:44 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/pykde4/ChangeLog,v 1.122 2011/07/09 15:14:06 alexxy Exp $
+
+*pykde4-4.6.5-r1 (09 Jul 2011)
+
+ 09 Jul 2011; Alexey Shvetsov <alexxy@gentoo.org> +pykde4-4.6.5-r1.ebuild,
+ +files/kpythonpluginfactorywrapper.c:
+ Version bump KDE SC 4.6.5
06 Jul 2011; Andreas K. Huettel <dilfridge@gentoo.org> -pykde4-4.6.2.ebuild:
Drop KDE 4.6.2
diff --git a/kde-base/pykde4/files/kpythonpluginfactorywrapper.c b/kde-base/pykde4/files/kpythonpluginfactorywrapper.c
new file mode 100644
index 000000000000..3915a0d122be
--- /dev/null
+++ b/kde-base/pykde4/files/kpythonpluginfactorywrapper.c
@@ -0,0 +1,52 @@
+#include <dlfcn.h>
+#include <stdio.h>
+#include <stdlib.h>
+#include <string.h>
+#include <unistd.h>
+
+#define VERSION_LEN 10
+
+#define FORMAT EPREFIX PLUGIN_DIR "/kpython%spluginfactory.so"
+
+static void *handle;
+static void *(*wrapped_qt_plugin_instance)();
+
+static void get_python_version(char* out) {
+ int pipefd[2];
+ pipe(pipefd);
+ pid_t cpid = fork();
+ if (cpid == 0) {
+ close(pipefd[1]);
+ read(pipefd[0], out, VERSION_LEN);
+ } else {
+ close(pipefd[0]);
+ close(1);
+ dup2(pipefd[1], 1);
+ close(pipefd[1]);
+ close(0);
+ char *args[] = { "eselect", "python", "show", "--ABI", "--python2", 0 };
+ execv(EPREFIX "/usr/bin/eselect", args);
+ }
+}
+
+__attribute__((constructor))
+static void init() {
+ char buf[VERSION_LEN + 1];
+ memset(buf, 0, VERSION_LEN + 1);
+ get_python_version(buf);
+ int length = strlen(FORMAT) + strlen(buf) + 1;
+ char *name = malloc(length + 1);
+ snprintf(name, length, FORMAT, buf);
+ void *handle = dlopen(name, RTLD_NOW);
+ free(name);
+ wrapped_qt_plugin_instance = dlsym(handle, "qt_plugin_instance");
+}
+
+__attribute__((destructor))
+static void fini() {
+ dlclose(handle);
+}
+
+void *qt_plugin_instance() {
+ return wrapped_qt_plugin_instance();
+}
diff --git a/kde-base/pykde4/pykde4-4.6.5-r1.ebuild b/kde-base/pykde4/pykde4-4.6.5-r1.ebuild
new file mode 100644
index 000000000000..ec274e0e7d60
--- /dev/null
+++ b/kde-base/pykde4/pykde4-4.6.5-r1.ebuild
@@ -0,0 +1,172 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/pykde4/pykde4-4.6.5-r1.ebuild,v 1.1 2011/07/09 15:14:06 alexxy Exp $
+
+EAPI=3
+
+PYTHON_DEPEND="*:2.5"
+RESTRICT_PYTHON_ABIS="*-jython 2.4"
+PYTHON_USE_WITH="threads"
+SUPPORT_PYTHON_ABIS="1"
+
+OPENGL_REQUIRED="always"
+KDE_SCM="git"
+if [[ ${PV} == *9999 ]]; then
+ KMMODULE="."
+ kde_eclass="kde4-base"
+else
+ KMNAME="kdebindings"
+ KMMODULE="python/pykde4"
+ kde_eclass="kde4-meta"
+fi
+
+inherit python portability ${kde_eclass}
+
+DESCRIPTION="Python bindings for KDE4"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug doc examples semantic-desktop"
+
+# blocker added due to compatibility issues and error during compile time
+RDEPEND="
+ !dev-python/pykde
+ >=dev-python/sip-4.12
+ $(add_kdebase_dep kdelibs 'opengl,semantic-desktop=')
+ semantic-desktop? ( $(add_kdebase_dep kdepimlibs 'semantic-desktop') )
+ aqua? ( >=dev-python/PyQt4-4.8.2[dbus,declarative,sql,svg,webkit,aqua] )
+ !aqua? ( >=dev-python/PyQt4-4.8.2[dbus,declarative,sql,svg,webkit,X] )
+"
+DEPEND="${RDEPEND}
+ sys-devel/libtool
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.6.4-pyqt475.patch
+ "${FILESDIR}"/${PN}-4.6.3-python-3.2.patch
+)
+
+pkg_setup() {
+ python_pkg_setup
+ ${kde_eclass}_pkg_setup
+
+ have_python2=false
+
+ scan_python_versions() {
+ [[ ${PYTHON_ABI} == 2.* ]] && have_python2=true
+ :
+ }
+ python_execute_function -q scan_python_versions
+ if ! ${have_python2}; then
+ ewarn "You do not have a Python 2 version selected."
+ ewarn "kpythonpluginfactory will not be built"
+ fi
+}
+
+src_prepare() {
+ ${kde_eclass}_src_prepare
+
+ if ! use examples; then
+ sed -e '/^ADD_SUBDIRECTORY(examples)/s/^/# DISABLED /' -i ${KMMODULE}/CMakeLists.txt \
+ || die "Failed to disable examples"
+ fi
+
+ # See bug 322351
+ use arm && epatch "${FILESDIR}/${PN}-4.4.4-arm-sip.patch"
+
+ sed -i -e 's/kpythonpluginfactory /kpython${PYTHON_SHORT_VERSION}pluginfactory /g' ${KMMODULE}/kpythonpluginfactory/CMakeLists.txt
+
+ if ${have_python2}; then
+ mkdir -p "${WORKDIR}/wrapper" || die "failed to copy wrapper"
+ cp "${FILESDIR}/kpythonpluginfactorywrapper.c" "${WORKDIR}/wrapper" || die "failed to copy wrapper"
+ fi
+}
+
+src_configure() {
+ # Required for KTabWidget::label
+ append-cxxflags -DKDE3_SUPPORT
+
+ configuration() {
+ local mycmakeargs=(
+ -DWITH_PolkitQt=OFF
+ -DWITH_QScintilla=OFF
+ $(cmake-utils_use_with semantic-desktop Soprano)
+ $(cmake-utils_use_with semantic-desktop Nepomuk)
+ $(cmake-utils_use_with semantic-desktop KdepimLibs)
+ -DPYTHON_EXECUTABLE=$(PYTHON -a)
+ )
+ local CMAKE_BUILD_DIR=${S}_build-${PYTHON_ABI}
+ ${kde_eclass}_src_configure
+ }
+
+ python_execute_function configuration
+}
+
+echo_and_run() {
+ echo "$@"
+ "$@"
+}
+
+src_compile() {
+ compilation() {
+ local CMAKE_BUILD_DIR=${S}_build-${PYTHON_ABI}
+ ${kde_eclass}_src_compile
+ }
+ python_execute_function compilation
+
+ if ${have_python2}; then
+ cd "${WORKDIR}/wrapper"
+ echo_and_run libtool --tag=CC --mode=compile $(tc-getCC) \
+ -shared \
+ ${CFLAGS} ${CPPFLAGS} \
+ -DEPREFIX="\"${EPREFIX}\"" \
+ -DPLUGIN_DIR="\"/usr/$(get_libdir)/kde4\"" -c \
+ -o kpythonpluginfactorywrapper.lo \
+ kpythonpluginfactorywrapper.c
+ echo_and_run libtool --tag=CC --mode=link $(tc-getCC) \
+ -shared -module -avoid-version \
+ ${CFLAGS} ${LDFLAGS} \
+ -o kpythonpluginfactory.la \
+ -rpath "${EPREFIX}/usr/$(get_libdir)/kde4" \
+ kpythonpluginfactorywrapper.lo \
+ $(dlopen_lib)
+ fi
+}
+
+src_install() {
+ installation() {
+ cd "${S}_build-${PYTHON_ABI}"
+ emake DESTDIR="${T}/images/${PYTHON_ABI}" install || die "emake install failed for Python ${PYTHON_ABI}"
+ }
+ python_execute_function installation
+
+ python_merge_intermediate_installation_images "${T}/images/${PYTHON_ABI}"
+
+ # As we don't call the eclass's src_install, we have to install the docs manually
+ DOCS=("${S}"/${KMMODULE}/{AUTHORS,NEWS,README})
+ use doc && HTML_DOCS=("${S}/${KMMODULE}/docs/html/")
+ base_src_install_docs
+
+ if ${have_python2}; then
+ cd "${WORKDIR}/wrapper"
+ echo_and_run libtool --mode=install install kpythonpluginfactory.la "${ED}/usr/$(get_libdir)/kde4/kpythonpluginfactory.la"
+ rm "${ED}/usr/$(get_libdir)/kde4/kpythonpluginfactory.la"
+ fi
+}
+
+pkg_postinst() {
+ ${kde_eclass}_pkg_postinst
+
+ python_mod_optimize PyKDE4 PyQt4/uic/pykdeuic4.py PyQt4/uic/widget-plugins/kde4.py
+
+ if use examples; then
+ echo
+ elog "PyKDE4 examples have been installed to"
+ elog "${EPREFIX}/usr/share/apps/${PN}/examples"
+ echo
+ fi
+}
+
+pkg_postrm() {
+ ${kde_eclass}_pkg_postrm
+
+ python_mod_cleanup PyKDE4 PyQt4/uic/pykdeuic4.py PyQt4/uic/widget-plugins/kde4.py
+}