summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Reffett <creffett@gentoo.org>2014-01-10 04:22:20 +0000
committerChris Reffett <creffett@gentoo.org>2014-01-10 04:22:20 +0000
commit803efb3b1f3061a26772f670a2e44a59efbf3f3f (patch)
tree82f2adcff5045d9821efd3318efe2cacf46c43ea /kde-base/qyoto
parent0.7.5 bump (diff)
downloadgentoo-2-803efb3b1f3061a26772f670a2e44a59efbf3f3f.tar.gz
gentoo-2-803efb3b1f3061a26772f670a2e44a59efbf3f3f.tar.bz2
gentoo-2-803efb3b1f3061a26772f670a2e44a59efbf3f3f.zip
Bump KDE SC 4.11.5
(Portage version: 2.2.8/cvs/Linux x86_64, RepoMan options: --force, signed Manifest commit with key 42618354)
Diffstat (limited to 'kde-base/qyoto')
-rw-r--r--kde-base/qyoto/ChangeLog9
-rw-r--r--kde-base/qyoto/qyoto-4.11.5.ebuild33
2 files changed, 40 insertions, 2 deletions
diff --git a/kde-base/qyoto/ChangeLog b/kde-base/qyoto/ChangeLog
index b2dca924beb1..856d42cf769d 100644
--- a/kde-base/qyoto/ChangeLog
+++ b/kde-base/qyoto/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/qyoto
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/qyoto/ChangeLog,v 1.97 2013/12/18 19:57:44 johu Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/qyoto/ChangeLog,v 1.98 2014/01/10 04:22:09 creffett Exp $
+
+*qyoto-4.11.5 (10 Jan 2014)
+
+ 10 Jan 2014; Chris Reffett <creffett@gentoo.org> +qyoto-4.11.5.ebuild:
+ Bump KDE SC 4.11.5
*qyoto-4.12.0 (18 Dec 2013)
diff --git a/kde-base/qyoto/qyoto-4.11.5.ebuild b/kde-base/qyoto/qyoto-4.11.5.ebuild
new file mode 100644
index 000000000000..9cd7603ccc47
--- /dev/null
+++ b/kde-base/qyoto/qyoto-4.11.5.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/qyoto/qyoto-4.11.5.ebuild,v 1.1 2014/01/10 04:22:09 creffett Exp $
+
+EAPI=5
+
+KDE_REQUIRED="never"
+inherit mono-env kde4-base
+
+DESCRIPTION="C# bindings for Qt"
+KEYWORDS=" ~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug +phonon qscintilla webkit"
+HOMEPAGE="http://techbase.kde.org/Development/Languages/Qyoto"
+
+DEPEND="
+ dev-lang/mono
+ $(add_kdebase_dep smokeqt 'opengl,phonon?,qscintilla?,webkit?')
+"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ mono-env_pkg_setup
+ kde4-base_pkg_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_with phonon)
+ $(cmake-utils_use_disable qscintilla QScintilla)
+ $(cmake-utils_use_disable webkit QtWebKit)
+ )
+ kde4-base_src_configure
+}