summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2013-12-18 19:58:23 +0000
committerJohannes Huber <johu@gentoo.org>2013-12-18 19:58:23 +0000
commit885ecb4a69485d6d2cbb21c20f0dc4cf4f20995c (patch)
treea746d61b035d298b8c5f5bdb7a403546a6c68fe7 /kde-base/qyoto
parentMask >=kde-base/kopete-4.12.0[otr] because of package mask on >=net-libs/libo... (diff)
downloadgentoo-2-885ecb4a69485d6d2cbb21c20f0dc4cf4f20995c.tar.gz
gentoo-2-885ecb4a69485d6d2cbb21c20f0dc4cf4f20995c.tar.bz2
gentoo-2-885ecb4a69485d6d2cbb21c20f0dc4cf4f20995c.zip
Version bump KDE SC 4.12.0
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key F3CFD2BD)
Diffstat (limited to 'kde-base/qyoto')
-rw-r--r--kde-base/qyoto/ChangeLog7
-rw-r--r--kde-base/qyoto/qyoto-4.12.0.ebuild33
2 files changed, 39 insertions, 1 deletions
diff --git a/kde-base/qyoto/ChangeLog b/kde-base/qyoto/ChangeLog
index 30bd2e5e93b8..b2dca924beb1 100644
--- a/kde-base/qyoto/ChangeLog
+++ b/kde-base/qyoto/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/qyoto
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/qyoto/ChangeLog,v 1.96 2013/12/12 03:37:33 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/qyoto/ChangeLog,v 1.97 2013/12/18 19:57:44 johu Exp $
+
+*qyoto-4.12.0 (18 Dec 2013)
+
+ 18 Dec 2013; Johannes Huber <johu@gentoo.org> +qyoto-4.12.0.ebuild:
+ Version bump KDE SC 4.12.0
12 Dec 2013; Agostino Sarubbo <ago@gentoo.org> -qyoto-4.10.5.ebuild:
Remove old
diff --git a/kde-base/qyoto/qyoto-4.12.0.ebuild b/kde-base/qyoto/qyoto-4.12.0.ebuild
new file mode 100644
index 000000000000..e0d9f292b792
--- /dev/null
+++ b/kde-base/qyoto/qyoto-4.12.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/qyoto/qyoto-4.12.0.ebuild,v 1.1 2013/12/18 19:57:44 johu Exp $
+
+EAPI=5
+
+KDE_REQUIRED="never"
+inherit mono-env kde4-base
+
+DESCRIPTION="C# bindings for Qt"
+KEYWORDS=" ~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug +phonon qscintilla webkit"
+HOMEPAGE="http://techbase.kde.org/Development/Languages/Qyoto"
+
+DEPEND="
+ dev-lang/mono
+ $(add_kdebase_dep smokeqt 'opengl,phonon?,qscintilla?,webkit?')
+"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ mono-env_pkg_setup
+ kde4-base_pkg_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_with phonon)
+ $(cmake-utils_use_disable qscintilla QScintilla)
+ $(cmake-utils_use_disable webkit QtWebKit)
+ )
+ kde4-base_src_configure
+}