summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2013-06-04 18:22:23 +0000
committerJohannes Huber <johu@gentoo.org>2013-06-04 18:22:23 +0000
commit20f55f8fb805f8021dd9ded690b2815eb78ffc4f (patch)
tree80067b7b6ce35f4bffa5921e939a528f7d1cae22 /kde-base/smokeqt
parentVersion bump. (diff)
downloadgentoo-2-20f55f8fb805f8021dd9ded690b2815eb78ffc4f.tar.gz
gentoo-2-20f55f8fb805f8021dd9ded690b2815eb78ffc4f.tar.bz2
gentoo-2-20f55f8fb805f8021dd9ded690b2815eb78ffc4f.zip
Version bump KDE SC 4.10.4
(Portage version: 2.2.0_alpha177/cvs/Linux x86_64, signed Manifest commit with key F3CFD2BD)
Diffstat (limited to 'kde-base/smokeqt')
-rw-r--r--kde-base/smokeqt/ChangeLog7
-rw-r--r--kde-base/smokeqt/smokeqt-4.10.4.ebuild55
2 files changed, 61 insertions, 1 deletions
diff --git a/kde-base/smokeqt/ChangeLog b/kde-base/smokeqt/ChangeLog
index 6114fb00dbb4..b636d78715cc 100644
--- a/kde-base/smokeqt/ChangeLog
+++ b/kde-base/smokeqt/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/smokeqt
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/smokeqt/ChangeLog,v 1.71 2013/06/04 13:06:36 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/smokeqt/ChangeLog,v 1.72 2013/06/04 18:21:39 johu Exp $
+
+*smokeqt-4.10.4 (04 Jun 2013)
+
+ 04 Jun 2013; Johannes Huber <johu@gentoo.org> +smokeqt-4.10.4.ebuild:
+ Version bump KDE SC 4.10.4
04 Jun 2013; Agostino Sarubbo <ago@gentoo.org> smokeqt-4.10.3.ebuild:
Stable for amd64, wrt to bug #471392
diff --git a/kde-base/smokeqt/smokeqt-4.10.4.ebuild b/kde-base/smokeqt/smokeqt-4.10.4.ebuild
new file mode 100644
index 000000000000..292cf5895948
--- /dev/null
+++ b/kde-base/smokeqt/smokeqt-4.10.4.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/smokeqt/smokeqt-4.10.4.ebuild,v 1.1 2013/06/04 18:21:39 johu Exp $
+
+EAPI=5
+
+DECLARATIVE_REQUIRED="optional"
+MULTIMEDIA_REQUIRED="optional"
+QTHELP_REQUIRED="optional"
+OPENGL_REQUIRED="optional"
+KDE_REQUIRED="never"
+
+inherit kde4-base
+
+DESCRIPTION="Scripting Meta Object Kompiler Engine - Qt bindings"
+KEYWORDS=" ~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug +phonon qimageblitz qscintilla qwt webkit"
+
+# Maybe make more of Qt optional?
+DEPEND="
+ $(add_kdebase_dep smokegen)
+ dev-qt/qtcore:4
+ dev-qt/qtdbus:4
+ dev-qt/qtgui:4
+ dev-qt/qtscript:4
+ dev-qt/qtsql:4
+ dev-qt/qtsvg:4
+ dev-qt/qttest:4
+ phonon? ( >=media-libs/phonon-4.4.3 )
+ qimageblitz? ( >=media-libs/qimageblitz-0.0.4 )
+ qscintilla? ( x11-libs/qscintilla:= )
+ qwt? ( x11-libs/qwt:5 )
+ webkit? ( dev-qt/qtwebkit:4 )
+"
+RDEPEND="${DEPEND}"
+
+# Split in 4.7
+add_blocker smoke
+
+src_configure() {
+ mycmakeargs=(
+ -DDISABLE_Qt3Support=ON
+ -DWITH_QT3_SUPPORT=OFF
+ $(cmake-utils_use_disable declarative QtDeclarative)
+ $(cmake-utils_use_disable multimedia QtMultimedia)
+ $(cmake-utils_use_disable opengl QtOpenGL)
+ $(cmake-utils_use_with phonon)
+ $(cmake-utils_use_with qimageblitz QImageBlitz)
+ $(cmake-utils_use_with qscintilla QScintilla)
+ $(cmake-utils_use_disable qthelp QtHelp)
+ $(cmake-utils_use_disable qwt Qwt5)
+ $(cmake-utils_use_disable webkit QtWebKit)
+ )
+ kde4-base_src_configure
+}