summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2013-12-18 19:58:23 +0000
committerJohannes Huber <johu@gentoo.org>2013-12-18 19:58:23 +0000
commit885ecb4a69485d6d2cbb21c20f0dc4cf4f20995c (patch)
treea746d61b035d298b8c5f5bdb7a403546a6c68fe7 /kde-base/superkaramba
parentMask >=kde-base/kopete-4.12.0[otr] because of package mask on >=net-libs/libo... (diff)
downloadgentoo-2-885ecb4a69485d6d2cbb21c20f0dc4cf4f20995c.tar.gz
gentoo-2-885ecb4a69485d6d2cbb21c20f0dc4cf4f20995c.tar.bz2
gentoo-2-885ecb4a69485d6d2cbb21c20f0dc4cf4f20995c.zip
Version bump KDE SC 4.12.0
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key F3CFD2BD)
Diffstat (limited to 'kde-base/superkaramba')
-rw-r--r--kde-base/superkaramba/ChangeLog7
-rw-r--r--kde-base/superkaramba/superkaramba-4.12.0.ebuild42
2 files changed, 48 insertions, 1 deletions
diff --git a/kde-base/superkaramba/ChangeLog b/kde-base/superkaramba/ChangeLog
index 39fd0f3592cf..bca433a6ebb7 100644
--- a/kde-base/superkaramba/ChangeLog
+++ b/kde-base/superkaramba/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/superkaramba
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/superkaramba/ChangeLog,v 1.278 2013/12/12 03:37:35 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/superkaramba/ChangeLog,v 1.279 2013/12/18 19:58:01 johu Exp $
+
+*superkaramba-4.12.0 (18 Dec 2013)
+
+ 18 Dec 2013; Johannes Huber <johu@gentoo.org> +superkaramba-4.12.0.ebuild:
+ Version bump KDE SC 4.12.0
12 Dec 2013; Agostino Sarubbo <ago@gentoo.org> -superkaramba-4.10.5.ebuild:
Remove old
diff --git a/kde-base/superkaramba/superkaramba-4.12.0.ebuild b/kde-base/superkaramba/superkaramba-4.12.0.ebuild
new file mode 100644
index 000000000000..f1d02c386725
--- /dev/null
+++ b/kde-base/superkaramba/superkaramba-4.12.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/superkaramba/superkaramba-4.12.0.ebuild,v 1.1 2013/12/18 19:58:01 johu Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7} )
+inherit python-single-r1 kde4-base
+
+DESCRIPTION="A tool to create interactive applets for the KDE desktop."
+HOMEPAGE="http://www.kde.org/applications/utilities/superkaramba
+http://utils.kde.org/projects/superkaramba"
+KEYWORDS=" ~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug python"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+DEPEND="
+ media-libs/qimageblitz
+ x11-libs/libX11
+ x11-libs/libXrender
+ python? (
+ ${PYTHON_DEPS}
+ $(add_kdebase_dep pykde4 "${PYTHON_USEDEP}")
+ )
+"
+RDEPEND="${DEPEND}
+ python? ( $(add_kdebase_dep krosspython "${PYTHON_USEDEP}") )
+"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+ kde4-base_pkg_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_with python PythonLibs)
+ )
+
+ kde4-base_src_configure
+}