summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarc Schiffbauer <mschiff@gentoo.org>2013-07-04 08:20:28 +0000
committerMarc Schiffbauer <mschiff@gentoo.org>2013-07-04 08:20:28 +0000
commit137235d3f0154a794e76c3908a5a6f5d3f0a6a4b (patch)
tree989aa389e1eb92f966b1542f6036d5eca81ebdf4 /kde-base
parentversion bump, drop old (diff)
downloadgentoo-2-137235d3f0154a794e76c3908a5a6f5d3f0a6a4b.tar.gz
gentoo-2-137235d3f0154a794e76c3908a5a6f5d3f0a6a4b.tar.bz2
gentoo-2-137235d3f0154a794e76c3908a5a6f5d3f0a6a4b.zip
Fix accountwizard autoconfig feature. Backport patch from 4.11 (KDE bug #321927)
(Portage version: 2.2.0_alpha186/cvs/Linux x86_64, signed Manifest commit with key 0x296C6CCA35A64134)
Diffstat (limited to 'kde-base')
-rw-r--r--kde-base/kdepim-runtime/ChangeLog10
-rw-r--r--kde-base/kdepim-runtime/files/kdepim-runtime-4.10.5-fix-autoconfig.patch22
-rw-r--r--kde-base/kdepim-runtime/kdepim-runtime-4.10.5-r1.ebuild (renamed from kde-base/kdepim-runtime/kdepim-runtime-4.10.5.ebuild)3
3 files changed, 33 insertions, 2 deletions
diff --git a/kde-base/kdepim-runtime/ChangeLog b/kde-base/kdepim-runtime/ChangeLog
index aba4a62371ad..6fe3757aaa62 100644
--- a/kde-base/kdepim-runtime/ChangeLog
+++ b/kde-base/kdepim-runtime/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for kde-base/kdepim-runtime
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepim-runtime/ChangeLog,v 1.145 2013/07/02 16:47:22 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepim-runtime/ChangeLog,v 1.146 2013/07/04 08:20:28 mschiff Exp $
+
+*kdepim-runtime-4.10.5-r1 (04 Jul 2013)
+
+ 04 Jul 2013; Marc Schiffbauer <mschiff@gentoo.org>
+ +files/kdepim-runtime-4.10.5-fix-autoconfig.patch,
+ +kdepim-runtime-4.10.5-r1.ebuild, -kdepim-runtime-4.10.5.ebuild:
+ Fix accountwizard autoconfig feature. Backport patch from 4.11 (KDE bug
+ #321927)
*kdepim-runtime-4.10.5 (02 Jul 2013)
diff --git a/kde-base/kdepim-runtime/files/kdepim-runtime-4.10.5-fix-autoconfig.patch b/kde-base/kdepim-runtime/files/kdepim-runtime-4.10.5-fix-autoconfig.patch
new file mode 100644
index 000000000000..3ced22093a23
--- /dev/null
+++ b/kde-base/kdepim-runtime/files/kdepim-runtime-4.10.5-fix-autoconfig.patch
@@ -0,0 +1,22 @@
+commit bb58cdc9dd1a166e886b091602483f20f61c3130
+Author: Montel Laurent <montel@kde.org>
+Date: Thu Jul 4 08:31:35 2013 +0200
+
+ Fix Bug 321927 - autoconfig support not working properly
+
+ FIXED-IN: 4.11
+ BUG: 321927
+
+diff --git a/accountwizard/ispdb/ispdb.cpp b/accountwizard/ispdb/ispdb.cpp
+index 0c04cf2..24d274f 100644
+--- a/accountwizard/ispdb/ispdb.cpp
++++ b/accountwizard/ispdb/ispdb.cpp
+@@ -68,7 +68,7 @@ void Ispdb::lookupInDb()
+ {
+ case IspAutoConfig:
+ {
+- url = KUrl( "http://autoconfig." + mAddr.domain.toLower() + "/mail/config-v1.1.xml" );
++ url = KUrl( "http://autoconfig." + mAddr.domain.toLower() + "/mail/config-v1.1.xml?emailaddress=" + mAddr.asString().toLower() );
+ }
+ break;
+ case IspWellKnow:
diff --git a/kde-base/kdepim-runtime/kdepim-runtime-4.10.5.ebuild b/kde-base/kdepim-runtime/kdepim-runtime-4.10.5-r1.ebuild
index 7a0525f37f98..fe9350b02c0a 100644
--- a/kde-base/kdepim-runtime/kdepim-runtime-4.10.5.ebuild
+++ b/kde-base/kdepim-runtime/kdepim-runtime-4.10.5-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepim-runtime/kdepim-runtime-4.10.5.ebuild,v 1.1 2013/07/02 16:47:22 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepim-runtime/kdepim-runtime-4.10.5-r1.ebuild,v 1.1 2013/07/04 08:20:28 mschiff Exp $
EAPI=5
@@ -35,6 +35,7 @@ RDEPEND="${DEPEND}
add_blocker kdepim-common-libs 4.7.50
src_configure() {
+ epatch "${FILESDIR}/${PN}-4.10.5-fix-autoconfig.patch"
local mycmakeargs=(
$(cmake-utils_use_find_package google LibKGAPI)
$(cmake-utils_use_find_package kolab Libkolab)