summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2012-03-09 09:55:08 +0000
committerAlexis Ballier <aballier@gentoo.org>2012-03-09 09:55:08 +0000
commit4713bdee2ff63f3d6e28b15d08a61c28d691cd27 (patch)
treec887af30f6767e378ea8a06958b2ac4e9c180db0 /kde-base
parentx86 stable wrt bug #400261 (diff)
downloadgentoo-2-4713bdee2ff63f3d6e28b15d08a61c28d691cd27.tar.gz
gentoo-2-4713bdee2ff63f3d6e28b15d08a61c28d691cd27.tar.bz2
gentoo-2-4713bdee2ff63f3d6e28b15d08a61c28d691cd27.zip
fix build with ffmpeg trunk
(Portage version: 2.2.0_alpha90/cvs/Linux x86_64)
Diffstat (limited to 'kde-base')
-rw-r--r--kde-base/ffmpegthumbs/ChangeLog6
-rw-r--r--kde-base/ffmpegthumbs/ffmpegthumbs-4.8.1.ebuild4
-rw-r--r--kde-base/ffmpegthumbs/files/ffmpegthumbs-4.8.1-ffmpeg.patch29
3 files changed, 37 insertions, 2 deletions
diff --git a/kde-base/ffmpegthumbs/ChangeLog b/kde-base/ffmpegthumbs/ChangeLog
index a40252b5e248..d712f3807c70 100644
--- a/kde-base/ffmpegthumbs/ChangeLog
+++ b/kde-base/ffmpegthumbs/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for kde-base/ffmpegthumbs
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/ffmpegthumbs/ChangeLog,v 1.45 2012/03/06 23:35:27 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ffmpegthumbs/ChangeLog,v 1.46 2012/03/09 09:55:08 aballier Exp $
+
+ 09 Mar 2012; Alexis Ballier <aballier@gentoo.org> ffmpegthumbs-4.8.1.ebuild,
+ +files/ffmpegthumbs-4.8.1-ffmpeg.patch:
+ fix build with ffmpeg trunk
*ffmpegthumbs-4.8.1 (06 Mar 2012)
diff --git a/kde-base/ffmpegthumbs/ffmpegthumbs-4.8.1.ebuild b/kde-base/ffmpegthumbs/ffmpegthumbs-4.8.1.ebuild
index f7ec5fb27a49..60946eb69afa 100644
--- a/kde-base/ffmpegthumbs/ffmpegthumbs-4.8.1.ebuild
+++ b/kde-base/ffmpegthumbs/ffmpegthumbs-4.8.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/ffmpegthumbs/ffmpegthumbs-4.8.1.ebuild,v 1.1 2012/03/06 23:35:27 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ffmpegthumbs/ffmpegthumbs-4.8.1.ebuild,v 1.2 2012/03/09 09:55:08 aballier Exp $
EAPI=4
@@ -15,3 +15,5 @@ DEPEND="
virtual/ffmpeg
"
RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${PN}-4.8.1-ffmpeg.patch" )
diff --git a/kde-base/ffmpegthumbs/files/ffmpegthumbs-4.8.1-ffmpeg.patch b/kde-base/ffmpegthumbs/files/ffmpegthumbs-4.8.1-ffmpeg.patch
new file mode 100644
index 000000000000..afbb8a66f5af
--- /dev/null
+++ b/kde-base/ffmpegthumbs/files/ffmpegthumbs-4.8.1-ffmpeg.patch
@@ -0,0 +1,29 @@
+Index: ffmpegthumbs-4.8.1/ffmpegthumbs/ffmpegthumbnailer/moviedecoder.cpp
+===================================================================
+--- ffmpegthumbs-4.8.1.orig/ffmpegthumbs/ffmpegthumbnailer/moviedecoder.cpp
++++ ffmpegthumbs-4.8.1/ffmpegthumbs/ffmpegthumbnailer/moviedecoder.cpp
+@@ -52,12 +52,14 @@ MovieDecoder::~MovieDecoder()
+ void MovieDecoder::initialize(const QString& filename)
+ {
+ av_register_all();
++#if LIBAVCODEC_VERSION_INT < AV_VERSION_INT(54,0,0)
+ avcodec_init();
++#endif
+ avcodec_register_all();
+
+ QFileInfo fileInfo(filename);
+
+- if ((!m_FormatContextWasGiven) && av_open_input_file(&m_pFormatContext, fileInfo.absoluteFilePath().toUtf8().data(), NULL, 0, NULL) != 0) {
++ if ((!m_FormatContextWasGiven) && avformat_open_input(&m_pFormatContext, fileInfo.absoluteFilePath().toUtf8().data(), NULL, NULL) != 0) {
+ kDebug() << "Could not open input file: " << fileInfo.absoluteFilePath();
+ return;
+ }
+@@ -89,7 +91,7 @@ void MovieDecoder::destroy()
+ }
+
+ if ((!m_FormatContextWasGiven) && m_pFormatContext) {
+- av_close_input_file(m_pFormatContext);
++ avformat_close_input(&m_pFormatContext);
+ m_pFormatContext = NULL;
+ }
+