summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2009-05-06 22:52:43 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2009-05-06 22:52:43 +0000
commitce8dd04c5e7601e00b6ed7b7705daeb422a90745 (patch)
treee1ca9aefabbfa5ad1c50051eb821e7f4eca959af /kde-base
parentVersion bump KDE 4.2.3 (diff)
downloadgentoo-2-ce8dd04c5e7601e00b6ed7b7705daeb422a90745.tar.gz
gentoo-2-ce8dd04c5e7601e00b6ed7b7705daeb422a90745.tar.bz2
gentoo-2-ce8dd04c5e7601e00b6ed7b7705daeb422a90745.zip
Version bump KDE 4.2.3
(Portage version: 2.2_rc31/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'kde-base')
-rw-r--r--kde-base/kalzium/ChangeLog8
-rw-r--r--kde-base/kalzium/files/kalzium-include-order.patch26
-rw-r--r--kde-base/kalzium/kalzium-4.2.3.ebuild42
3 files changed, 75 insertions, 1 deletions
diff --git a/kde-base/kalzium/ChangeLog b/kde-base/kalzium/ChangeLog
index 666f666fba88..26e1b269a7ba 100644
--- a/kde-base/kalzium/ChangeLog
+++ b/kde-base/kalzium/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/kalzium
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kalzium/ChangeLog,v 1.121 2009/04/17 07:54:16 alexxy Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kalzium/ChangeLog,v 1.122 2009/05/06 22:52:43 scarabeus Exp $
+
+*kalzium-4.2.3 (06 May 2009)
+
+ 06 May 2009; Tomas Chvatal <scarabeus@gentoo.org> +kalzium-4.2.3.ebuild,
+ +files/kalzium-include-order.patch:
+ Version bump
17 Apr 2009; Alexey Shvetsov <alexxy@gentoo.org> kalzium-4.2.2:
Restore ~hppa keywords
diff --git a/kde-base/kalzium/files/kalzium-include-order.patch b/kde-base/kalzium/files/kalzium-include-order.patch
new file mode 100644
index 000000000000..1faffa2e3812
--- /dev/null
+++ b/kde-base/kalzium/files/kalzium-include-order.patch
@@ -0,0 +1,26 @@
+--- kalzium-4.2.1/work/kalzium-4.2.1/kalzium/libavogadro-kalzium/src/CMakeLists.txt 2009-02-26 09:17:16.000000000 -0500
++++ /root/CMakeLists.txt 2009-03-11 18:19:48.000000000 -0400
+@@ -15,10 +15,12 @@
+ ${CMAKE_CURRENT_BINARY_DIR}/config.h
+ )
+
+-include(${QT_USE_FILE})
++# Ensure the Avogadro include directory is always first
++get_directory_property(tmp_include_dirs INCLUDE_DIRECTORIES)
++set_directory_properties(PROPERTIES INCLUDE_DIRECTORIES
++ "${libavogadro-kalzium_SOURCE_DIR}/include;${tmp_include_dirs}")
+
+ include_directories(
+- ${libavogadro-kalzium_SOURCE_DIR}/include
+ ${CMAKE_SOURCE_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}/..
+@@ -26,6 +28,8 @@
+ ${EIGEN_INCLUDE_DIR}
+ )
+
++include(${QT_USE_FILE})
++
+ # Need to build with visibility enabled if KDE is
+ if(__KDE_HAVE_GCC_VISIBILITY)
+ add_definitions(-DHAVE_GCC_VISIBILITY)
diff --git a/kde-base/kalzium/kalzium-4.2.3.ebuild b/kde-base/kalzium/kalzium-4.2.3.ebuild
new file mode 100644
index 000000000000..077b76de92d0
--- /dev/null
+++ b/kde-base/kalzium/kalzium-4.2.3.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kalzium/kalzium-4.2.3.ebuild,v 1.1 2009/05/06 22:52:43 scarabeus Exp $
+
+EAPI="2"
+
+KMNAME="kdeedu"
+CPPUNIT_REQUIRED="optional"
+OPENGL_REQUIRED="always"
+inherit kde4-meta
+
+DESCRIPTION="KDE: periodic table of the elements."
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="editor debug doc +plasma solver"
+
+COMMON_DEPEND="
+ >=kde-base/libkdeedu-${PV}:${SLOT}[kdeprefix=]
+ editor? ( >=sci-chemistry/openbabel-2.2 )
+"
+DEPEND="${COMMON_DEPEND}
+ editor? ( >=dev-cpp/eigen-1.0.5 )
+ solver? ( dev-ml/facile[ocamlopt] )
+"
+RDEPEND="${COMMON_DEPEND}"
+
+KMEXTRACTONLY="
+ libkdeedu/kdeeduui/
+ libkdeedu/libscience/
+"
+
+PATCHES=( "${FILESDIR}/${PN}-include-order.patch" )
+
+src_configure(){
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_with editor Eigen)
+ $(cmake-utils_use_with editor OpenBabel2)
+ $(cmake-utils_use_with editor OpenGL)
+ $(cmake-utils_use_with solver OCaml)
+ $(cmake-utils_use_with solver Libfacile)"
+
+ kde4-meta_src_configure
+}