summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2015-06-15 18:35:14 +0000
committerMichael Palimaka <kensington@gentoo.org>2015-06-15 18:35:14 +0000
commit2d1c788f76931abc4ee8e8e0bc452767337abfa4 (patch)
treee9d1ed35c8e4f46168e251027feaa048dcc1a955 /kde-frameworks/frameworkintegration
parentUpdating remote-id in metadata.xml (diff)
downloadgentoo-2-2d1c788f76931abc4ee8e8e0bc452767337abfa4.tar.gz
gentoo-2-2d1c788f76931abc4ee8e8e0bc452767337abfa4.tar.bz2
gentoo-2-2d1c788f76931abc4ee8e8e0bc452767337abfa4.zip
Version bump.
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 0x06B1F38DCA45A1EC!)
Diffstat (limited to 'kde-frameworks/frameworkintegration')
-rw-r--r--kde-frameworks/frameworkintegration/ChangeLog8
-rw-r--r--kde-frameworks/frameworkintegration/frameworkintegration-5.11.0.ebuild48
2 files changed, 55 insertions, 1 deletions
diff --git a/kde-frameworks/frameworkintegration/ChangeLog b/kde-frameworks/frameworkintegration/ChangeLog
index dbab579f3456..d53912ed6f3a 100644
--- a/kde-frameworks/frameworkintegration/ChangeLog
+++ b/kde-frameworks/frameworkintegration/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-frameworks/frameworkintegration
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-frameworks/frameworkintegration/ChangeLog,v 1.19 2015/05/23 01:33:49 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-frameworks/frameworkintegration/ChangeLog,v 1.20 2015/06/15 18:35:11 kensington Exp $
+
+*frameworkintegration-5.11.0 (15 Jun 2015)
+
+ 15 Jun 2015; Michael Palimaka <kensington@gentoo.org>
+ +frameworkintegration-5.11.0.ebuild:
+ Version bump.
23 May 2015; Manuel Rüger <mrueg@gentoo.org>
-frameworkintegration-5.9.0.ebuild:
diff --git a/kde-frameworks/frameworkintegration/frameworkintegration-5.11.0.ebuild b/kde-frameworks/frameworkintegration/frameworkintegration-5.11.0.ebuild
new file mode 100644
index 000000000000..cd993e15a29e
--- /dev/null
+++ b/kde-frameworks/frameworkintegration/frameworkintegration-5.11.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-frameworks/frameworkintegration/frameworkintegration-5.11.0.ebuild,v 1.1 2015/06/15 18:35:11 kensington Exp $
+
+EAPI=5
+
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Framework for integrating Qt applications with KDE workspaces"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~x86"
+IUSE="X"
+
+RDEPEND="
+ $(add_plasma_dep oxygen-fonts)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kjobwidgets)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ X? (
+ dev-qt/qtx11extras:5
+ x11-libs/libxcb
+ x11-libs/libXcursor
+ )
+"
+DEPEND="${RDEPEND}"
+
+# requires running kde environment
+RESTRICT="test"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package X XCB)
+ )
+
+ kde5_src_configure
+}