summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Reffett <creffett@gentoo.org>2013-06-18 01:11:31 +0000
committerChris Reffett <creffett@gentoo.org>2013-06-18 01:11:31 +0000
commit815c31709f6d37226e2c58e177f779f473e36490 (patch)
tree3bd60a34546e4f3484d7f77af2c7bfa80ead70fc /kde-misc/konstruktor
parentDrop unused bash-completion use flag. (diff)
downloadgentoo-2-815c31709f6d37226e2c58e177f779f473e36490.tar.gz
gentoo-2-815c31709f6d37226e2c58e177f779f473e36490.tar.bz2
gentoo-2-815c31709f6d37226e2c58e177f779f473e36490.zip
Add to tree from kde overlay, add patch to fix compilation
(Portage version: 2.2.0_alpha180/cvs/Linux x86_64, signed Manifest commit with key 42618354)
Diffstat (limited to 'kde-misc/konstruktor')
-rw-r--r--kde-misc/konstruktor/ChangeLog10
-rw-r--r--kde-misc/konstruktor/files/konstruktor-0.9_beta1-multipledeclaration.patch10
-rw-r--r--kde-misc/konstruktor/konstruktor-0.9_beta1.ebuild31
-rw-r--r--kde-misc/konstruktor/metadata.xml5
4 files changed, 56 insertions, 0 deletions
diff --git a/kde-misc/konstruktor/ChangeLog b/kde-misc/konstruktor/ChangeLog
new file mode 100644
index 000000000000..391c8cb4907a
--- /dev/null
+++ b/kde-misc/konstruktor/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for kde-misc/konstruktor
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/konstruktor/ChangeLog,v 1.1 2013/06/18 01:11:31 creffett Exp $
+
+*konstruktor-0.9_beta1 (18 Jun 2013)
+
+ 18 Jun 2013; Chris Reffett <creffett@gentoo.org>
+ +files/konstruktor-0.9_beta1-multipledeclaration.patch,
+ +konstruktor-0.9_beta1.ebuild, +metadata.xml:
+ Add to tree from kde overlay, add patch to fix compilation
diff --git a/kde-misc/konstruktor/files/konstruktor-0.9_beta1-multipledeclaration.patch b/kde-misc/konstruktor/files/konstruktor-0.9_beta1-multipledeclaration.patch
new file mode 100644
index 000000000000..afccd147d52e
--- /dev/null
+++ b/kde-misc/konstruktor/files/konstruktor-0.9_beta1-multipledeclaration.patch
@@ -0,0 +1,10 @@
+--- konstruktor-0.9-beta1/src/app/renderwidget.cpp
++++ konstruktor-0.9-beta1/src/app/renderwidget.cpp
+@@ -395,7 +395,6 @@
+
+ glBegin(GL_POINTS);
+
+- int i = 0;
+ for (ldraw::model::const_iterator it = currentModel_->elements().begin(); it != currentModel_->elements().end(); ++it) {
+ if ((*it)->get_type() == ldraw::type_ref) {
+ ldraw::element_ref *r = CAST_AS_REF(*it);
diff --git a/kde-misc/konstruktor/konstruktor-0.9_beta1.ebuild b/kde-misc/konstruktor/konstruktor-0.9_beta1.ebuild
new file mode 100644
index 000000000000..ff100e3fb4d0
--- /dev/null
+++ b/kde-misc/konstruktor/konstruktor-0.9_beta1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/konstruktor/konstruktor-0.9_beta1.ebuild,v 1.1 2013/06/18 01:11:31 creffett Exp $
+
+EAPI=5
+
+MY_P="${P/_/-}"
+OPENGL_REQUIRED="always"
+inherit kde4-base
+
+DESCRIPTION="LEGO CAD"
+HOMEPAGE="http://konstruktor.influx.kr/"
+SRC_URI="http://konstruktor.influx.kr/${MY_P}.tar.bz2"
+KEYWORDS="~amd64 ~x86"
+
+LICENSE="GPL-2"
+SLOT="4"
+IUSE="test"
+
+DEPEND="dev-db/sqlite:3"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${PN}-0.9_beta1-multipledeclaration.patch" )
+
+S=${WORKDIR}/${MY_P}
+
+pkg_postinst() {
+ elog "You still need to obtain ldraw data files."
+ elog "Because they are not distributable you need to download them from:"
+ elog " http://www.ldraw.org/Downloads-req-viewdownload-cid-1.html"
+}
diff --git a/kde-misc/konstruktor/metadata.xml b/kde-misc/konstruktor/metadata.xml
new file mode 100644
index 000000000000..8d1e86a9cefb
--- /dev/null
+++ b/kde-misc/konstruktor/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>kde</herd>
+</pkgmetadata>