summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2015-05-31 22:06:18 +0000
committerJohannes Huber <johu@gentoo.org>2015-05-31 22:06:18 +0000
commit785902c8217c6232472fb6521c23cbe2cdd45a0d (patch)
treeeece118d5a4804b42d19b57e5d9400f8816c256d /kde-plasma/kwin
parentMask Plasma 5.3 for testing. (diff)
downloadgentoo-2-785902c8217c6232472fb6521c23cbe2cdd45a0d.tar.gz
gentoo-2-785902c8217c6232472fb6521c23cbe2cdd45a0d.tar.bz2
gentoo-2-785902c8217c6232472fb6521c23cbe2cdd45a0d.zip
Initial commit for KDE Plasma 5. Imported from kde overlay. Ebuilds written by several people. Thank you all who worked on it in the overlay.
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 0xF3CFD2BD)
Diffstat (limited to 'kde-plasma/kwin')
-rw-r--r--kde-plasma/kwin/ChangeLog10
-rw-r--r--kde-plasma/kwin/kwin-5.3.1.ebuild85
-rw-r--r--kde-plasma/kwin/metadata.xml8
3 files changed, 103 insertions, 0 deletions
diff --git a/kde-plasma/kwin/ChangeLog b/kde-plasma/kwin/ChangeLog
new file mode 100644
index 000000000000..5e8a0a31c081
--- /dev/null
+++ b/kde-plasma/kwin/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for kde-plasma/kwin
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/kde-plasma/kwin/ChangeLog,v 1.1 2015/05/31 22:06:17 johu Exp $
+
+*kwin-5.3.1 (31 May 2015)
+
+ 31 May 2015; Johannes Huber <johu@gentoo.org> +kwin-5.3.1.ebuild,
+ +metadata.xml:
+ Initial commit for KDE Plasma 5. Imported from kde overlay. Ebuilds written by
+ several people. Thank you all who worked on it in the overlay.
diff --git a/kde-plasma/kwin/kwin-5.3.1.ebuild b/kde-plasma/kwin/kwin-5.3.1.ebuild
new file mode 100644
index 000000000000..4e6269a7781a
--- /dev/null
+++ b/kde-plasma/kwin/kwin-5.3.1.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-plasma/kwin/kwin-5.3.1.ebuild,v 1.1 2015/05/31 22:06:17 johu Exp $
+
+EAPI=5
+
+KDE_HANDBOOK="true"
+KDE_TEST="true"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="KDE window manager"
+LICENSE="GPL-2+"
+KEYWORDS="~amd64"
+IUSE="gles2 wayland"
+
+COMMON_DEPEND="
+ $(add_frameworks_dep kactivities)
+ $(add_frameworks_dep kauth)
+ $(add_frameworks_dep kcmutils)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kcrash)
+ $(add_frameworks_dep kdeclarative)
+ $(add_frameworks_dep kglobalaccel)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kinit)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep knewstuff)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem X)
+ $(add_frameworks_dep kxmlgui)
+ $(add_frameworks_dep plasma)
+ $(add_plasma_dep kdecoration)
+ dev-qt/qtdbus:5
+ dev-qt/qtdeclarative:5
+ dev-qt/qtgui:5[gles2=,opengl]
+ dev-qt/qtmultimedia:5[qml]
+ dev-qt/qtscript:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras
+ media-libs/libepoxy
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ >=x11-libs/libxcb-1.0
+ x11-libs/xcb-util-cursor
+ x11-libs/xcb-util-image
+ x11-libs/xcb-util-keysyms
+ wayland? (
+ $(add_plasma_dep kwayland)
+ >=dev-libs/libinput-0.10
+ >=dev-libs/wayland-1.2
+ virtual/libudev:=
+ >=x11-libs/libxkbcommon-0.4.1
+ )
+"
+RDEPEND="${COMMON_DEPEND}
+ $(add_plasma_dep kde-cli-tools)
+ !kde-base/kwin
+ !kde-base/systemsettings
+"
+DEPEND="${COMMON_DEPEND}
+ dev-qt/designer:5
+ dev-qt/qtconcurrent:5
+ media-libs/mesa[egl,gles2?]
+ x11-proto/xproto
+ test? ( x11-libs/xcb-util-wm )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package wayland)
+ $(cmake-utils_use_find_package wayland KF5Wayland)
+ $(cmake-utils_use_find_package wayland Libinput)
+ $(cmake-utils_use_find_package wayland UDev)
+ )
+
+ kde5_src_configure
+}
diff --git a/kde-plasma/kwin/metadata.xml b/kde-plasma/kwin/metadata.xml
new file mode 100644
index 000000000000..9a1ee920379c
--- /dev/null
+++ b/kde-plasma/kwin/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>kde</herd>
+ <use>
+ <flag name="gles2">Use OpenGL ES 2 instead of full GL</flag>
+ </use>
+</pkgmetadata>