summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2015-06-11 20:55:29 +0000
committerJohannes Huber <johu@gentoo.org>2015-06-11 20:55:29 +0000
commit6d95ed1193af6527b9b5e4b6c2f8d5eabc38a264 (patch)
treefc3eadaeae984b3098c14b885a12713d59a7b09a /kde-plasma
parentDrop old (diff)
downloadgentoo-2-6d95ed1193af6527b9b5e4b6c2f8d5eabc38a264.tar.gz
gentoo-2-6d95ed1193af6527b9b5e4b6c2f8d5eabc38a264.tar.bz2
gentoo-2-6d95ed1193af6527b9b5e4b6c2f8d5eabc38a264.zip
Revision bump adds upstream patch to fix gles2 support, bug #551448. Thanks to Dennis Schridde <devurandom@gmx.net>.
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 0xF3CFD2BD)
Diffstat (limited to 'kde-plasma')
-rw-r--r--kde-plasma/kwin/ChangeLog9
-rw-r--r--kde-plasma/kwin/files/kwin-5.3.1-gles2.patch47
-rw-r--r--kde-plasma/kwin/kwin-5.3.1-r1.ebuild (renamed from kde-plasma/kwin/kwin-5.3.1.ebuild)4
3 files changed, 58 insertions, 2 deletions
diff --git a/kde-plasma/kwin/ChangeLog b/kde-plasma/kwin/ChangeLog
index a8dcd4b752bb..fab00b99441e 100644
--- a/kde-plasma/kwin/ChangeLog
+++ b/kde-plasma/kwin/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for kde-plasma/kwin
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-plasma/kwin/ChangeLog,v 1.2 2015/06/11 16:10:34 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-plasma/kwin/ChangeLog,v 1.3 2015/06/11 20:55:29 johu Exp $
+
+*kwin-5.3.1-r1 (11 Jun 2015)
+
+ 11 Jun 2015; Johannes Huber <johu@gentoo.org> +files/kwin-5.3.1-gles2.patch,
+ +kwin-5.3.1-r1.ebuild, -kwin-5.3.1.ebuild:
+ Revision bump adds upstream patch to fix gles2 support, bug #551448. Thanks to
+ Dennis Schridde <devurandom@gmx.net>.
11 Jun 2015; Johannes Huber <johu@gentoo.org> kwin-5.3.1.ebuild:
Adjust dev-qt/qtgui USE dependencies, bug #551772.
diff --git a/kde-plasma/kwin/files/kwin-5.3.1-gles2.patch b/kde-plasma/kwin/files/kwin-5.3.1-gles2.patch
new file mode 100644
index 000000000000..cf4d859fe4ef
--- /dev/null
+++ b/kde-plasma/kwin/files/kwin-5.3.1-gles2.patch
@@ -0,0 +1,47 @@
+commit 713c6b25dce2fc60184ddc7b618b0b1195ab9870
+Author: Martin Gräßlin <mgraesslin@kde.org>
+Date: Fri May 8 08:53:34 2015 +0200
+
+ [kwinglutils] Init glVersion on gles
+
+ The glVersion was not set at all for gles causing any code doing a
+ hasGLVersion check to fail which means that the compositor doesn't
+ start at all, because it has a hasGLVersion(2, 0) check.
+
+ The complete ifdef is no longer needed. The used additional glGetStringi
+ is also available in gles 3.0, thus epoxy can handle it quite well
+ without a need for ifdef.
+
+ Unfortunately the version string can be "strange" on GLES. On desktop
+ it looks like: "3.0 some driver foo", on GLES it could also be:
+ "OpenGL ES 3.0 some driver bar". Thus to make the logic work we are
+ first removing any leading "OpenGL ES " and hope that then the version
+ is encoded just like on GL.
+
+diff --git a/libkwineffects/kwinglutils.cpp b/libkwineffects/kwinglutils.cpp
+index 8830c44..fd2e217 100644
+--- a/libkwineffects/kwinglutils.cpp
++++ b/libkwineffects/kwinglutils.cpp
+@@ -106,11 +106,12 @@ void initGL(OpenGLPlatformInterface platformInterface)
+ {
+ // Get OpenGL version
+ QString glversionstring = QString::fromUtf8((const char*)glGetString(GL_VERSION));
++ if (glversionstring.startsWith(QLatin1String("OpenGL ES "))) {
++ glversionstring = glversionstring.mid(10);
++ }
+ QStringList glversioninfo = glversionstring.left(glversionstring.indexOf(QStringLiteral(" "))).split(QStringLiteral("."));
+ while (glversioninfo.count() < 3)
+ glversioninfo << QStringLiteral("0");
+-
+-#ifndef KWIN_HAVE_OPENGLES
+ glVersion = MAKE_GL_VERSION(glversioninfo[0].toInt(), glversioninfo[1].toInt(), glversioninfo[2].toInt());
+
+ // Get list of supported OpenGL extensions
+@@ -123,7 +124,6 @@ void initGL(OpenGLPlatformInterface platformInterface)
+ glExtensions << name;
+ }
+ } else
+-#endif
+ glExtensions = QByteArray((const char*)glGetString(GL_EXTENSIONS)).split(' ');
+
+ // handle OpenGL extensions functions
diff --git a/kde-plasma/kwin/kwin-5.3.1.ebuild b/kde-plasma/kwin/kwin-5.3.1-r1.ebuild
index 59385ef50307..39bf6e9a80eb 100644
--- a/kde-plasma/kwin/kwin-5.3.1.ebuild
+++ b/kde-plasma/kwin/kwin-5.3.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-plasma/kwin/kwin-5.3.1.ebuild,v 1.2 2015/06/11 16:10:34 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-plasma/kwin/kwin-5.3.1-r1.ebuild,v 1.1 2015/06/11 20:55:29 johu Exp $
EAPI=5
@@ -73,6 +73,8 @@ DEPEND="${COMMON_DEPEND}
test? ( x11-libs/xcb-util-wm )
"
+PATCHES=( "${FILESDIR}/${P}-gles2.patch" )
+
src_configure() {
local mycmakeargs=(
$(cmake-utils_use_find_package wayland)