summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVictor Ostorga <vostorga@gentoo.org>2010-10-12 16:54:17 +0000
committerVictor Ostorga <vostorga@gentoo.org>2010-10-12 16:54:17 +0000
commitb6d7839cb300c2d04d1ea11d3a744ec44555a2b9 (patch)
treec74c228249d94830b7b3421faf820204c3a25a30 /lxde-base
parentia64 stable wrt #339640 (diff)
downloadgentoo-2-b6d7839cb300c2d04d1ea11d3a744ec44555a2b9.tar.gz
gentoo-2-b6d7839cb300c2d04d1ea11d3a744ec44555a2b9.tar.bz2
gentoo-2-b6d7839cb300c2d04d1ea11d3a744ec44555a2b9.zip
Fixing collision with the alarm structure, patch thanks to Ángel Velásquez <angvp@archlinux.org> bug #339029
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'lxde-base')
-rw-r--r--lxde-base/lxpanel/ChangeLog7
-rw-r--r--lxde-base/lxpanel/files/lxpanel-0.5.6-symbol-alarm.patch43
-rw-r--r--lxde-base/lxpanel/lxpanel-0.5.6.ebuild3
3 files changed, 51 insertions, 2 deletions
diff --git a/lxde-base/lxpanel/ChangeLog b/lxde-base/lxpanel/ChangeLog
index fac63e0f3485..fd0e120b3059 100644
--- a/lxde-base/lxpanel/ChangeLog
+++ b/lxde-base/lxpanel/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for lxde-base/lxpanel
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/lxde-base/lxpanel/ChangeLog,v 1.21 2010/07/29 14:44:12 vostorga Exp $
+# $Header: /var/cvsroot/gentoo-x86/lxde-base/lxpanel/ChangeLog,v 1.22 2010/10/12 16:54:17 vostorga Exp $
+
+ 12 Oct 2010; Víctor Ostorga <vostorga@gentoo.org> lxpanel-0.5.6.ebuild,
+ +files/lxpanel-0.5.6-symbol-alarm.patch:
+ Fixing collision with the alarm structure, patch thanks to Ángel
+ Velásquez <angvp@archlinux.org> bug #339029
*lxpanel-0.5.6 (29 Jul 2010)
diff --git a/lxde-base/lxpanel/files/lxpanel-0.5.6-symbol-alarm.patch b/lxde-base/lxpanel/files/lxpanel-0.5.6-symbol-alarm.patch
new file mode 100644
index 000000000000..e3da3d89776c
--- /dev/null
+++ b/lxde-base/lxpanel/files/lxpanel-0.5.6-symbol-alarm.patch
@@ -0,0 +1,43 @@
+From 4a974f2686d2fafdcda4a180b0483a7b17fd2d71 Mon Sep 17 00:00:00 2001
+From: Marty Jack <martyj@linux.local>
+Date: Thu, 22 Jul 2010 19:46:13 -0400
+Subject: [PATCH 3/3] Fix build issue with symbol "alarm" showing up on F14 (Bug3033293)
+
+---
+ src/plugins/batt/batt.c | 6 +++---
+ 1 files changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/src/plugins/batt/batt.c b/src/plugins/batt/batt.c
+index 288231f..05c0deb 100644
+--- a/src/plugins/batt/batt.c
++++ b/src/plugins/batt/batt.c
+@@ -95,7 +95,7 @@ typedef struct {
+ typedef struct {
+ char *command;
+ sem_t *lock;
+-} alarm;
++} Alarm;
+
+ static void destructor(Plugin *p);
+ static void update_display(lx_battery *lx_b, gboolean repaint);
+@@ -103,7 +103,7 @@ static void update_display(lx_battery *lx_b, gboolean repaint);
+ /* alarmProcess takes the address of a dynamically allocated alarm struct (which
+ it must free). It ensures that alarm commands do not run concurrently. */
+ static void * alarmProcess(void *arg) {
+- alarm *a = (alarm *) arg;
++ Alarm *a = (Alarm *) arg;
+
+ sem_wait(a->lock);
+ system(a->command);
+@@ -157,7 +157,7 @@ void update_display(lx_battery *lx_b, gboolean repaint) {
+ /* Run the alarm command if it isn't already running */
+ if (alarmCanRun) {
+
+- alarm *a = (alarm *) malloc(sizeof(alarm));
++ Alarm *a = (Alarm *) malloc(sizeof(Alarm));
+ a->command = lx_b->alarmCommand;
+ a->lock = &(lx_b->alarmProcessLock);
+
+--
+1.7.1.1
+
diff --git a/lxde-base/lxpanel/lxpanel-0.5.6.ebuild b/lxde-base/lxpanel/lxpanel-0.5.6.ebuild
index e6534012689f..0d9088bc3004 100644
--- a/lxde-base/lxpanel/lxpanel-0.5.6.ebuild
+++ b/lxde-base/lxpanel/lxpanel-0.5.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/lxde-base/lxpanel/lxpanel-0.5.6.ebuild,v 1.1 2010/07/29 14:44:12 vostorga Exp $
+# $Header: /var/cvsroot/gentoo-x86/lxde-base/lxpanel/lxpanel-0.5.6.ebuild,v 1.2 2010/10/12 16:54:17 vostorga Exp $
EAPI="2"
inherit eutils autotools
@@ -27,6 +27,7 @@ DEPEND="${RDEPEND}
src_prepare() {
epatch "${FILESDIR}"/${PN}-0.5.1-sandbox.patch
+ epatch "${FILESDIR}"/${P}-symbol-alarm.patch
eautoreconf
}