summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2005-08-11 23:28:28 +0000
committerAron Griffis <agriffis@gentoo.org>2005-08-11 23:28:28 +0000
commitda702adc2f3d53007a9ecfc8011d91d2757665ec (patch)
tree36c5bb927337953e1450c24300c6baf6ae991e2b /mail-client/mutt
parentFix the nodoc patch to apply to mutt. The muttng patch didn't apply (diff)
downloadgentoo-2-da702adc2f3d53007a9ecfc8011d91d2757665ec.tar.gz
gentoo-2-da702adc2f3d53007a9ecfc8011d91d2757665ec.tar.bz2
gentoo-2-da702adc2f3d53007a9ecfc8011d91d2757665ec.zip
Disable sasl unless pop or imap is specified; it's the same as ssl or gnutls
in that regard (Portage version: 2.0.51.22-r2)
Diffstat (limited to 'mail-client/mutt')
-rw-r--r--mail-client/mutt/ChangeLog6
-rw-r--r--mail-client/mutt/mutt-1.5.9.ebuild14
2 files changed, 13 insertions, 7 deletions
diff --git a/mail-client/mutt/ChangeLog b/mail-client/mutt/ChangeLog
index 973a1b543eae..3b2b23839938 100644
--- a/mail-client/mutt/ChangeLog
+++ b/mail-client/mutt/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for mail-client/mutt
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/mutt/ChangeLog,v 1.53 2005/08/11 23:22:39 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/mutt/ChangeLog,v 1.54 2005/08/11 23:28:28 agriffis Exp $
+
+ 11 Aug 2005; Aron Griffis <agriffis@gentoo.org> mutt-1.5.9.ebuild:
+ Disable sasl unless pop or imap is specified; it's the same as ssl or gnutls
+ in that regard
11 Aug 2005; Aron Griffis <agriffis@gentoo.org>
+files/mutt-1.5.9-nodoc.patch, -files/muttng-20050809-nodoc.patch,
diff --git a/mail-client/mutt/mutt-1.5.9.ebuild b/mail-client/mutt/mutt-1.5.9.ebuild
index 3e052bcbaf2f..b457e92d927e 100644
--- a/mail-client/mutt/mutt-1.5.9.ebuild
+++ b/mail-client/mutt/mutt-1.5.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/mutt/mutt-1.5.9.ebuild,v 1.3 2005/08/11 23:22:39 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/mutt/mutt-1.5.9.ebuild,v 1.4 2005/08/11 23:28:28 agriffis Exp $
inherit eutils flag-o-matic
@@ -41,13 +41,14 @@ RDEPEND="nls? ( sys-devel/gettext )
imap? (
gnutls? ( >=net-libs/gnutls-1.0.17 )
!gnutls? ( ssl? ( >=dev-libs/openssl-0.9.6 ) )
+ sasl? ( >=dev-libs/cyrus-sasl-2 )
)
pop? (
gnutls? ( >=net-libs/gnutls-1.0.17 )
!gnutls? ( ssl? ( >=dev-libs/openssl-0.9.6 ) )
+ sasl? ( >=dev-libs/cyrus-sasl-2 )
)
- gpgme? ( >=app-crypt/gpgme-0.9.0 )
- sasl? ( >=dev-libs/cyrus-sasl-2 )"
+ gpgme? ( >=app-crypt/gpgme-0.9.0 )"
DEPEND="${RDEPEND}
net-mail/mailbase
!vanilla? ( sys-devel/automake sys-devel/autoconf )"
@@ -94,7 +95,6 @@ src_compile() {
$(use_enable gpgme) \
$(use_enable imap) \
$(use_enable pop) \
- $(use_with sasl sasl2) \
$(use_enable crypt pgp) \
$(use_enable smime) \
$(use_enable cjk default-japanese) \
@@ -120,7 +120,7 @@ src_compile() {
myconf="${myconf} --disable-hcache --without-gdbm --without-bdb"
fi
- # there's no need for gnutls or ssl without either pop or imap.
+ # there's no need for gnutls, ssl or sasl without either pop or imap.
# in fact mutt's configure will bail if you do:
# --without-pop --without-imap --with-ssl
if use pop || use imap; then
@@ -129,8 +129,10 @@ src_compile() {
elif use ssl; then
myconf="${myconf} --with-ssl"
fi
+ # not sure if this should be mutually exclusive with the other two
+ myconf="${myconf} $(use_with sasl sasl2)"
else
- myconf="${myconf} --without-gnutls --without-ssl"
+ myconf="${myconf} --without-gnutls --without-ssl --without-sasl2"
fi
# See Bug #11170