summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAgostino Sarubbo <ago@gentoo.org>2013-09-30 17:04:13 +0000
committerAgostino Sarubbo <ago@gentoo.org>2013-09-30 17:04:13 +0000
commit6316f688d996ae031d7d957c80a59ca1f8115793 (patch)
tree2c26165c178b4dcf3d94e64cecaf3f6f4fd0337b /mail-client/trojita
parentStable for ppc64, wrt bug #467274 (diff)
downloadgentoo-2-6316f688d996ae031d7d957c80a59ca1f8115793.tar.gz
gentoo-2-6316f688d996ae031d7d957c80a59ca1f8115793.tar.bz2
gentoo-2-6316f688d996ae031d7d957c80a59ca1f8115793.zip
Version bump to 0.3.96, change the buildsystem to cmake, wrt bug #486588
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 7194459F)
Diffstat (limited to 'mail-client/trojita')
-rw-r--r--mail-client/trojita/ChangeLog8
-rw-r--r--mail-client/trojita/trojita-0.3.96.ebuild68
-rw-r--r--mail-client/trojita/trojita-9999.ebuild6
3 files changed, 78 insertions, 4 deletions
diff --git a/mail-client/trojita/ChangeLog b/mail-client/trojita/ChangeLog
index e6a4463e7482..95dca7da3e96 100644
--- a/mail-client/trojita/ChangeLog
+++ b/mail-client/trojita/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for mail-client/trojita
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/trojita/ChangeLog,v 1.26 2013/06/20 13:13:20 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/trojita/ChangeLog,v 1.27 2013/09/30 17:04:13 ago Exp $
+
+*trojita-0.3.96 (30 Sep 2013)
+
+ 30 Sep 2013; Agostino Sarubbo <ago@gentoo.org> +trojita-0.3.96.ebuild,
+ trojita-9999.ebuild:
+ Version bump to 0.3.96, change the buildsystem to cmake, wrt bug #486588
20 Jun 2013; Agostino Sarubbo <ago@gentoo.org> trojita-9999.ebuild:
Port the 9999 ebuil to cmake, wrt to bug #473930
diff --git a/mail-client/trojita/trojita-0.3.96.ebuild b/mail-client/trojita/trojita-0.3.96.ebuild
new file mode 100644
index 000000000000..8e36052d655e
--- /dev/null
+++ b/mail-client/trojita/trojita-0.3.96.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/trojita/trojita-0.3.96.ebuild,v 1.1 2013/09/30 17:04:13 ago Exp $
+
+EAPI=5
+
+QT_REQUIRED="4.6.0"
+EGIT_REPO_URI="git://anongit.kde.org/${PN}.git"
+[[ ${PV} == "9999" ]] && GIT_ECLASS="git-2"
+
+inherit qt4-r2 virtualx cmake-utils ${GIT_ECLASS}
+
+DESCRIPTION="A Qt IMAP e-mail client"
+HOMEPAGE="http://trojita.flaska.net/"
+if [[ ${PV} == "9999" ]]; then
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+ KEYWORDS="~amd64 ~ppc ~x86"
+ MY_LANGS="bs cs da de el es et fr ga gl hu ia lt mr nl pl pt pt_BR ro sk sv tr ug uk zh_CN zh_TW"
+fi
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="0"
+IUSE="debug test +zlib"
+for MY_LANG in ${MY_LANGS} ; do
+ IUSE="${IUSE} linguas_${MY_LANG}"
+done
+
+RDEPEND="
+ >=dev-qt/qtgui-${QT_REQUIRED}:4
+ >=dev-qt/qtsql-${QT_REQUIRED}:4[sqlite]
+ >=dev-qt/qtwebkit-${QT_REQUIRED}:4
+"
+DEPEND="${RDEPEND}
+ test? ( >=dev-qt/qttest-${QT_REQUIRED}:4 )
+ zlib? (
+ virtual/pkgconfig
+ sys-libs/zlib
+ )
+"
+
+DOCS="README LICENSE"
+
+src_configure() {
+ local mycmakeargs=""
+ use test || mycmakeargs="$mycmakeargs -DWITHOUT_TESTS=1"
+ use zlib || mycmakeargs="$mycmakeargs -DWITHOUT_ZLIB=1"
+ if [[ ${MY_LANGS} ]]; then
+ rm po/trojita_common_x-test.po
+ for x in po/*.po; do
+ mylang=${x#po/trojita_common_}
+ mylang=${mylang%.po}
+ use linguas_$mylang || rm $x
+ done
+ fi
+
+ # the build system is taking a look at `git describe ... --dirty` and
+ # gentoo's modifications to CMakeLists.txt break these
+ sed -i "s/--dirty//" "${S}/cmake/TrojitaVersion.cmake" || die "Cannot fix the version check"
+
+ cmake-utils_src_configure
+}
+
+src_test() {
+ VIRTUALX_COMMAND=cmake-utils_src_test virtualmake
+}
diff --git a/mail-client/trojita/trojita-9999.ebuild b/mail-client/trojita/trojita-9999.ebuild
index fdb2bc92f8ed..1da384e473d1 100644
--- a/mail-client/trojita/trojita-9999.ebuild
+++ b/mail-client/trojita/trojita-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/trojita/trojita-9999.ebuild,v 1.18 2013/06/20 13:13:20 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/trojita/trojita-9999.ebuild,v 1.19 2013/09/30 17:04:13 ago Exp $
EAPI=5
@@ -18,7 +18,7 @@ if [[ ${PV} == "9999" ]]; then
else
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
KEYWORDS="~amd64 ~ppc ~x86"
- MY_LANGS="bs cs da de el es et fr ga gl hu ia lt mr nl pl pt pt_BR sk sv tr uk zh_CN zh_TW"
+ MY_LANGS="bs cs da de el es et fr ga gl hu ia lt mr nl pl pt pt_BR ro sk sv tr ug uk zh_CN zh_TW"
fi
LICENSE="|| ( GPL-2 GPL-3 )"
@@ -58,7 +58,7 @@ src_configure() {
# the build system is taking a look at `git describe ... --dirty` and
# gentoo's modifications to CMakeLists.txt break these
- sed -i "s/--dirty//" "${S}/cmake/GitVersion.cmake"
+ sed -i "s/--dirty//" "${S}/cmake/TrojitaVersion.cmake" || die "Cannot fix the version check"
cmake-utils_src_configure
}