summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEray Aslan <eras@gentoo.org>2012-05-04 12:14:22 +0000
committerEray Aslan <eras@gentoo.org>2012-05-04 12:14:22 +0000
commit7ca56fc53dc60692569dd5d717c012e83b6c462d (patch)
tree321424c3cfcd4b09a6241548bc2cb4baf3c19b42 /mail-client
parentdev-util/pkgconfig -> virtual/pkgconfig (diff)
downloadgentoo-2-7ca56fc53dc60692569dd5d717c012e83b6c462d.tar.gz
gentoo-2-7ca56fc53dc60692569dd5d717c012e83b6c462d.tar.bz2
gentoo-2-7ca56fc53dc60692569dd5d717c012e83b6c462d.zip
version bump
(Portage version: 2.1.10.57/cvs/Linux x86_64)
Diffstat (limited to 'mail-client')
-rw-r--r--mail-client/cone/ChangeLog7
-rw-r--r--mail-client/cone/cone-0.90.ebuild62
2 files changed, 68 insertions, 1 deletions
diff --git a/mail-client/cone/ChangeLog b/mail-client/cone/ChangeLog
index fe120a349c11..82f317afd421 100644
--- a/mail-client/cone/ChangeLog
+++ b/mail-client/cone/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for mail-client/cone
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/cone/ChangeLog,v 1.43 2012/02/07 07:00:22 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/cone/ChangeLog,v 1.44 2012/05/04 12:14:22 eras Exp $
+
+*cone-0.90 (04 May 2012)
+
+ 04 May 2012; Eray Aslan <eras@gentoo.org> +cone-0.90.ebuild:
+ version bump
07 Feb 2012; Tim Harder <radhermit@gentoo.org> -cone-0.84.20100819-r1.ebuild,
-files/cone-0.84.20100819-skip-rfc2045-test.patch, -cone-0.86.ebuild:
diff --git a/mail-client/cone/cone-0.90.ebuild b/mail-client/cone/cone-0.90.ebuild
new file mode 100644
index 000000000000..d0bd140d5fee
--- /dev/null
+++ b/mail-client/cone/cone-0.90.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/cone/cone-0.90.ebuild,v 1.1 2012/05/04 12:14:22 eras Exp $
+
+EAPI=4
+
+inherit eutils autotools
+
+DESCRIPTION="CONE: COnsole News reader and Emailer"
+HOMEPAGE="http://www.courier-mta.org/cone/"
+SRC_URI="mirror://sourceforge/courier/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="crypt fam gnutls idn ipv6 ldap spell"
+
+RDEPEND=">=dev-libs/openssl-0.9.6
+ dev-libs/libxml2
+ sys-libs/ncurses
+ crypt? ( >=app-crypt/gnupg-1.0.4 )
+ fam? ( virtual/fam )
+ gnutls? ( net-libs/gnutls )
+ idn? ( net-dns/libidn )
+ ipv6? ( net-dns/libidn )
+ ldap? ( net-nds/openldap )
+ spell? ( app-text/aspell )"
+DEPEND="${RDEPEND}
+ dev-lang/perl"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.84.20100819-aspell-automagic.patch \
+ "${FILESDIR}"/${PN}-0.86-skip-rfc2045-test.patch
+
+ # move local macro to m4 and run eautoreconf
+ mkdir "${S}/m4"
+ sed -n -e '/# AC_PROG_SYSCONFTOOL/,+33 p' "${S}"/aclocal.m4 > \
+ m4/sysconftool.m4 || die
+ sed -i -e '/^SUBDIRS/i ACLOCAL_AMFLAGS = -I m4' "${S}"/Makefile.am || die
+ eautoreconf
+}
+
+src_configure() {
+ local myconf
+ if use spell ; then
+ myconf="--with-spellcheck=aspell"
+ else
+ myconf="--with-spellcheck=none"
+ fi
+
+ econf \
+ ${myconf} \
+ $(use_with ldap ldapaddressbook) \
+ $(use_with gnutls) \
+ $(use_with idn libidn) \
+ $(use_with ipv6)
+}
+
+src_install() {
+ default
+ emake DESTDIR="${D}" install-configure
+}