summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2004-08-08 19:09:25 +0000
committerAron Griffis <agriffis@gentoo.org>2004-08-08 19:09:25 +0000
commitd5d678c383017a85d982d5c78f669a683f2d5c7c (patch)
tree8e10878a369aaeb4dc308cccb142259b79483a03 /mail-client
parentMoved from net-www/webfs to www-servers/webfs (diff)
downloadgentoo-2-d5d678c383017a85d982d5c78f669a683f2d5c7c.tar.gz
gentoo-2-d5d678c383017a85d982d5c78f669a683f2d5c7c.tar.bz2
gentoo-2-d5d678c383017a85d982d5c78f669a683f2d5c7c.zip
Move extensions configuration to mozilla.eclass. Use edit_makefiles to reduce compilation RAM requirements
Diffstat (limited to 'mail-client')
-rw-r--r--mail-client/mozilla-thunderbird/ChangeLog7
-rw-r--r--mail-client/mozilla-thunderbird/mozilla-thunderbird-0.7.3.ebuild12
2 files changed, 13 insertions, 6 deletions
diff --git a/mail-client/mozilla-thunderbird/ChangeLog b/mail-client/mozilla-thunderbird/ChangeLog
index 7aa14de77248..1d7a896148ae 100644
--- a/mail-client/mozilla-thunderbird/ChangeLog
+++ b/mail-client/mozilla-thunderbird/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for mail-client/mozilla-thunderbird
# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/mozilla-thunderbird/ChangeLog,v 1.26 2004/08/08 19:01:35 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/mozilla-thunderbird/ChangeLog,v 1.27 2004/08/08 19:09:25 agriffis Exp $
+
+ 08 Aug 2004; Aron Griffis <agriffis@gentoo.org>
+ mozilla-thunderbird-0.7.3.ebuild:
+ Move extensions configuration to mozilla.eclass. Use edit_makefiles to reduce
+ compilation RAM requirements
08 Aug 2004; <agriffis@gentoo.org> mozilla-thunderbird-0.7.3.ebuild:
stable on ia64
diff --git a/mail-client/mozilla-thunderbird/mozilla-thunderbird-0.7.3.ebuild b/mail-client/mozilla-thunderbird/mozilla-thunderbird-0.7.3.ebuild
index 0b158523f106..417a1964e09e 100644
--- a/mail-client/mozilla-thunderbird/mozilla-thunderbird-0.7.3.ebuild
+++ b/mail-client/mozilla-thunderbird/mozilla-thunderbird-0.7.3.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/mozilla-thunderbird/mozilla-thunderbird-0.7.3.ebuild,v 1.6 2004/08/08 19:01:35 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/mozilla-thunderbird/mozilla-thunderbird-0.7.3.ebuild,v 1.7 2004/08/08 19:09:25 agriffis Exp $
IUSE="crypt gtk2"
unset ALLOWED_FLAGS # stupid extra-functions.sh ... bug 49179
-inherit flag-o-matic gcc eutils nsplugins mozilla mozilla-launcher
+inherit flag-o-matic gcc eutils nsplugins mozilla mozilla-launcher makeedit
EMVER="0.85.0"
IPCVER="1.0.7"
@@ -28,7 +28,6 @@ S=${WORKDIR}/mozilla
# Would do in pkg_setup but that loses the export attribute, they
# become pure shell variables.
export MOZ_THUNDERBIRD=1
-export MOZ_ENABLE_XFT=1
src_unpack() {
unpack ${A} || die "unpack failed"
@@ -65,8 +64,7 @@ src_compile() {
mozilla_conf
myconf="${myconf} \
- --with-default-mozilla-five-home=/usr/lib/MozillaThunderbird \
- --enable-extensions=wallet,spellcheck"
+ --with-default-mozilla-five-home=/usr/lib/MozillaThunderbird"
####################################
#
@@ -76,6 +74,10 @@ src_compile() {
econf ${myconf} || die
+ # This removes extraneous CFLAGS from the Makefiles to reduce RAM
+ # requirements while compiling
+ edit_makefiles
+
emake MOZ_THUNDERBIRD=1 || die
# Build the enigmail plugin