summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Scherbaum <dertobi123@gentoo.org>2008-12-27 17:09:00 +0000
committerTobias Scherbaum <dertobi123@gentoo.org>2008-12-27 17:09:00 +0000
commit0791d297122258faeb6138b6c19a1ae9dd26a646 (patch)
tree06b96724ec5bd220188fae2abd2f292cf30a5e51 /mail-filter/procmail
parentversion bump by Thomas Beierlein (diff)
downloadgentoo-2-0791d297122258faeb6138b6c19a1ae9dd26a646.tar.gz
gentoo-2-0791d297122258faeb6138b6c19a1ae9dd26a646.tar.bz2
gentoo-2-0791d297122258faeb6138b6c19a1ae9dd26a646.zip
Add note to configure a default mail storage location when using maildir (#249579), do not strip binaries and respect LDFLAGS (#249202)
(Portage version: 2.2_rc19/cvs/Linux 2.6.25-gentoo-r7 x86_64)
Diffstat (limited to 'mail-filter/procmail')
-rw-r--r--mail-filter/procmail/ChangeLog9
-rw-r--r--mail-filter/procmail/procmail-3.22-r10.ebuild100
2 files changed, 108 insertions, 1 deletions
diff --git a/mail-filter/procmail/ChangeLog b/mail-filter/procmail/ChangeLog
index 566138991902..c35cd39bfaf1 100644
--- a/mail-filter/procmail/ChangeLog
+++ b/mail-filter/procmail/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for mail-filter/procmail
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-filter/procmail/ChangeLog,v 1.35 2008/12/02 06:51:20 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/procmail/ChangeLog,v 1.36 2008/12/27 17:09:00 dertobi123 Exp $
+
+*procmail-3.22-r10 (27 Dec 2008)
+
+ 27 Dec 2008; Tobias Scherbaum <dertobi123@gentoo.org>
+ +procmail-3.22-r10.ebuild:
+ Add note to configure a default mail storage location when using maildir
+ (#249579), do not strip binaries and respect LDFLAGS (#249202)
02 Dec 2008; Jeroen Roovers <jer@gentoo.org> procmail-3.22-r9.ebuild:
Stable for HPPA (bug #233595).
diff --git a/mail-filter/procmail/procmail-3.22-r10.ebuild b/mail-filter/procmail/procmail-3.22-r10.ebuild
new file mode 100644
index 000000000000..0b2f8dac5fff
--- /dev/null
+++ b/mail-filter/procmail/procmail-3.22-r10.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/procmail/procmail-3.22-r10.ebuild,v 1.1 2008/12/27 17:09:00 dertobi123 Exp $
+
+inherit eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="Mail delivery agent/filter"
+HOMEPAGE="http://www.procmail.org/"
+SRC_URI="http://www.procmail.org/${P}.tar.gz"
+
+LICENSE="|| ( Artistic GPL-2 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="mbox selinux"
+
+DEPEND="virtual/libc virtual/mta"
+RDEPEND="virtual/libc
+ selinux? ( sec-policy/selinux-procmail )"
+PROVIDE="virtual/mda"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # disable flock, using both fcntl and flock style locking
+ # doesn't work with NFS with 2.6.17+ kernels, bug #156493
+
+ sed -e "s:/\*#define NO_flock_LOCK:#define NO_flock_LOCK:" \
+ -i config.h || die "sed failed"
+
+ if ! use mbox ; then
+ echo "# Use maildir-style mailbox in user's home directory" > "${S}"/procmailrc
+ echo 'DEFAULT=$HOME/.maildir/' >> "${S}"/procmailrc
+ cd "${S}"
+ epatch "${FILESDIR}/gentoo-maildir3.diff"
+ else
+ echo '# Use mbox-style mailbox in /var/spool/mail' > "${S}"/procmailrc
+ echo 'DEFAULT=/var/spool/mail/$LOGNAME' >> "${S}"/procmailrc
+ fi
+
+ # Do not use lazy bindings on lockfile and procmail
+ epatch "${FILESDIR}/${PN}-lazy-bindings.diff"
+
+ # Fix for bug #102340
+ epatch "${FILESDIR}/${PN}-comsat-segfault.diff"
+
+ # Fix for bug #119890
+ epatch "${FILESDIR}/${PN}-maxprocs-fix.diff"
+
+ # Fix for bug #200006
+ epatch "${FILESDIR}/${PN}-pipealloc.diff"
+}
+
+src_compile() {
+ # -finline-functions (implied by -O3) leaves strstr() in an infinite loop.
+ # To work around this, we append -fno-inline-functions to CFLAGS
+ append-flags -fno-inline-functions
+
+ sed -e "s:CFLAGS0 = -O:CFLAGS0 = ${CFLAGS}:" \
+ -e "s:LDFLAGS0= -s:LDFLAGS0 = ${LDFLAGS}:" \
+ -e "s:LOCKINGTEST=__defaults__:#LOCKINGTEST=__defaults__:" \
+ -e "s:#LOCKINGTEST=/tmp:LOCKINGTEST=/tmp:" \
+ -i Makefile || die "sed failed"
+
+ emake CC="$(tc-getCC)" || die
+}
+
+src_install() {
+ cd "${S}"/new
+ insinto /usr/bin
+ insopts -m 6755
+ doins procmail || die
+
+ doins lockfile || die
+ fowners root:mail /usr/bin/lockfile
+ fperms 2775 /usr/bin/lockfile
+
+ dobin formail mailstat || die
+ insopts -m 0644
+
+ doman *.1 *.5
+
+ cd "${S}"
+ dodoc FAQ FEATURES HISTORY INSTALL KNOWN_BUGS README
+
+ insinto /etc
+ doins procmailrc || die
+
+ docinto examples
+ dodoc examples/*
+}
+
+pkg_postinst() {
+ if ! use mbox ; then
+ elog "Starting with mail-filter/procmail-3.22-r9 you'll need to ensure"
+ elog "that you configure a mail storage location using DEFAULT in"
+ elog "/etc/procmailrc, for example:"
+ elog "\tDEFAULT=\$HOME/.maildir/"
+ fi
+}