summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWolfram Schlich <wschlich@gentoo.org>2005-03-12 23:36:36 +0000
committerWolfram Schlich <wschlich@gentoo.org>2005-03-12 23:36:36 +0000
commitb48835a1a3334c2469eb4516e9194076c1713774 (patch)
treed381a9205375a282f1b8a2eb40b397ebce1aa827 /media-gfx/dcraw/dcraw-7.02.ebuild
parentfix ChangeLog typo (diff)
downloadgentoo-2-b48835a1a3334c2469eb4516e9194076c1713774.tar.gz
gentoo-2-b48835a1a3334c2469eb4516e9194076c1713774.tar.bz2
gentoo-2-b48835a1a3334c2469eb4516e9194076c1713774.zip
version bump
(Portage version: 2.0.51-r14)
Diffstat (limited to 'media-gfx/dcraw/dcraw-7.02.ebuild')
-rw-r--r--media-gfx/dcraw/dcraw-7.02.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/media-gfx/dcraw/dcraw-7.02.ebuild b/media-gfx/dcraw/dcraw-7.02.ebuild
new file mode 100644
index 000000000000..d5055b126957
--- /dev/null
+++ b/media-gfx/dcraw/dcraw-7.02.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/dcraw/dcraw-7.02.ebuild,v 1.1 2005/03/12 23:36:36 wschlich Exp $
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="Converts the native (RAW) format of various digital cameras into netpbm portable pixmap (.ppm) image"
+HOMEPAGE="http://www.cybercom.net/~dcoffin/dcraw/"
+SRC_URI="http://dev.gentoo.org/~wschlich/src/media-gfx/dcraw/${P}.tar.bz2"
+LICENSE="freedist GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~ppc ~sparc"
+IUSE="debug"
+DEPEND="virtual/libc >=media-libs/jpeg-6b"
+RDEPEND="media-libs/netpbm"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+}
+
+src_compile() {
+ use debug && {
+ append-flags -O -ggdb -DDEBUG
+ RESTRICT="${RESTRICT} nostrip"
+ }
+ emake || die "make failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc doc/conversion-examples.txt doc/fujiturn-usage.txt doc/dcwrap
+}
+
+pkg_postinst() {
+ einfo ""
+ einfo "See conversion-examples.txt.gz on how to convert"
+ einfo "the PPM files produced by dcraw to other image formats."
+ einfo ""
+ ewarn "The functionality of the external program 'fujiturn' was"
+ ewarn "incoporated into dcraw and is automatically used now."
+ einfo ""
+ einfo "There's an example wrapper script included called 'dcwrap'."
+ einfo ""
+ einfo "This package also includes 'dcparse', which extracts"
+ einfo "thumbnail images (preferably JPEGs) from any raw digital"
+ einfo "camera formats that have them, and shows table contents."
+ einfo ""
+}