summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDenis Dupeyron <calchan@gentoo.org>2008-02-19 10:06:37 +0000
committerDenis Dupeyron <calchan@gentoo.org>2008-02-19 10:06:37 +0000
commit0fb02847c3111fad4c723cb7e5b48f22f7090fd0 (patch)
tree1534914967b766484c6fbff4205dc31b86ae2c5d /media-gfx/f-spot
parentVersion bump, bug 207968, reported by Craig Bradney <cbradney AT zip.com.au> ... (diff)
downloadgentoo-2-0fb02847c3111fad4c723cb7e5b48f22f7090fd0.tar.gz
gentoo-2-0fb02847c3111fad4c723cb7e5b48f22f7090fd0.tar.bz2
gentoo-2-0fb02847c3111fad4c723cb7e5b48f22f7090fd0.zip
Version bump.
(Portage version: 2.1.4.4)
Diffstat (limited to 'media-gfx/f-spot')
-rw-r--r--media-gfx/f-spot/ChangeLog8
-rw-r--r--media-gfx/f-spot/f-spot-0.4.2.ebuild56
-rw-r--r--media-gfx/f-spot/files/f-spot-0.4.2-color-adjust.patch55
3 files changed, 118 insertions, 1 deletions
diff --git a/media-gfx/f-spot/ChangeLog b/media-gfx/f-spot/ChangeLog
index ee4fb41309c8..0e2333923588 100644
--- a/media-gfx/f-spot/ChangeLog
+++ b/media-gfx/f-spot/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-gfx/f-spot
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/f-spot/ChangeLog,v 1.26 2008/01/04 14:47:42 calchan Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/f-spot/ChangeLog,v 1.27 2008/02/19 10:06:36 calchan Exp $
+
+*f-spot-0.4.2 (19 Feb 2008)
+
+ 19 Feb 2008; Denis Dupeyron <calchan@gentoo.org>
+ +files/f-spot-0.4.2-color-adjust.patch, +f-spot-0.4.2.ebuild:
+ Version bump.
04 Jan 2008; Denis Dupeyron <calchan@gentoo.org> f-spot-0.4.1.ebuild:
Disabled tests, thanks to Dustin Surawicz (see bug #203566).
diff --git a/media-gfx/f-spot/f-spot-0.4.2.ebuild b/media-gfx/f-spot/f-spot-0.4.2.ebuild
new file mode 100644
index 000000000000..edd35b7caaa3
--- /dev/null
+++ b/media-gfx/f-spot/f-spot-0.4.2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/f-spot/f-spot-0.4.2.ebuild,v 1.1 2008/02/19 10:06:36 calchan Exp $
+
+inherit gnome2 mono autotools
+
+DESCRIPTION="Personal photo management application for the gnome desktop"
+HOMEPAGE="http://f-spot.org"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/mono-1.1.10
+ >=dev-libs/dbus-glib-0.71
+ >=dev-libs/glib-2
+ >=x11-libs/gtk+-2.6
+ >=dev-dotnet/gtk-sharp-2.8
+ >=dev-dotnet/dbus-sharp-0.4.2
+ >=dev-dotnet/dbus-glib-sharp-0.3.0
+ >=dev-dotnet/gtkhtml-sharp-2.7
+ >=dev-dotnet/gconf-sharp-2.7
+ >=dev-dotnet/glade-sharp-2.7
+ >=dev-dotnet/gnomevfs-sharp-2.7
+ >=gnome-base/libgnome-2.2
+ >=gnome-base/libgnomeui-2.2
+ >=media-libs/libexif-0.6.16
+ <media-libs/libexif-0.7.0
+ >=media-libs/libgphoto2-2.1.4
+ >=media-libs/lcms-1.15
+ media-libs/jpeg
+ >=dev-db/sqlite-3"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ >=dev-util/intltool-0.29"
+
+DOCS="AUTHORS ChangeLog MAINTAINERS NEWS README"
+
+MAKEOPTS="${MAKEOPTS} -j1"
+
+# See bug #203566
+RESTRICT="test"
+
+src_unpack() {
+ gnome2_src_unpack
+ cd "${S}"
+
+ # Fix http://bugzilla.gnome.org/show_bug.cgi?id=517193
+ epatch "${FILESDIR}"/${P}-color-adjust.patch
+
+ # Disable Beagle
+ sed -i -e '/PKG_CHECK_MODULES.*BEAGLE/,/AC_SUBST.*LINK_BEAGLE/ d' configure.in || die "sed failed"
+
+ eautoreconf
+}
diff --git a/media-gfx/f-spot/files/f-spot-0.4.2-color-adjust.patch b/media-gfx/f-spot/files/f-spot-0.4.2-color-adjust.patch
new file mode 100644
index 000000000000..d0550e874e0e
--- /dev/null
+++ b/media-gfx/f-spot/files/f-spot-0.4.2-color-adjust.patch
@@ -0,0 +1,55 @@
+Index: src/Makefile.am
+===================================================================
+--- src/Makefile.am (revision 3689)
++++ src/Makefile.am (working copy)
+@@ -385,7 +385,7 @@
+ $(F_SPOT_DISTRESOURCES) \
+ f-spot.exe.config.in \
+ f-spot.in \
+- Cms.dll.config
++ Cms.dll.config.in
+
+ CLEANFILES = \
+ f-spot.exe.config \
+@@ -399,7 +399,8 @@
+ FSpot.Query.dll \
+ FSpot.Query.dll.mdb \
+ FSpot.Core.dll.mdb \
+- FSpot.Core.dll
++ FSpot.Core.dll \
++ Cms.dll.config
+
+
+ DISTCLEANFILES = \
+Index: src/Cms.dll.config
+===================================================================
+--- src/Cms.dll.config (revision 3689)
++++ src/Cms.dll.config (working copy)
+@@ -1,4 +0,0 @@
+-<configuration>
+- <dllmap dll="liblcms-1.0.0.dll" target="liblcms.so.1"/>
+-</configuration>
+-
+Index: src/Cms.dll.config.in
+===================================================================
+--- src/Cms.dll.config.in (revision 0)
++++ src/Cms.dll.config.in (revision 0)
+@@ -0,0 +1,5 @@
++<configuration>
++ <dllmap dll="liblcms-1.0.0.dll" target="liblcms.so.1"/>
++ <dllmap dll="libfspot" target="@expanded_libdir@/f-spot/libfspot.so.0"/>
++</configuration>
++
+Index: configure.in
+===================================================================
+--- configure.in (revision 3689)
++++ configure.in (working copy)
+@@ -292,6 +292,7 @@
+ src/Core/Defines.cs
+ src/AssemblyInfo.cs
+ src/f-spot.exe.config
++src/Cms.dll.config
+ src/Makefile
+ glitz-sharp/Makefile
+ glitz-sharp/src/Makefile
+