summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-02-22 08:24:00 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-02-22 08:24:00 +0000
commit058103b3e5a675a7444bbd2aad6ada4bbb1f4be7 (patch)
tree5f865c5277fdfa712d2bdaa0ccc43c6cb879f2ec /media-gfx/feh
parentstable x86, bug 305733 (diff)
downloadgentoo-2-058103b3e5a675a7444bbd2aad6ada4bbb1f4be7.tar.gz
gentoo-2-058103b3e5a675a7444bbd2aad6ada4bbb1f4be7.tar.bz2
gentoo-2-058103b3e5a675a7444bbd2aad6ada4bbb1f4be7.zip
Version bump.
(Portage version: 2.2_rc63/cvs/Linux x86_64)
Diffstat (limited to 'media-gfx/feh')
-rw-r--r--media-gfx/feh/ChangeLog9
-rw-r--r--media-gfx/feh/feh-1.3.5.ebuild48
2 files changed, 55 insertions, 2 deletions
diff --git a/media-gfx/feh/ChangeLog b/media-gfx/feh/ChangeLog
index fa6e265b33ed..1d42a5f46bfa 100644
--- a/media-gfx/feh/ChangeLog
+++ b/media-gfx/feh/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-gfx/feh
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/feh/ChangeLog,v 1.32 2008/08/09 12:34:17 maekke Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/feh/ChangeLog,v 1.33 2010/02/22 08:24:00 ssuominen Exp $
+
+*feh-1.3.5 (22 Feb 2010)
+
+ 22 Feb 2010; Samuli Suominen <ssuominen@gentoo.org> +feh-1.3.5.ebuild:
+ Version bump.
09 Aug 2008; Markus Meier <maekke@gentoo.org> feh-1.3.4.ebuild:
block <sci-astronomy/xephem-3.7.3 as this version is fixed, bug #224705
diff --git a/media-gfx/feh/feh-1.3.5.ebuild b/media-gfx/feh/feh-1.3.5.ebuild
new file mode 100644
index 000000000000..1fa58555c7ff
--- /dev/null
+++ b/media-gfx/feh/feh-1.3.5.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/feh/feh-1.3.5.ebuild,v 1.1 2010/02/22 08:24:00 ssuominen Exp $
+
+EAPI=2
+inherit autotools eutils
+
+DESCRIPTION="A fast, lightweight imageviewer using imlib2"
+HOMEPAGE="https://derf.homelinux.org/~derf/projects/feh/"
+SRC_URI="mirror://debian/pool/main/f/${PN}/${PN}_${PV}.orig.tar.bz2"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="xinerama"
+
+RDEPEND="!<sci-astronomy/xephem-3.7.3
+ >=media-libs/giblib-1.2.4
+ >=media-libs/imlib2-1.0.0
+ >=media-libs/jpeg-6b:0
+ media-libs/libpng
+ x11-libs/libX11
+ x11-libs/libXext
+ xinerama? ( x11-libs/libXinerama )
+ x11-libs/libXt"
+DEPEND="${RDEPEND}
+ x11-proto/xproto
+ x11-proto/xineramaproto"
+
+src_prepare() {
+ rm -f configure.ac
+ epatch "${FILESDIR}"/${PN}-1.3.4-xinerama.patch \
+ "${FILESDIR}"/${PN}-1.3.4-headers.patch
+ sed -i -e "/^docsdir =/s:doc/feh:share/doc/${PF}:" Makefile.am || die
+ # the bundled autotool code was generated with automake-1.4
+ # but there's no reason to restrict to that version #141427
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable xinerama)
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+ dodoc AUTHORS ChangeLog README TODO
+}