summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2014-08-03 08:04:02 +0000
committerAndrey Grozin <grozin@gentoo.org>2014-08-03 08:04:02 +0000
commit6e0b4d1ef7d5500b2bd623bdd660600a9dc48d71 (patch)
treed46da67afad7250462e967edad4c519cd0cdcd3b /media-gfx/fotoxx/fotoxx-14.08.ebuild
parentRemove old (diff)
downloadgentoo-2-6e0b4d1ef7d5500b2bd623bdd660600a9dc48d71.tar.gz
gentoo-2-6e0b4d1ef7d5500b2bd623bdd660600a9dc48d71.tar.bz2
gentoo-2-6e0b4d1ef7d5500b2bd623bdd660600a9dc48d71.zip
Version bump
(Portage version: 2.2.10/cvs/Linux i686, signed Manifest commit with key 0x3AFFCE974D34BD8C!)
Diffstat (limited to 'media-gfx/fotoxx/fotoxx-14.08.ebuild')
-rw-r--r--media-gfx/fotoxx/fotoxx-14.08.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/media-gfx/fotoxx/fotoxx-14.08.ebuild b/media-gfx/fotoxx/fotoxx-14.08.ebuild
new file mode 100644
index 000000000000..b1ffd26cf8f8
--- /dev/null
+++ b/media-gfx/fotoxx/fotoxx-14.08.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/fotoxx/fotoxx-14.08.ebuild,v 1.1 2014/08/03 08:04:02 grozin Exp $
+
+EAPI=4
+
+inherit eutils toolchain-funcs fdo-mime
+
+DESCRIPTION="Program for improving image files made with a digital camera"
+HOMEPAGE="http://www.kornelix.com/fotoxx.html"
+SRC_URI="http://www.kornelix.com/uploads/1/3/0/3/13035936/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ x11-libs/gtk+:3
+ media-libs/libpng
+ media-libs/tiff
+ media-libs/lcms:2"
+RDEPEND="${DEPEND}
+ media-libs/exiftool
+ media-gfx/ufraw[gtk]
+ media-gfx/dcraw
+ x11-misc/xdg-utils"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PF}.patch
+}
+
+src_compile() {
+ tc-export CXX
+ emake
+}
+
+src_install() {
+ # For the Help menu items to work, *.html must be in /usr/share/doc/${PF},
+ # and README, changelog, translations, edit-menus, KB-shortcuts must not be compressed
+ emake DESTDIR="${D}" install
+ newmenu desktop ${PN}.desktop
+ rm -f "${D}"/usr/share/doc/${PF}/*.man
+ docompress -x /usr/share/doc
+}
+
+pkg_postinst() {
+ fdo-mime_mime_database_update
+ fdo-mime_desktop_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}