summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2011-11-25 12:34:35 +0000
committerMichael Weber <xmw@gentoo.org>2011-11-25 12:34:35 +0000
commitce0d9765558aedba7d2f05c82e3ca97c3eab3dd8 (patch)
tree1a063ea5d525d80b0bbc43971661eed4bb00eefa /media-gfx/gifsicle/gifsicle-1.64.ebuild
parentVersion bump for beta channel release. Remove old. (diff)
downloadgentoo-2-ce0d9765558aedba7d2f05c82e3ca97c3eab3dd8.tar.gz
gentoo-2-ce0d9765558aedba7d2f05c82e3ca97c3eab3dd8.tar.bz2
gentoo-2-ce0d9765558aedba7d2f05c82e3ca97c3eab3dd8.zip
Version bump
(Portage version: 2.1.10.11/cvs/Linux x86_64)
Diffstat (limited to 'media-gfx/gifsicle/gifsicle-1.64.ebuild')
-rw-r--r--media-gfx/gifsicle/gifsicle-1.64.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/media-gfx/gifsicle/gifsicle-1.64.ebuild b/media-gfx/gifsicle/gifsicle-1.64.ebuild
new file mode 100644
index 000000000000..78e513273df0
--- /dev/null
+++ b/media-gfx/gifsicle/gifsicle-1.64.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/gifsicle/gifsicle-1.64.ebuild,v 1.1 2011/11/25 12:34:35 xmw Exp $
+
+EAPI=4
+
+DESCRIPTION="A command-line tool for creating, editing, and getting information about GIF images and animations"
+HOMEPAGE="http://www.lcdf.org/~eddietwo/gifsicle/"
+SRC_URI="http://www.lcdf.org/~eddietwo/gifsicle/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="X"
+
+RDEPEND="X? ( x11-libs/libX11
+ x11-libs/libXt )"
+DEPEND="${RDEPEND}
+ X? ( x11-proto/xproto )"
+
+src_configure() {
+ local myconf
+ use X || myconf="--disable-gifview"
+
+ econf ${myconf}
+}