summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2014-10-26 17:15:39 +0000
committerTim Harder <radhermit@gentoo.org>2014-10-26 17:15:39 +0000
commit48a69ea3358c51350263ae885d32b6e6184f45dc (patch)
tree31bc5629ed1c8fc009beb764a1a1eebcbc67d2e6 /media-gfx/rawtherapee
parentremove 0.11.0, keep three (diff)
downloadgentoo-2-48a69ea3358c51350263ae885d32b6e6184f45dc.tar.gz
gentoo-2-48a69ea3358c51350263ae885d32b6e6184f45dc.tar.bz2
gentoo-2-48a69ea3358c51350263ae885d32b6e6184f45dc.zip
Version bump, define CACHE_NAME_SUFFIX to use a static config location (bug #523022).
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'media-gfx/rawtherapee')
-rw-r--r--media-gfx/rawtherapee/ChangeLog8
-rw-r--r--media-gfx/rawtherapee/rawtherapee-4.2.ebuild52
2 files changed, 59 insertions, 1 deletions
diff --git a/media-gfx/rawtherapee/ChangeLog b/media-gfx/rawtherapee/ChangeLog
index b1de5e06e4c5..19c8d2fd0516 100644
--- a/media-gfx/rawtherapee/ChangeLog
+++ b/media-gfx/rawtherapee/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-gfx/rawtherapee
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/rawtherapee/ChangeLog,v 1.16 2014/06/11 08:30:28 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/rawtherapee/ChangeLog,v 1.17 2014/10/26 17:15:39 radhermit Exp $
+
+*rawtherapee-4.2 (26 Oct 2014)
+
+ 26 Oct 2014; Tim Harder <radhermit@gentoo.org> +rawtherapee-4.2.ebuild:
+ Version bump, define CACHE_NAME_SUFFIX to use a static config location (bug
+ #523022).
*rawtherapee-4.1 (11 Jun 2014)
diff --git a/media-gfx/rawtherapee/rawtherapee-4.2.ebuild b/media-gfx/rawtherapee/rawtherapee-4.2.ebuild
new file mode 100644
index 000000000000..bd7222fd64a6
--- /dev/null
+++ b/media-gfx/rawtherapee/rawtherapee-4.2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/rawtherapee/rawtherapee-4.2.ebuild,v 1.1 2014/10/26 17:15:39 radhermit Exp $
+
+EAPI=5
+
+inherit cmake-utils toolchain-funcs
+
+DESCRIPTION="A powerful cross-platform raw image processing program"
+HOMEPAGE="http://www.rawtherapee.com/"
+SRC_URI="http://rawtherapee.com/shared/source/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="bzip2 openmp"
+
+RDEPEND="bzip2? ( app-arch/bzip2 )
+ >=x11-libs/gtk+-2.24.18:2
+ >=dev-cpp/gtkmm-2.12:2.4
+ >=dev-cpp/glibmm-2.16:2
+ dev-libs/expat
+ dev-libs/libsigc++:2
+ media-libs/libcanberra[gtk]
+ media-libs/tiff
+ media-libs/libpng
+ media-libs/libiptcdata
+ media-libs/lcms:2
+ sci-libs/fftw:3.0
+ sys-libs/zlib
+ virtual/jpeg"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils
+ virtual/pkgconfig"
+
+pkg_pretend() {
+ if use openmp ; then
+ tc-has-openmp || die "Please switch to an openmp compatible compiler"
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use openmp OPTION_OMP)
+ $(cmake-utils_use_with bzip2 BZIP)
+ -DDOCDIR=/usr/share/doc/${PF}
+ -DCREDITSDIR=/usr/share/${PN}
+ -DLICENCEDIR=/usr/share/${PN}
+ -DCACHE_NAME_SUFFIX=""
+ )
+ cmake-utils_src_configure
+}