summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2002-06-22 08:40:51 +0000
committerRyan Phillips <rphillips@gentoo.org>2002-06-22 08:40:51 +0000
commitaa4dabd324cbf4ebc02514e193b2a23507fc573e (patch)
tree6ce8281bb9d971cce7e415a485818977d680e220 /media-gfx/sane-backends
parentnew ebuild - hddtemp: HDD temperature reporting utility (diff)
downloadgentoo-2-aa4dabd324cbf4ebc02514e193b2a23507fc573e.tar.gz
gentoo-2-aa4dabd324cbf4ebc02514e193b2a23507fc573e.tar.bz2
gentoo-2-aa4dabd324cbf4ebc02514e193b2a23507fc573e.zip
new version
Diffstat (limited to 'media-gfx/sane-backends')
-rw-r--r--media-gfx/sane-backends/ChangeLog17
-rw-r--r--media-gfx/sane-backends/files/digest-sane-backends-1.0.81
-rw-r--r--media-gfx/sane-backends/sane-backends-1.0.8.ebuild48
3 files changed, 56 insertions, 10 deletions
diff --git a/media-gfx/sane-backends/ChangeLog b/media-gfx/sane-backends/ChangeLog
index 27580779f233..fde9a4e1bb99 100644
--- a/media-gfx/sane-backends/ChangeLog
+++ b/media-gfx/sane-backends/ChangeLog
@@ -1,26 +1,23 @@
# ChangeLog for media-gfx/sane-backends
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/sane-backends/ChangeLog,v 1.4 2002/04/14 07:07:09 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/sane-backends/ChangeLog,v 1.5 2002/06/22 08:40:51 rphillips Exp $
-*sane-backends-1.0.7-r1 (13 Apr 2002)
+*sane-backends-1.0.8 (22 Jun 2002)
- 13 Apr 2002; Seemant Kulleen <seemant@gentoo.org>
- sane-backends-1.0.7-r1.ebuild files/digest-sane-backends-1.0.7-r1 :
+ 22 Jun 2002; Ryan Phillips <rphillips@gentoo.org> sane-backends-1.0.8.ebuild
+ files/digest-sane-backends-1.0.8
- Added a pkg_postinst() function to add the SANE_CONFIG_DIR environment
- variable. This solution was found by the bug reporter of bug #1595,
- MvOstheim@web.de (Michael v.Ostheim)
+ New version
-=======
*sane-backends-1.0.7-r1 (13 Apr 2002)
13 Apr 2002; Seemant Kulleen <seemant@gentoo.org>
sane-backends-1.0.7-r1.ebuild files/digest-sane-backends-1.0.7-r1 :
Added a pkg_postinst() function to add the SANE_CONFIG_DIR environment
- variable.
+ variable. This solution was found by the bug reporter of bug #1595,
+ MvOstheim@web.de (Michael v.Ostheim)
->>>>>>> 1.3
*sane-backends-1.0.7 (2 Mar 2002)
2 Mar 2002; Chris Houser <chouser@gentoo.org>
diff --git a/media-gfx/sane-backends/files/digest-sane-backends-1.0.8 b/media-gfx/sane-backends/files/digest-sane-backends-1.0.8
new file mode 100644
index 000000000000..d53f0d86d97c
--- /dev/null
+++ b/media-gfx/sane-backends/files/digest-sane-backends-1.0.8
@@ -0,0 +1 @@
+MD5 10785bf9a87e0f45ad445e34a8529a3d sane-backends-1.0.8.tar.gz 2169657
diff --git a/media-gfx/sane-backends/sane-backends-1.0.8.ebuild b/media-gfx/sane-backends/sane-backends-1.0.8.ebuild
new file mode 100644
index 000000000000..286da2125ce5
--- /dev/null
+++ b/media-gfx/sane-backends/sane-backends-1.0.8.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Desktop Team <desktop@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/sane-backends/sane-backends-1.0.8.ebuild,v 1.1 2002/06/22 08:40:51 rphillips Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Scanner Access Now Easy - Backends"
+SRC_URI="ftp://ftp.mostang.com/pub/sane/sane-$PV/$P.tar.gz"
+HOMEPAGE="http://www.mostang.com/sane/"
+
+DEPEND=">=media-libs/jpeg-6b"
+
+src_unpack() {
+ unpack ${A}
+ cp ${FILESDIR}/linux_sg3_err.h ${S}/sanei
+
+ #only generate the .ps and not the fonts
+ cp ${S}/doc/Makefile.in ${S}/doc/Makefile.in.orig
+ sed -e 's:dvips sane.dvi -o sane.ps:dvips sane.dvi -o -M0 sane.ps:' \
+ ${S}/doc/Makefile.in.orig > ${S}/doc/Makefile.in
+}
+
+src_compile() {
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --host=${CHOST} || die
+ make || die
+}
+
+src_install () {
+ make prefix=${D}/usr \
+ sysconfdir=${D}/etc \
+ mandir=${D}/usr/share/man \
+ docdir=${D}/usr/share/doc/${PF} \
+ install || die
+
+ docinto backend
+ cd backend
+ dodoc GUIDE *.README *.BUGS *.CHANGES *.FAQ *.TODO
+}
+
+
+pkg_postinst() {
+
+ echo "SANE_CONFIG_DIR=/etc/sane.d" > /etc/env.d/30sane
+
+}