summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2007-04-09 11:11:48 +0000
committerMichael Januszewski <spock@gentoo.org>2007-04-09 11:11:48 +0000
commit82bc632a23afd68a7c4c2b238414ce54a092464d (patch)
tree34ed47e04ea583d05e7e1be5b56c92dcf2a5c121 /media-gfx/splashutils
parentFixing the built_with_use for apache-2.0.59, since apache-2.0 only supports a... (diff)
downloadgentoo-2-82bc632a23afd68a7c4c2b238414ce54a092464d.tar.gz
gentoo-2-82bc632a23afd68a7c4c2b238414ce54a092464d.tar.bz2
gentoo-2-82bc632a23afd68a7c4c2b238414ce54a092464d.zip
Fix bug #173830.
(Portage version: 2.1.2.3)
Diffstat (limited to 'media-gfx/splashutils')
-rw-r--r--media-gfx/splashutils/ChangeLog7
-rw-r--r--media-gfx/splashutils/files/splashutils-gentoo-0.1.14-stat.patch23
-rw-r--r--media-gfx/splashutils/splashutils-1.1.9.10-r1.ebuild5
3 files changed, 32 insertions, 3 deletions
diff --git a/media-gfx/splashutils/ChangeLog b/media-gfx/splashutils/ChangeLog
index 0e8627649955..a8323fbb4db2 100644
--- a/media-gfx/splashutils/ChangeLog
+++ b/media-gfx/splashutils/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-gfx/splashutils
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/splashutils/ChangeLog,v 1.80 2007/04/06 09:02:01 spock Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/splashutils/ChangeLog,v 1.81 2007/04/09 11:11:48 spock Exp $
+
+ 09 Apr 2007; Michał Januszewski <spock@gentoo.org>
+ +files/splashutils-gentoo-0.1.14-stat.patch,
+ splashutils-1.1.9.10-r1.ebuild:
+ Fix bug #173830.
06 Apr 2007; Michał Januszewski <spock@gentoo.org>
+files/splashutils-1.4-remove-debug-msgs.patch, splashutils-1.4.ebuild:
diff --git a/media-gfx/splashutils/files/splashutils-gentoo-0.1.14-stat.patch b/media-gfx/splashutils/files/splashutils-gentoo-0.1.14-stat.patch
new file mode 100644
index 000000000000..6e8ef66a1426
--- /dev/null
+++ b/media-gfx/splashutils/files/splashutils-gentoo-0.1.14-stat.patch
@@ -0,0 +1,23 @@
+diff -Naurp splashutils-gentoo-0.1.14-orig/splash-functions.sh splashutils-gentoo-0.1.14/splash-functions.sh
+--- splashutils-gentoo-0.1.14-orig/splash-functions.sh 2007-04-09 12:45:01.000000000 +0200
++++ splashutils-gentoo-0.1.14/splash-functions.sh 2007-04-09 12:46:32.000000000 +0200
+@@ -207,7 +207,7 @@ splash_cache_prep() {
+
+ mount -n --move "${spl_tmpdir}" "${spl_cachedir}"
+
+- h=$(stat -c '%y' ${spl_cachedir}/deptree 2>/dev/null)
++ h=$(ls -ld --full-time ${spl_cachedir}/deptree | cut -f6,7,8 -d' ' 2>/dev/null)
+
+ # Point depscan.sh to our cachedir
+ spl_cache_depscan="yes" /sbin/depscan.sh -u
+@@ -226,8 +226,8 @@ splash_cache_prep() {
+ local lastlev timestamp
+ { read lastlev; read timestamp; } < ${spl_cachedir}/levels
+ if [[ "${lastlev}" != "${BOOTLEVEL}/${DEFAULTLEVEL}" || \
+- "${timestamp}" != "$(stat -c '%y' /etc/runlevels/${BOOTLEVEL})/$(stat -c '%y' /etc/runlevels/${DEFAULTLEVEL})" || \
+- "$(stat -c '%y' ${spl_cachedir}/deptree)" != "${h}" ]]; then
++ "${timestamp}" != "$(ls -ld --full-time /etc/runlevels/${BOOTLEVEL} | cut -f6,7,8 -d' ')/$(ls -ld --full-time /etc/runlevels/${DEFAULTLEVEL} | cut -f6,7,8 -d' ')" || \
++ "$(ls -ld --full-time ${spl_cachedir}/deptree | cut -f6,7,8 -d' ')" != "${h}" ]]; then
+ echo $(splash_svclist_update "start") > ${spl_cachedir}/svcs_start
+ fi
+ fi
diff --git a/media-gfx/splashutils/splashutils-1.1.9.10-r1.ebuild b/media-gfx/splashutils/splashutils-1.1.9.10-r1.ebuild
index 4d4af9214662..d23dadbad1af 100644
--- a/media-gfx/splashutils/splashutils-1.1.9.10-r1.ebuild
+++ b/media-gfx/splashutils/splashutils-1.1.9.10-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/splashutils/splashutils-1.1.9.10-r1.ebuild,v 1.8 2007/02/10 14:23:37 spock Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/splashutils/splashutils-1.1.9.10-r1.ebuild,v 1.9 2007/04/09 11:11:48 spock Exp $
inherit eutils multilib linux-mod
@@ -84,14 +84,15 @@ src_unpack() {
# Ensure that we call depscan with --svcdir
cd "${WORKDIR}/${GENTOOSPLASH}"
epatch "${FILESDIR}/splashutils-depscan.patch"
+ epatch ${FILESDIR}/splashutils-gentoo-0.1.14-stat.patch
mv ${WORKDIR}/{libpng-${V_PNG},jpeg-${V_JPEG},zlib-${V_ZLIB},freetype-${V_FT}} ${S}/libs
# We need to delete the Makefile and let it be rebuilt when splashutils
# is being configured. Either that, or we end up with a segfaulting kernel
# helper.
rm ${S}/libs/zlib-${V_ZLIB}/Makefile
- cd ${S}
+ cd ${S}
epatch ${FILESDIR}/${P}-ppc-2.6.14.patch
epatch ${FILESDIR}/${P}-makefile.patch
epatch ${FILESDIR}/${P}-2.6.18-vt-fix.patch